Jamo Outdoor I/O 8A2 speakers - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 10-10-2011, 07:50 AM - Thread Starter
Member
 
harleysilo's Avatar
 
Join Date: Sep 2007
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi everyone,

I've had a pair of these speakers for about 4.5 years mounted on my West facing deck under the eve. No direct rain, few hours of direct sunlight. Well about a month ago one blew. Took the cover off and you could clear see where it had cracked around the speaker surround. Took the cover off the other one and it had a small crack as well. Got out the receipt and called Jamo. Long story short a few weeks later a brand new set of I/O 8A2's arrived. I was extremely pleased that they honored their warranty (5 years) as I expected mine to be refurbished or another refurbished set sent in replacement. Did I mention these speakers sound GREAT? I wonder why the surrounds on both cracked? Any ideas?
harleysilo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-17-2011, 02:02 PM
Newbie
 
Bevostein's Avatar
 
Join Date: Mar 2006
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I would guess 4.5 years of outdoor exposure is what caused the cracking even it was under an eve.
Bevostein is offline  
Reply Outdoor Theaters

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off