Mitsubishi intermittent green & pink problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 01-24-2011, 09:04 AM - Thread Starter
Newbie
 
Stan Corrected's Avatar
 
Join Date: Jan 2006
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
WD73638 occasionally displays am image that is saturated green & pink. Seems to happen when I switch image sources (Ie. from DVD to DirecTV), or when first turned on.

I'm using HDMI (1.4) cables. Only 1 Input on the set is in use (the Denon receiver handles all inputs with one output).

If I switch the input on the Mits. to a different input, then back again, it corrects itself, but this is a pain.

Anyone know if this is common....what the issue might be...and if something like this will get worse over time?

Thanks.
Stan Corrected is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-24-2011, 11:05 AM
 
jet2233's Avatar
 
Join Date: Jan 2011
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the mits 60638 and mine turns green sometimes too. I think it has something to do with my 3d player cause it only turns green when I have the sony blu ray player on.
jet2233 is offline  
post #3 of 4 Old 01-24-2011, 12:44 PM - Thread Starter
Newbie
 
Stan Corrected's Avatar
 
Join Date: Jan 2006
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hmm, I may have missed an obvious step in the testing process - using a different HDMI input o the set.

I have now switched over to using Input 2, and, so far (fingers crossed), no problem!
I suppose the set could have a corrupt input?!?
Stan Corrected is offline  
post #4 of 4 Old 01-27-2011, 06:16 AM
Advanced Member
 
CIR-Engineering's Avatar
 
Join Date: Aug 2005
Location: Chicago USA & Berlin Germany
Posts: 880
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
You have a digital set and as such have posted in the wrong forum.

That being said, you are having an HDMI communications issue with respect to the HDMI info frame. Either the wrong data is beings sent from the source to the TV, the TV is reading the info frame incorrectly, or the data is being lost in transmission due to a cable incompatibility or switcher incompatibility (receiver).

The problem is the result of the source sending a color space that is either RGB, YCbCr 444, or YCbCr 422, and the TV is not using the same color space. From the description it sounds like the TV is using RGB and the source is using YCbCr 444 or 422 on different occasions (green or pink picture).

When you cycle inputs, you cause the TV to resend the EDID data and this is then read by the source again. The source sends the signal based on the re-EDID and the second time the TV picks up the correct color space.

This could also be a hotplug HDMI problem if you are switching inside a receiver while using the same HDMI input on the TV.

craigr

Precision Video Calibration
JETI Specbos 1211 Spectroradiometer
Klein K10-A Laboratory Grade Colorimeter
Quantum Data QD780 Multimedia Generator
ChromaPure Pro Color Calibration Software


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Craig Rounds

CIR-Engineering is offline  
Reply CRT Projectors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off