G90 parts - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 07-10-2012, 07:26 PM - Thread Starter
Newbie
 
sph007's Avatar
 
Join Date: Jul 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am a previous CRT g90 owner and have gone to the grey side but while cleaning out the basement today I ran across a couple of parts for the g90


a new output amp CAB board
and a new DC board
and lastly the BNC input card that plugs into the back - (taken out for MOOME card)


75 dollars plus shipping gets the lot


email sph007@embarqmail.com
sph007 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-18-2013, 10:11 AM
Newbie
 
wallyhawk's Avatar
 
Join Date: Jan 2013
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I realize this post is half a year old but do you still have any of this? I'm new to projectors and am trying to fix a really odd quirk mine has.
wallyhawk is offline  
post #3 of 5 Old 01-18-2013, 01:07 PM - Thread Starter
Newbie
 
sph007's Avatar
 
Join Date: Jul 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
sorry, parts are gone. I had a lot of time with the g90 and worked out a lot of problems trying to learn how to master it. What kind of problems are you having?
sph007 is offline  
post #4 of 5 Old 01-21-2013, 06:16 AM
Newbie
 
wallyhawk's Avatar
 
Join Date: Jan 2013
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The projector doesn't seem to like 480p resolution. Anything on that resolution gets a wrapping effect on the top of the screen. On any resolution any bright flashes cause the picture to flicker as well. Almost as if I am turning the projector off and on real fast but it doesnt make the sound like it is powering down and the fans keep spinning. I thought maybe the VIM card?

Any help is much appreciated. Once i fix the flicker i can worry about new tubes.
wallyhawk is offline  
post #5 of 5 Old 01-21-2013, 06:18 AM
Newbie
 
wallyhawk's Avatar
 
Join Date: Jan 2013
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Oh I forgot. All video sources are component and run through an integra receiver. I did try another model receiver and skipping the receiver altogether and the problem persisted.
wallyhawk is offline  
Reply CRT Projectors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off