ECP 4100 focus went screwy - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 2 Old 10-02-2012, 09:04 AM - Thread Starter
B.Mclaughlin's Avatar
Join Date: Dec 2005
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an ecp 4100 which has just recently went all fuzzy. The remote's focus can't restore it nor can the manual focus on the tubes. Also it is all 3 colours. I assume some board has gone bad but which one? I have an ecp 3100 for spares. Any ideas?
B.Mclaughlin is offline  
Sponsored Links
post #2 of 2 Old 10-02-2012, 07:50 PM
AVS Special Member
draganm's Avatar
Join Date: Dec 2002
Location: Brighton, Colorado
Posts: 4,788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 19
curt's the one you need to talk to, hopefully he kept some of his old ECP parts. At any rate sounds like the focus board on some of the ECP's can be problematic according to this guide he wrote

Marquee HD mod's Marquee Upgrade/re-build package
draganm is offline  
Sponsored Links
Reply CRT Projectors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off