Vidikron Vision One 9" CRT - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 04-30-2014, 06:30 AM - Thread Starter
KenB3's Avatar
Join Date: Apr 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Just a quick question, The unit powers up, Fan runs but NO bulbs

and no error lights are lit on the rear of the unit


any idea's ???


this is a great unit

KenB3 is offline  
Sponsored Links
Old 04-30-2014, 07:11 AM
AVS Addicted Member
Curt Palme's Avatar
Join Date: May 2000
Location: Vancouver, Canada
Posts: 18,399
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Liked: 32
Well, it's a great unit.. when it works. smile.gif

two common issues: Bad HVPS or bad H deflection board. There's no way to know which one it is without either swapping in another board, or testing your boards in another set. I can test/repair/replace those for you if you want to send them in. Email me at curtpalme at if you want more info.

Cheers! - CRT tech info -pro audio website
Curt Palme is offline  
Old 04-30-2014, 01:25 PM
AVS Special Member
draganm's Avatar
Join Date: Dec 2002
Location: Brighton, Colorado
Posts: 4,788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 19
post you general location (city-state) and there's a good chance there's a CRT guy near by that can help

Marquee HD mod's Marquee Upgrade/re-build package
draganm is offline  
Sponsored Links
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off