problem with Barcovision 508 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 05-05-2014, 10:05 AM - Thread Starter
Newbie
 
semajjames's Avatar
 
Join Date: May 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Hi having now found the right forum ,,,,,

       I have just got a Barcovision 508 projector and no nothing about them !!!!

 

So i connected it to my pc using the S video in put and powered it up expecting the screen to just light up ,,but it did not ,,,

 

so the stand by seems to work the led is red for off press stand buy button led goes green and more green leds on the internal boards light,,,,, the base of the tubes starts to glow grange but no screen

 

the pc seems to think is has a tv plugged in which seems fine 

 

BUT on the back there is 1 orange led lit the COINCIDENCE led this is lit so does anyone know what this led means or am i missing a step somewhere 

 

cheers  

semajjames is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-06-2014, 10:25 AM
AVS Special Member
 
draganm's Avatar
 
Join Date: Dec 2002
Location: Brighton, Colorado
Posts: 4,779
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 15
most likely a high voltage quad or splitter problem and even in todays market the prices on those parts used is 10X what your machine would be worth if it was running. Check CL and find something for free, look at this list for ideas

http://www.curtpalme.com/Projector_Rankings.shtm

Marquee HD mod's Marquee Upgrade/re-build package
draganm is offline  
Reply CRT Projectors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off