ECP - Green flicker - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 12-05-2006, 02:01 PM - Thread Starter
Senior Member
 
MrGogo's Avatar
 
Join Date: Nov 2004
Location: Montreal, QC
Posts: 295
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi guys ... got a problem

The green tube on my ECP 4000 flickers horizontal bands. The effect is that my picture turns a bit purpleish like the green isn't being driven as hard as it needs to be. It never stop displaying the picture completely its just gets dimmer in stripes across the screen. Sometimes its the whole tube face some times its horizontal bands that jump around. And the most annoying thing is that its very intermitant. Its will work fine for 30min then flicker like crazy for 2min then back to normal.

What I've done so far:
- Checked the input wires from my HTPC ... its good I wiggled the hell out of it and nothing happened.
- Removed the neckcard from the green and put it back on.
- Disconnected every wire from the G2 control to the neckcard and reseated them.
- Pulled all the circuit boards out of the back and reseated them

To do:
- Recheck connectors on green neck card.
- Pull power deflection module and reseat it (I don't think that could be it though)


Anyways crealy its some sort of loose connection along the signal path that intermitantly getting woozy any ideas where else I can fiddle. If any can thing of a spot where these connectios go bad that I haven't let me know.

Tnx for the help.
MrGogo is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-05-2006, 02:28 PM
Member
 
Qwal_will's Avatar
 
Join Date: Jan 2006
Location: Edmonton, Ab
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am no expert on these so can take this with a grain of salt


When I was adjusting my ECP 3100 I would get these strange flickering as well. What solved it for me was on the CRT socket the trim pots on the back of it were very touchy. I got some cleaner / lubricant and sprayed them. Worked the cleaner / lubricant in and then did the setup again. Has not given me issue since.

Again this may not work for you but did work for me.

Cheers,

Shawn
Qwal_will is offline  
post #3 of 7 Old 12-06-2006, 08:14 PM - Thread Starter
Senior Member
 
MrGogo's Avatar
 
Join Date: Nov 2004
Location: Montreal, QC
Posts: 295
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Bump,

Any other ideas from the experts?
MrGogo is offline  
post #4 of 7 Old 12-06-2006, 09:57 PM
AVS Special Member
 
pcCinema's Avatar
 
Join Date: May 2002
Location: Portland, Oregon
Posts: 4,982
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Swap the green neck board with blue or red and see if the problem moves to the other color. If so you need a new neckboard. I'll bet that's all it is.

Troy

The Non-Profit Home Theater Company will make your HTPC experience much easier.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
pcCinema is offline  
post #5 of 7 Old 01-28-2007, 06:46 PM - Thread Starter
Senior Member
 
MrGogo's Avatar
 
Join Date: Nov 2004
Location: Montreal, QC
Posts: 295
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey guys, thought I had fixed this but nope.

I replaced the neckboard on the green tube with one that I know works from another set. Didn't fix it, damn.

This is really starting to piss me off.

I have a full set of parts but I don't know what to swap.

Any suggestions?
MrGogo is offline  
post #6 of 7 Old 01-28-2007, 07:46 PM
Senior Member
 
Soapsuds's Avatar
 
Join Date: Sep 2005
Location: Mississauga, ON, Canada
Posts: 381
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
swap the grn RGBHV for another colour. If the problem moves with the cable, it's something in the HTPC chain. At least this will help narrow it down....


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Soapsuds is offline  
post #7 of 7 Old 01-29-2007, 04:00 PM - Thread Starter
Senior Member
 
MrGogo's Avatar
 
Join Date: Nov 2004
Location: Montreal, QC
Posts: 295
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Good call Soap.

But it affects the convergence grid too. I suppose it might be that I'll give it a try.

Thnx any one else with suggestions?
MrGogo is offline  
Reply CRT Projectors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off