Speakers cutting out- help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 11-10-2010, 08:11 PM - Thread Starter
Member
 
silbenny's Avatar
 
Join Date: May 2005
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,
I have a set of A/D/S components attached to an Eclipse amp that also powers an Infinity sub. For some odd reason my left tweets and mids speakers cut out at a lower volume now. It used to happen every once in a while but now its all the time. When I turn the volume up to a high level the speakers turn back on (sometimes distorted). However, lowering the volume again leads to no music . I've checked the wires and the crossover in the door and they seem fine. Any suggestions? Thanks in advance!
silbenny is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-11-2010, 06:21 AM
AVS Special Member
 
cubdenno's Avatar
 
Join Date: Dec 2008
Location: Cham-Bana Illinois
Posts: 1,441
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 54
First, at the amp, try swapping the left side to the right and vice versa to eliminate the amp. if your speakers (the same ones) are still cutting out, then the amp is fine. Now on to step 2.

If the same set of speakers still has the same problem, then start looking at swapping the passive crossovers.to eliminate them from the problem. Actually this is where I usually look. its just easier to swap the speaker wires at the amp to eliminate that as an issue first.

Hope this helps you narrow down the problem. My guess is the crossover has a bad component.

Good luck!

XBL-Steelhouse1

"No one wants to fight the naked guy."
cubdenno is offline  
post #3 of 3 Old 11-14-2010, 08:53 AM
AVS Special Member
 
bigbarney's Avatar
 
Join Date: Apr 2007
Location: Winnipeg, Canada
Posts: 2,565
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Liked: 54
You have a loose or corroded connection some where on the low line level side. Could be a wire... or somewhere on the board in the HU.
bigbarney is online now  
Reply Car Audio, Video, and Nav

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off