left channel on amp blown - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 01-27-2013, 02:06 PM - Thread Starter
Member
 
RusticR6's Avatar
 
Join Date: Nov 2003
Location: louisiana
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I bought a refurbished Fockford Fosgate T600-4 about a year ago. Polk Audio MM6501's for front and I bridged channel 3,4 for MM1040 sub. So about 6 months ago I get a ground whine in the left channel. Everything was fine until then. Now about 3 months later the left channel is pretty much gone.

I ran a dummy RCA cable to check each channel and its definately the amp's left channel.

The amp only had a 90 day warranty so I was gonna try to get it repaired thru RF.(on my dime im sure) But I wanted to ask if just based on the info I gave if you think it was a bad amp or something to do with the install. I mean its got to be a bum amp right? if its only the left channel and for 6 months I had no problems. Thats what im thinking anyway, but i dont want to swap it out with a good amp and burn that one too.

Not sure if i need to rip out my rca's or not either.

what do yall think


Edit: Ok so i borrowed an amp and slapped it in and everything works good. So its got to be the amp and that means i gotta buy an amp. poop.

Do What?
RusticR6 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-04-2013, 06:17 PM
Member
 
dictator92's Avatar
 
Join Date: Jan 2013
Location: Sc
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
It's a bad amp. Look at mb quart or something on car audio classifieds. 4channels are cheap used. Rockford is a too expensive for what you need.
dictator92 is offline  
Reply Car Audio, Video, and Nav

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off