Pyle PLBT72G problems - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 08-18-2013, 09:37 PM - Thread Starter
Newbie
 
Jeremy LaFave's Avatar
 
Join Date: Aug 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently installed the Pyle PLBT72G single din in-dash dvd player with gps. The gps and all audio works, however, when trying to play any video from dvd and usb it only plays audio or once in awhile from usb it gives the error of "invalid key." I am easily able to remove the unit and check wiring connections. Anyone have any ideas?
Jeremy LaFave is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-20-2013, 11:10 PM
Newbie
 
Matthew Gurskis's Avatar
 
Join Date: Aug 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Connect the brown "Brake" wire to your black ground wire.
Jeremy LaFave likes this.
Matthew Gurskis is offline  
post #3 of 5 Old 08-23-2013, 08:34 AM - Thread Starter
Newbie
 
Jeremy LaFave's Avatar
 
Join Date: Aug 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I will try that when I get the chance and let you know how it turns out. Thanks for your input.
Jeremy LaFave is offline  
post #4 of 5 Old 08-29-2013, 08:16 PM - Thread Starter
Newbie
 
Jeremy LaFave's Avatar
 
Join Date: Aug 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It worked, thanks.
Jeremy LaFave is offline  
post #5 of 5 Old 05-27-2014, 05:16 PM
Newbie
 
Rorekofnol's Avatar
 
Join Date: May 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

i just got mine and it will not save any changes that i make on it    i cant find out why this is happening  plz help

Rorekofnol is offline  
Reply Car Audio, Video, and Nav

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off