Help - Newbie in a bind - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 05-20-2017, 04:15 PM - Thread Starter
Member
 
LAR196's Avatar
 
Join Date: Mar 2010
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 11
Help - Newbie in a bind

Hi,

So I know nothing about cars and am in the process of surprising my son with his first car, a 2008 Toyota Highlander. I had just finished getting minor things done at the dealership and then went to a Car Stereo place who installed a Kenwood DDX6903S stereo and an Alpine subwoofer.

Sounded great all was cool. Just ready to surprise my son but then smoke started coming out of the engine. Went back to the dealership and the mechanic says the smoke is coming from the alternator and has something to do with the way the stereo/woofer was hired in.

does this make any sense to you all? I'm a little worried that when I go back to the stereo shop on Monday that they are going to say that its not possibly their fault but the mechanic sure sounds convinced.

I'd love to learn a little about the goings on here - is it possible that the alternator has been affected by this install, is it dead, can I drive the car with the stereo turned off just to get back tot he stereo shop, etc?

Hope to learn a little more before I get into some kind of finger pointing battle.

Thanks very much!
LAR
LAR196 is offline  
Sponsored Links
Advertisement
 
Reply Car Audio, Video, and Nav

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off