Dewalt radio dc011 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 06-23-2012, 10:19 AM - Thread Starter
Newbie
 
Jawbone311's Avatar
 
Join Date: Jun 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Hello, I need some advice from someone with some electronics experience. I have a dewalt worksite radio that is only producing good sound out of one speaker. The other speaker just pops and cracks, with very low audio coming through. It's as if the speaker is blown, but it's not. I switched the speakers and it plays on the good side.

Here is a link to the schematic. If someone could point me in the direction of where to begin troubleshooting this I would appreciate it.

http://www.ereplacementparts.com/dewalt-dc011-type-72v-18v-radio-charger-parts-c-1009_18803_7415.html

Thanks in advance.
Jawbone311 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-23-2012, 09:59 PM
 
gregzoll's Avatar
 
Join Date: Jun 2009
Posts: 2,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 32
Umm, buy a new one, or see if DeWalt will fix their Chinese made crap. Only thing that they make that is worth anything, is the hand tools. Other than that forget it. Now if you want to fix, find a speaker close to the existing either through partsexpress.com. It used to be that you could order replacement speakers through Radio Shack, but no more.
gregzoll is offline  
post #3 of 3 Old 06-28-2012, 10:24 PM
AVS Special Member
 
olyteddy's Avatar
 
Join Date: Oct 2005
Posts: 3,190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Liked: 197
Quote:
Originally Posted by Jawbone311 View Post

Hello, I need some advice from someone with some electronics experience. I have a dewalt worksite radio that is only producing good sound out of one speaker. The other speaker just pops and cracks, with very low audio coming through. It's as if the speaker is blown, but it's not. I switched the speakers and it plays on the good side.
Here is a link to the schematic. If someone could point me in the direction of where to begin troubleshooting this I would appreciate it.
http://www.ereplacementparts.com/dewalt-dc011-type-72v-18v-radio-charger-parts-c-1009_18803_7415.html
Thanks in advance.

Quote:
Originally Posted by gregzoll View Post

Umm, buy a new one, or see if DeWalt will fix their Chinese made crap. Only thing that they make that is worth anything, is the hand tools. Other than that forget it. Now if you want to fix, find a speaker close to the existing either through partsexpress.com. It used to be that you could order replacement speakers through Radio Shack, but no more.
Sorry, but the OP said it isn't the speaker.
olyteddy is online now  
Reply Portable A/V

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off