42" LG LCD No picture AND No sound - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 12-06-2009, 03:11 PM - Thread Starter
Newbie
 
Scotch021's Avatar
 
Join Date: May 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello,

My LG doesnt have any picture or sound, when I turn it on the standby light will blink a couple of times and then go to green, but the screen still looks as if it is off.

I have searched and found some people were having problems with the C235 capacitor on the power supply board but they had sound or a blue screen where as mine shows nothing. Has anyone had any expereince with this? Or can point me in the right direction to getting this resolved? The LCD is about 2.5 years old.

thanks,

Joe
Scotch021 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-06-2009, 03:45 PM
AVS Special Member
 
Servicetech571's Avatar
 
Join Date: Apr 2008
Posts: 4,691
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Model#?
Take the back off and look for bulged top capacitors on the power board.
Servicetech571 is offline  
post #3 of 3 Old 12-06-2009, 06:35 PM - Thread Starter
Newbie
 
Scotch021's Avatar
 
Join Date: May 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Servicetech571 View Post

Model#?
Take the back off and look for bulged top capacitors on the power board.

Model # LG42LC7D, I will check for the capacitor.
Scotch021 is offline  
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off