Official LG XXLD450 Thread - Page 28 - AVS Forum
Forum Jump: 
 1Likes
Reply
 
Thread Tools
post #811 of 1549 Old 01-14-2011, 11:27 PM
Senior Member
 
thepoohcontinuum's Avatar
 
Join Date: Mar 2006
Posts: 421
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by galneon View Post

Nice, are you going to do the test? I feel so alone in the "4:2:2 but it should be 4:4:4" camp :P

Wow. Now this is interesting. As I said before, while I was on a DVI->HDMI connection, I unplugged it and replaced it with a HDMI->HDMI connection. And it displayed 4:4:4 perfectly fine.

So I decided to restart my computer while I still had the HDMI->HDMI connection. And once I got into Windows... bam! No more 4:4:4. I opened up CCC and the Pixel Format tab was now there. I switched to all four options, but all of them was doing 4:2:2.

Without restarting, I disconnected the HDMI->HDMI connection and rehooked my DVI->HDMI connection... and 4:4:4 was back! CCC no longer had the Pixel Format tab though.

Again, without restarting, I disconnected the DVI->HDMI connection, and rehooked the HDMI->HDMI connection. But unfortunately, no more 4:4:4. Pixel Format tab came back though, but cycling through all four options produced a 4:2:2 picture.

So this is quite bizarre indeed. And good god 4:2:2 looks awful
thepoohcontinuum is offline  
Sponsored Links
Advertisement
 
post #812 of 1549 Old 01-14-2011, 11:36 PM
Member
 
SeanPMcD's Avatar
 
Join Date: Dec 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thepoohcontinuum View Post

Its been assumed the VGA connection is 4:4:4 capable. I haven't verified it myself, so I don't now for certain. Try it out and let us know

I haven't been able to find out yet.. But do I need to adjust any ATI graphic settings to get a good image and 4:4:4 image?
SeanPMcD is offline  
post #813 of 1549 Old 01-14-2011, 11:41 PM
Senior Member
 
thepoohcontinuum's Avatar
 
Join Date: Mar 2006
Posts: 421
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by SeanPMcD View Post

I haven't been able to find out yet.. But do I need to adjust any ATI graphic settings to get a good image and 4:4:4 image?

According to DarkNovaNick, VGA does support 4:4:4. He seems pretty knowledgeable based on his previous posts, so I believe him.

Edit: err oops, I didn't answer your question the first time around. 4:4:4 sampling should be on by default. But in case it isn't, in the Pixel Format tab (assuming it shows up for a VGA connection), make sure its on RGB 4:4:4.
thepoohcontinuum is offline  
post #814 of 1549 Old 01-14-2011, 11:52 PM
Member
 
SeanPMcD's Avatar
 
Join Date: Dec 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thepoohcontinuum View Post

According to DarkNovaNick, VGA does support 4:4:4. He seems pretty knowledgeable based on his previous posts, so I believe him.

Edit: err oops, I didn't answer your question the first time around. 4:4:4 sampling should be on by default. But in case it isn't, in the Pixel Format tab (assuming it shows up for a VGA connection), make sure its on RGB 4:4:4.

Thanks!!
SeanPMcD is offline  
post #815 of 1549 Old 01-15-2011, 09:57 AM
Member
 
ScrotumC's Avatar
 
Join Date: Oct 2010
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thepoohcontinuum View Post

Wow. Now this is interesting. As I said before, while I was on a DVI->HDMI connection, I unplugged it and replaced it with a HDMI->HDMI connection. And it displayed 4:4:4 perfectly fine.

So I decided to restart my computer while I still had the HDMI->HDMI connection. And once I got into Windows... bam! No more 4:4:4. I opened up CCC and the Pixel Format tab was now there. I switched to all four options, but all of them was doing 4:2:2.

Without restarting, I disconnected the HDMI->HDMI connection and rehooked my DVI->HDMI connection... and 4:4:4 was back! CCC no longer had the Pixel Format tab though.

Again, without restarting, I disconnected the DVI->HDMI connection, and rehooked the HDMI->HDMI connection. But unfortunately, no more 4:4:4. Pixel Format tab came back though, but cycling through all four options produced a 4:2:2 picture.

So this is quite bizarre indeed. And good god 4:2:2 looks awful

I had to disable the EDID extension block to have 4:4:4 on my ATI 4830 DVI->DVI/HDMI Converter->HDMI setup. Removing the extensions disables audio through HDMI, so I have to run a separate audio cable from my computer to the TV's audio in. Sounds like ATI's HDMI output is funny.

...I can also confirm that VGA is 4:4:4. Seeing the quality decrease going from VGA to HDMI clued me in to the HDMI issues.
ScrotumC is offline  
post #816 of 1549 Old 01-15-2011, 12:48 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just booted up with a DVI to HDMI cable. Perfect 4:4:4 in Windows. I disconnected DVI and hooked up an HDMI to HDMI cable, and 4:2:2 again. Sadly it looks like booting with DVI and switching won't be an option for me. What could be the difference in our setups? I really need HDMI audio so going DVI to HDMI and SPDIF to receiver isn't an option I'm going to try reverting to 10.11 drivers later and see if your switch method works for me, pooh.

I've just posted on ATI's forum about this, as well as submitting a report to the Catalyst crew.

Edit: Just tried 10.11 drivers. No 4:4:4 HDMI no matter what
galneon is offline  
post #817 of 1549 Old 01-15-2011, 01:55 PM
Newbie
 
rdlao's Avatar
 
Join Date: Oct 2003
Location: NYC
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
hi - has anyone been able to get into the LG xxLD450 service menu using a fios box remote? I tried using 0018 and 0019 on the fios remote but was not able to even turn off the tv. Thanks in advance for your help!
rdlao is offline  
post #818 of 1549 Old 01-15-2011, 11:58 PM
Newbie
 
SumCanadianGuy's Avatar
 
Join Date: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Does anyone know how to do the USB hack on a 47ld450? My firmware is 3.05. I can't get in to the service menu but I found a few other things happen if you open menu highlight options and press a certain number key 7 times.
SumCanadianGuy is offline  
post #819 of 1549 Old 01-16-2011, 09:52 PM
Member
 
thecraw's Avatar
 
Join Date: Oct 2003
Location: Jupiter, FL, USA, Earth, Sol System, Milky Way, Known Universe
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by galneon View Post

I just booted up with a DVI to HDMI cable. Perfect 4:4:4 in Windows. I disconnected DVI and hooked up an HDMI to HDMI cable, and 4:2:2 again. Sadly it looks like booting with DVI and switching won't be an option for me. What could be the difference in our setups? I really need HDMI audio so going DVI to HDMI and SPDIF to receiver isn't an option I'm going to try reverting to 10.11 drivers later and see if your switch method works for me, pooh.

I've just posted on ATI's forum about this, as well as submitting a report to the Catalyst crew.

Edit: Just tried 10.11 drivers. No 4:4:4 HDMI no matter what


same problem here. i got a new amd 6950 to address this and it only works in dvi->hdmi. if i use hdmi->hdmi it is crappy 4:2:2

please post if you get any resolution or response from amd.

There are 10 types of people in the world. Those who understand binary and those who do not.
thecraw is offline  
post #820 of 1549 Old 01-17-2011, 02:11 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Will do, thecraw.

I urge you and anyone else experiencing chroma subsampling via HDMI out to post in my thread on the AMD forum.

Here's the thread: http://forums.amd.com/game/messagevi...hreadid=145310
galneon is offline  
post #821 of 1549 Old 01-17-2011, 02:59 PM
Senior Member
 
thepoohcontinuum's Avatar
 
Join Date: Mar 2006
Posts: 421
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by galneon View Post
Will do, thecraw.

I urge you and anyone else experiencing chroma subsampling via HDMI out to post in my thread on the AMD forum.

Here's the thread: http://forums.amd.com/game/messagevi...hreadid=145310
According to your 444proper.jpg pic, that's not really 4:4:4 either. A column of red pixels should only be 1 pixel in width. Using your pic as an example, in the "middle" grouping, the first, second, and fourth columns show 4:4:4, but the third and fifth column do not.

zoran0909 has a really good 4:4:4 pic here - link.
thepoohcontinuum is offline  
post #822 of 1549 Old 01-17-2011, 03:16 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I wonder what it is? It certainly looks better than the awful 4:2:2 example photo I posted. I doubt it's the test .gif I used at fault... I haven't been able to find a .tif of the modified Belle Nuit pattern. Nonetheless, the two photos of HDMI to HDMI vs DVI to HDMI are night and day.
galneon is offline  
post #823 of 1549 Old 01-17-2011, 11:11 PM
Member
 
enphenate's Avatar
 
Join Date: Apr 2008
Posts: 147
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I was having the same exact problem with my Nvidia 460.

Had it originally plugged into my receiver via HDMI (for sound and video) and 4:4:4 failed miserably. I ended up plugging the Nvidia directly to my TV via HDMI and than for the audio SPDIF from my pc to my receiver.

Kind of inconvenient but it solved the 4:4:4 issue for me.
enphenate is offline  
post #824 of 1549 Old 01-18-2011, 10:17 AM
Senior Member
 
thepoohcontinuum's Avatar
 
Join Date: Mar 2006
Posts: 421
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by enphenate View Post

I was having the same exact problem with my Nvidia 460.

Had it originally plugged into my receiver via HDMI (for sound and video) and 4:4:4 failed miserably. I ended up plugging the Nvidia directly to my TV via HDMI and than for the audio SPDIF from my pc to my receiver.

Kind of inconvenient but it solved the 4:4:4 issue for me.

Ah yes, now I remember you. I wonder if this means if the true culprit is the HDMI signaling (whether its on the TV issue and/or video card issue), and not a ATI vs. Nvidia thing. I could've swore I got 4:4:4 working on my HDMI->HDMI connection though, I'll have to do more checking.
thepoohcontinuum is offline  
post #825 of 1549 Old 01-18-2011, 12:28 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
If HDMI has some sort of limitation that downsamples chroma to 4:2:2 no matter what when passing audio along to an HDMI audio-enabled device (be it our TVs or an HDMI AVR), then it doesn't seem to be documented in the HDMI spec anywhere. This would be a truly crippling limitation I'm quite sure my PS3 outputs 4:4:4 while bitstreaming or sending 8-channel PCM just fine.

Edit: I've just posted a couple threads on Nvidia-specific forums to see if anyone is able to get 4:4:4 + audio over HDMI with their GTX 460/570/580 cards. I'll report back...
galneon is offline  
post #826 of 1549 Old 01-18-2011, 02:52 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've come to a grim conclusion after talking to some nvidia users and nuker43. nuker43, who posted the original EDID fix for nvidia cards (referenced in the FAQ on page 22), says with the fix he can't pass HDMI audio along with video. This means the nvidia EDID fix to get 4:4:4 is the same as the AMD EDID fix--both disable extension blocks, thus disabling HDMI audio and forcing the HDMI port to output in pure DVI mode.

This problem afflicts both of the big two video card vendors. It's been a problem in AMD and Nvidia's drivers since they first introduced onboard 8-channel PCM/bit-streaming audio codecs. AMD was first to the game with onboard codecs, so they've had longer to correct the problem via driver fix--IF it was ever fixable. I'm beginning to believe it isn't fixable. This is why AMD has never acknowledged the problem, and the admin of AMD, spyre, continues to obfuscate and blame users' other hardware, every time this issue is raised, for their lack of 4:4:4 chroma via HDMI video+audio connections. They can't fix it.

It seems like a problem with both vendors' hardware implementation of the HDMI interface (eg both vendors could use a similar, or the very same, cheap subcontracted interface with its own flawed middleware library that 'just works' and AMD and nvidia never have to deal with programming it directly, only making driver calls to it), or is totally unfixable and a pure hardware limitation of the HDMI interface of the 5xxx/6xxx AMD lines and the 4xx/5xx nvidia lines.

Either explanation, and I'm quite confident it's one or the other, is out of my hands as to how to fix. I'm personally giving up on this now that I know it afflicts both vendors. I'll be trying an HDMI soundcard (probably a Xonar) and will be outputting DVI to HDMI straight to my LD450's HDMI In, with my AVR outputting to the LD450's second HDMI In.

On a side note, is the second HDMI In on the xxLD450 inferior in any way? Additional input lag? If so, I'll probably use a passive 2-way HDMI switch and just use the primary HDMI Input.
galneon is offline  
post #827 of 1549 Old 01-18-2011, 03:33 PM
Member
 
enphenate's Avatar
 
Join Date: Apr 2008
Posts: 147
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thepoohcontinuum View Post

Ah yes, now I remember you. I wonder if this means if the true culprit is the HDMI signaling (whether its on the TV issue and/or video card issue), and not a ATI vs. Nvidia thing. I could've swore I got 4:4:4 working on my HDMI->HDMI connection though, I'll have to do more checking.


HDMI --> HDMI indeed works for me, if I only connect it from my graphic card (Nvidia 460) directly to my TV. When i tried connecting my Nvidia 460 directly (HDMI -->HDMI) to my Onkyo TX-SR707, 4:4:4 failed, reds looked a bit more bland and darker.

So for me it works now with the EDID fix when connected directly from the card via HDMI -> HDMI to my TV. Audio is also passed to my TV but that is useless as i have a 7.1 sound system so i have the audio passed to my receiver via SPDIF.

New Nvidia driver just came out today so im going to install it without the EDID fix and see if i still get perfect 4:4:4.

Heres a photo i took a while back when i tried plugging it into the receiver



and a photo when it is plugged in directly to the tv
enphenate is offline  
post #828 of 1549 Old 01-18-2011, 05:16 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So it is passing audio with the nvidia EDID fix... Could it be that 2-channel PCM via HDMI isn't a problem for the 460/570/580, but 8-channel you'd pass to your receiver results in subsampled chroma?
galneon is offline  
post #829 of 1549 Old 01-18-2011, 07:59 PM
Member
 
thecraw's Avatar
 
Join Date: Oct 2003
Location: Jupiter, FL, USA, Earth, Sol System, Milky Way, Known Universe
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by galneon View Post

So it is passing audio with the nvidia EDID fix... Could it be that 2-channel PCM via HDMI isn't a problem for the 460/570/580, but 8-channel you'd pass to your receiver results in subsampled chroma?

I don't believe this. I have the gtx 470 and switched to the amd 6950 for this very reason. I did the EDID fix, saw how amazing it looked with my 37" screen and had to have it. I did multiple iterations of the EDID fix and it never worked with integrated sound (and I am only doing simple two channel stereo). Unless something is amazingly different with the gtx460 (doubtful), I think that someone got their connections mixed up or something. I have not tried dvi->hdmi on the gtx470 but I am about 100% positive it would pass 4:4:4 now.

Note: I am not saying that enphenate is wrong but he has some different scenarios in his setup and I am not sure he had sound passing over his hdmi with the EDID fix. I really think this is some flaw with HDMI or the chipsets used or just poor driver implementations from both companies. I would love to find out that NVidia has it working on the newer cards but I doubt it. The GTX470 was a premiere card in April 2010 and is still being made and sold and it doesn't work.

There are 10 types of people in the world. Those who understand binary and those who do not.
thecraw is offline  
post #830 of 1549 Old 01-18-2011, 08:10 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah, this would certainly be the first time I've heard of HDMI with audio (2-channel PCM or 8-channel, doesn't matter) passing 4:4:4 through the HDMI out of the 460. I'm also positive any card would pass 4:4:4 no problem from the DVI port. It's when audio from the HDMI port comes in to play that things go to crap :/ I agree with you totally.
galneon is offline  
post #831 of 1549 Old 01-18-2011, 08:27 PM
Member
 
thecraw's Avatar
 
Join Date: Oct 2003
Location: Jupiter, FL, USA, Earth, Sol System, Milky Way, Known Universe
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by galneon View Post

Yeah, this would certainly be the first time I've heard of HDMI with audio (2-channel PCM or 8-channel, doesn't matter) passing 4:4:4 through the HDMI out of the 460. I'm also positive any card would pass 4:4:4 no problem from the DVI port. It's when audio from the HDMI port comes in to play that things go to crap :/ I agree with you totally.

I spent $300 in my quest for cabling nirvana and now I still have to run another cable from the card to get sound! I now have the most overpowered backup computer ever but my daughter loves how much better she can play video games on it now. I feel like such an idiot sometimes!

There are 10 types of people in the world. Those who understand binary and those who do not.
thecraw is offline  
post #832 of 1549 Old 01-18-2011, 08:40 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hahaha man, at least you did it for someone else's benefit and she's happy with it! I did it for myself and all I have to show for it is a dent in my bank balance and either downgraded audio (I used to have multichannel discrete analog at least! :P) or downgraded video.
galneon is offline  
post #833 of 1549 Old 01-19-2011, 09:31 AM
Senior Member
 
thepoohcontinuum's Avatar
 
Join Date: Mar 2006
Posts: 421
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by galneon View Post

Yeah, this would certainly be the first time I've heard of HDMI with audio (2-channel PCM or 8-channel, doesn't matter) passing 4:4:4 through the HDMI out of the 460. I'm also positive any card would pass 4:4:4 no problem from the DVI port. It's when audio from the HDMI port comes in to play that things go to crap :/ I agree with you totally.

Yeah, the HDMI->HDMI + Audio combination seems to be culprit for messing up 4:4:4 sampling capability. Here's what my experimentation shows...

About a month ago, while helping another ATI person try to get his 4:4:4 working, I had stated I got 4:4:4 working on HDMI->HDMI. However, in retrospect, I recall skipping the "ATI HDMI/DP Audio Driver" option when installing the Catalyst drivers. Thus the audio was never a factor and I was able to get 4:4:4 on HDMI->HDMI.

But since then, I've updated my Catalyst drivers and apparently also installed the HDMI/DP audio option. As I mentioned in an earlier post, I can no longer get 4:4:4 on HDMI->HDMI.

So I uninstalled Catalyst, ran Driver Sweeper, disconnected all video card ports except HDMI->HDMI, rebooted my computer, and installed Catalyst 10.12 -- but this time without the "ATI HDMI/DP Audio Driver" option. Rebooted again, and unfortunately still no 4:4:4 (even after cycling through all four Pixel Format options). But here's the really weird part... I disconnected the HDMI->HDMI connection and replaced it with a DVI->HDMI connection. 4:4:4 was there as expected. So then I disconnected DVI->HDMI, replaced it HDMI->HDMI, and 4:4:4 was now there in all its glory .

While still on the HDMI->HDMI (w/ 4:4:4) connection, I rebooted my computer. Unfortunately, 4:4:4 was no longer there. So I repeated the DVI-HDMI / HDMI-HDMI swap again, but 4:4:4 never came back. I tried it again, and still 4:4:4 never came back.

So even with a HDMI->HDMI + No Audio connection, it seems 4:4:4 *is* possible, but getting it to happen is rare due to some unknown factor (for me anyways, your outcome might be different). As galneon theorizes in post #826, this issue could just be the nature of the HDMI hardware implementation of both video card vendors. And if that's the case, getting HDMI to output 4:4:4 without EDID hacks is probably impossible

On a different note, when you guys say "the ATI EDID fix", is this the same Nvidia EDID fix that nuker43 came up with? Or is it something different? I like to get my facts straight so I can update the FAQ accordingly.
thepoohcontinuum is offline  
post #834 of 1549 Old 01-19-2011, 10:06 AM
Newbie
 
Raging Chicken's Avatar
 
Join Date: Jan 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Another 4:2:2 HDMI victim reporting in .
I have a 32LD450 hooked up via hdmi->hdmi, and I tried virtually EVERYTHING to get a proper picture out of my AMD 6850. I even deleted the hdmi extension block and CCC shows that I'm using a DVI monitor , but hdmi audio still gets routed through regardless and the screen remains fuzzy.
The red text in the AMD-forum is a good example that is barely readable at all
Only thing that works is uninstalling the driver or using a vga lead , but that results in forced edge enhancing

I'll report back when my hdmi->dvi cable arrives.
Raging Chicken is offline  
post #835 of 1549 Old 01-19-2011, 01:01 PM
Member
 
SeanPMcD's Avatar
 
Join Date: Dec 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Does anyone know why the picture is choppy when i connect my laptop to my tv? I have it hooked up via svga and it appears choppy when people start moving fast. I'm watching netflix on it. Is it best to be connected through dvi to hdmi? And is there a way to use audio when my input is pc? I have my head phone jack that splits to component audio connectors. I thought it would pull audio from component 1's audio but didn't.
Thanks
SeanPMcD is offline  
post #836 of 1549 Old 01-19-2011, 01:24 PM
Newbie
 
Raging Chicken's Avatar
 
Join Date: Jan 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
To get smooth playback you have to switch to a 24hz refresh rate and set "real cinema" on in the osd.
If 24hz is not selectable on your laptop you have to create a custom resolution or a custom driver . I managed to get flawless 24p on hdmi and vga no problem.

To get audio in pc mode you have to use the specific labeled input (headphone jack above the vga input on european version or spdif in). If you only have cinch cables use an adapter. You can't use the component-in-audio if you use any of the hdmi or vga ports. Keep in mind if you have audio over hdmi this won't work , only in dvi mode or vga.
Raging Chicken is offline  
post #837 of 1549 Old 01-19-2011, 02:04 PM
Member
 
SeanPMcD's Avatar
 
Join Date: Dec 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Raging Chicken View Post

To get smooth playback you have to switch to a 24hz refresh rate and set "real cinema" on in the osd.
If 24hz is not selectable on your laptop you have to create a custom resolution or a custom driver . I managed to get flawless 24p on hdmi and vga no problem.

To get audio in pc mode you have to use the specific labeled input (headphone jack above the vga input on european version or spdif in). If you only have cinch cables use an adapter. You can't use the component-in-audio if you use any of the hdmi or vga ports. Keep in mind if you have audio over hdmi this won't work , only in dvi mode or vga.

I'll have to get that adapter for ausio.

How do i set up custom display settings? My graphic drive is a ati radeon hd 4200. I tried a few things and didn't help. My resolution is 1280x720 and text looks blurry and not everything is fitting on my lg screen.
SeanPMcD is offline  
post #838 of 1549 Old 01-19-2011, 03:30 PM
Newbie
 
Raging Chicken's Avatar
 
Join Date: Jan 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Text will ALWAYS look blurry if you dont use 1920x1080 .
Here's my monitor driver with added 24hz mode , which should work with vga.

 

24hz.zip 0.9892578125k . file
Raging Chicken is offline  
post #839 of 1549 Old 01-19-2011, 04:45 PM
Member
 
galneon's Avatar
 
Join Date: Dec 2005
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thepoohcontinuum View Post
On a different note, when you guys say "the ATI EDID fix", is this the same Nvidia EDID fix that nuker43 came up with? Or is it something different? I like to get my facts straight so I can update the FAQ accordingly.
I was mistaken regarding extension blocks. The ATI EDID fix I was referring to was disabling the 'extension blocs' boolean value (and thus HDMI audio) in an EDID override ScrotumC mentioned in here. However, he was using a DVI to HDMI connection on his 4xxx series card. Interesting he had to disable extension blocks just to get 4:4:4 via DVI, though. With what Raging Chicken (welcome to the bitter club :P) has just posted about disabling extension blocks, it seems to make no difference at all for the HDMI problem and audio is still output from the HDMI port. I've read so much about this lately that I'm mixing signal chains up

I'd be very interested to hear from more 4xxx users. We've got multiple examples of 5xxx and 6xxx series users who can't get 4:4:4+audio via HDMI, and logically I'd assume this is the same for 4xxx cards with onboard audio codecs. If we can confirm this is the case, then I believe we can conclude that all video cards with onboard HD audio codecs (I'm not talking about the early nvidia cards with pass-through SPDIF inputs you'd feed audio to from your onboard Realtek codec or PCI[e] soundcard), both AMD and nvidia, are affilicted. Just more evidence for the faulty HDMI interface or broken interface library that both companies very well could rely on. When it comes to subcomponents for computer parts, what's cheap becomes standard. Look at Foxconn I/O interfaces on motherboards. Unfortunately, PC users/PC gamers with HDMI receivers and high-quality (4:4:4 chroma) displays are few and far between still, so this problem has likely gone unnoticed by the majority of users. I hope the problem becomes more widely known.

Regarding the earlier reference to some early 4xxx and 58xx cards passing 4:4:4+audio properly, I have an early reference 5850, so it's likely not the case for the 5xxx series, at least :/
galneon is offline  
post #840 of 1549 Old 01-19-2011, 07:40 PM
Member
 
ScrotumC's Avatar
 
Join Date: Oct 2010
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by galneon View Post

I was mistaken regarding extension blocks. The ATI EDID fix I was referring to was disabling the 'extension blocs' boolean value (and thus HDMI audio) in an EDID override ScrotumC mentioned in here. However, he was using a DVI to HDMI connection on his 4xxx series card. Interesting he had to disable extension blocks just to get 4:4:4 via DVI, though. With what Raging Chicken (welcome to the bitter club :P) has just posted about disabling extension blocks, it seems to make no difference at all for the HDMI problem and audio is still output from the HDMI port. I've read so much about this lately that I'm mixing signal chains up

I'd be very interested to hear from more 4xxx users. We've got multiple examples of 5xxx and 6xxx series users who can't get 4:4:4+audio via HDMI, and logically I'd assume this is the same for 4xxx cards with onboard audio codecs. If we can confirm this is the case, then I believe we can conclude that all video cards with onboard HD audio codecs (I'm not talking about the early nvidia cards with pass-through SPDIF inputs you'd feed audio to from your onboard Realtek codec or PCI[e] soundcard), both AMD and nvidia, are affilicted. Just more evidence for the faulty HDMI interface or broken interface library that both companies very well could rely on. When it comes to subcomponents for computer parts, what's cheap becomes standard. Look at Foxconn I/O interfaces on motherboards. Unfortunately, PC users/PC gamers with HDMI receivers and high-quality (4:4:4 chroma) displays are few and far between still, so this problem has likely gone unnoticed by the majority of users. I hope the problem becomes more widely known.

Regarding the earlier reference to some early 4xxx and 58xx cards passing 4:4:4+audio properly, I have an early reference 5850, so it's likely not the case for the 5xxx series, at least :/

The 4830 I'm using only has DVI connectors, but they are capable of audio output if I use ATI's DVI-HDMI adapter. This essentially turns my DVI to HDMI and gives me audio (but non-4:4:4). CCC shows it as being HDMI if I don't disable the extension block...whereas now, with extensions disabled, it shows it as DVI. I'm feeding a 40 year old amplifier, so I can live with 2 channel...I certainly wouldn't be happy if I had some 5.1+ setup like some of you guys.

I thought it was just the 4xxx line that had this issue...I was *this* close to going out and buying a new card last month.
ScrotumC is offline  
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off