Hitachi 50VS810 Fuzzy Problems on/off - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 12-31-2010, 03:29 AM - Thread Starter
Newbie
 
spacejunk426's Avatar
 
Join Date: Dec 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My Hitachi 50VS810 quit working with the front panel light showing the cooling fan was not working. I pulled the

rear cover panel and the bulb as well...the bulb appeared ok but the cooling fan for the bulb was stalled out with

massive dust clogging it. I blew the unit out w/ compressed air and counted 5 internal fans (I now believe there are

six or more) and logged the Model #s etc. of most of them. I re-installed the bulb, turned on the set and it would

not light up...? The indicator LED's showing the bulb was bad. I pulled the bulb and it was obviously bad?
I ordered and installed a new bulb/housing assy. All was fine for a while...a couple of weeks that is!
Then When I turned on the tv (cold start up) it would be fuzzy/blurry for a minute or two? This went on for 10

month's or so.
It progessed to a longer and longer period of time before the pic would become normal. Like 10-15 minutes or so by

the end. (untill it started cycling off and on repeatedly).
Then on Thanksgiving 2010 it started shuting off and then turn back on in cycles repeating in an endless loop.
There is a (power inverter?) circuit board which has 2 fair sized caps 680uf/200v which I replaced with same uf and

same brand but a slightly higher 220v rating.
This board has 120AC volts coming in and 330v DC out when the lamp is lit. (340v DC when lamp cycles off---no load).
This is feeding the ballast circuit board. I have replaced the ballast board as well.
The tv will stay on for long periods now but will still cycle off at random.
It is still fuzzy for 12- 15 minutes on cold starts and it starts up fuzzy when it restarts...even though it has had

no apparent time to cool down? I would really like help to fix this tv.
I offered to give it to my mom thinking it was a easy fix...I spoke to soon...now I don't know what to think.
Please Help!

Mike
spacejunk426 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-25-2012, 09:49 PM
Newbie
 
Amilie DeCou's Avatar
 
Join Date: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Were you able to fix it? We have the same tv, same issue.
Amilie DeCou is offline  
Reply LCD Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off