Insignia 42" Display Issue - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 03-18-2012, 03:00 PM - Thread Starter
Newbie
 
diabelek68's Avatar
 
Join Date: Mar 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,

I have an Insignia NS-42L550A11. This is the 42" LCD 1080p 120hz model. I am starting to get black lines across the screen that are intermittent. Also there is some occasional ghosting that occurs, the best way I can describe this is that is is similar to how the bad guy in the Riddick Chronicles moves. These symptoms are not continuous but do get worse as use goes on. When the TV is turned on cold usually takes about 5-10 minutes for them to start once it is warm.

BB wants $150 to come out to "look" at it. I have found a few websites with parts but I am just not sure what part to change.

I appreciate any help and will try to give more details as best I can.
diabelek68 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-18-2012, 03:43 PM
AVS Special Member
 
tylerSC's Avatar
 
Join Date: Jun 2010
Location: Mauldin SC, 29607
Posts: 3,939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 88
It may cost almost more to get it repaired vs getting a new one. And not sure what parts are used in the Insignia LCDs. The Insignia plasmas use Samsung panels, so I would get the Insignia 42" plasma now on sale for $399.
tylerSC is online now  
post #3 of 3 Old 03-18-2012, 04:02 PM - Thread Starter
Newbie
 
diabelek68's Avatar
 
Join Date: Mar 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah I was thinking the same thing. I just figured a if I could get away with a $30-60 part then I could do that. It is a nice TV for being low end. I have gotten a lot of compliments from folks that have never, more expensive TV's.

If anyone else has a thought on it I would appreciate it. I saw a list of parts here, www shopjimmy com/insignia-ns-42l550a11.

Does not seem complete to me but I really don't know. Would replacing the main board be enough to fix this problem? Or are there other parts I should be looking at?
diabelek68 is offline  
Reply LCD Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off