LG 42SL9500 Led - screen problem - looks like snail trail? - AVS Forum
Forum Jump: 
 
Thread Tools
Old 02-13-2013, 10:07 AM - Thread Starter
Newbie
 
thexlr8r's Avatar
 
Join Date: Dec 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Had this LG 42SL9500 (exclusive to Dixons) for almost 3 years.

Over the past year, the screen has developed a strange fault.

its best described what looks like , a snail trail on the right side of the screen, and also slightly middle-bottom.

i have attached a picture taken while i was in service menu test white balance section.

Note: this fault only appears on HDMI inputs, and does not manifest itself on the tv's inbuilt test patterns within the Service Menu ??? rolleyes.gif

I contagted LG, but was a waste of time as its outside warranty and they didnt care to help at all.

Took it to a tv repair center and they said "new screen (£500)" , so thats obviously not an option.

here is a pic i took of the fault . fault areas are circled in yellow. you can see a weird stain / snail-trail mark.

I use a 4to2 matrix HDMI switchbox. thinking it was the problem, i removed it and tested several devices directly into each TV HDMI input socket, same result on all 4 inputs.


would appreciate any useful comments as to what this fault might be. thanks

thexlr8r is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off