Official Seiki SE50UY04 50-Inch 4K UHD Owners Thread - Page 16 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 26Likes
Reply
 
Thread Tools
post #451 of 454 Old 04-25-2017, 09:08 AM
Newbie
 
Join Date: Apr 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Quote:
Originally Posted by panyeye View Post
SE50UY04 FIRMWARE QUESTION
I have what appears to be an early model of this TV based on the serial number. After reading all 449 post I'm still a little Leary of trying a firmware upgrade even though I have many of the same problems as others. The only way that worked for in contacting Seiki was through their facebook and using messenger. After providing them with the version Info, release version and the serial number, they sent me what appears to be the original firmware as the image file is dated the same as the "Produce date of 3/3/2013". They said it was the only firmware available for my unit.
The zip file they sent is: SEIKI_2975_SY13036-1_20130303_094520_496698_install.zip.

I'm wondering if the SE50uy04_20130528.zip file(Seiki Austrilia) which contains the disc image file "install.img" dated 5/28/2013 would work and help solve some the problems.

Here my information:
VERSION INFO
Baseline Ver: 496698
Customer Ver: 1.0
Order form: SY13036
Board ver: ST2975K_R10.3
Panel: Info: CMI_V500DK1_LS1
Customer:SEIKI
Produce Date: Mar 03 2013
Produce Time: 09:45:20am

RELEASE VERSION
Boot Ver: 0001.0716.1017
Linux Ver: 000
Video Ver; 496203
Audio Ver: 494203
AP Ver: 496698

Any comments will be greatly appreciated.
@panyeye I know this is an old post, but seeing as I still visit this thread after 2 years with my Seiki, I figured it may help someone else too. Flashing on this model is very easy and I've even managed to even repair a softbrick after flashing a bad rom.

I personally have not experienced blanking or frame drops like others have reported, but I have had a few of the other annoying issues. The most annoying being the backlight setting reverting on every boot . I've successfully installed @NightWolve 's most recent firmware and it's working swimmingly for me.

TL;DR, It's an easy an relatively harmless process. I'd try the firmware linked above by @NightWolve . Just make sure to follow the instructions and wait patiently for the flash to complete.

And shout out to @NightWolve for hounding Seiki for the "final" version of the firmware for this unit!
redforest is offline  
Sponsored Links
Advertisement
 
post #452 of 454 Old 04-25-2017, 10:33 AM
Newbie
 
panyeye's Avatar
 
Join Date: Apr 2004
Posts: 9
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Quote:
Originally Posted by redforest View Post
@panyeye I know this is an old post, but seeing as I still visit this thread after 2 years with my Seiki, I figured it may help someone else too. Flashing on this model is very easy and I've even managed to even repair a softbrick after flashing a bad rom.

I personally have not experienced blanking or frame drops like others have reported, but I have had a few of the other annoying issues. The most annoying being the backlight setting reverting on every boot . I've successfully installed @NightWolve 's most recent firmware and it's working swimmingly for me.

TL;DR, It's an easy an relatively harmless process. I'd try the firmware linked above by @NightWolve . Just make sure to follow the instructions and wait patiently for the flash to complete.

And shout out to @NightWolve for hounding Seiki for the "final" version of the firmware for this unit!
Redforest, Thanks for the input. Do you have the exact model that I have; produce date etc? and what do you mean "TL;DR"
panyeye is online now  
post #453 of 454 Old 06-11-2017, 02:01 PM
Newbie
 
pepowdylan's Avatar
 
Join Date: May 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
I need some help troubleshooting my SE50UY04. When I turn it on the logo comes up and the LED turns green, but then it is blank. You can hear sound, but no picture. Any ideas on how to fix? I was thinking it may need the tcon board replaced.
pepowdylan is offline  
 
post #454 of 454 Old Today, 12:14 PM
Newbie
 
Join Date: Jun 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Exclamation Help

I have a 50 in seiki that will not start. I press the power button and it opens with the seiki logo and then freezes on the logo! I cant even turn it off normally after this I have to unplug it from the wall. I was thinking it could be the eepom memory since I have seen the same thing happen to vizio tvs
Elliott Fisher is online now  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Tags
Seiki Digital Se50uy04 50 Inch 4k 120hz Led Hdtv
Gear in this thread



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off