Sony Bravia KDL-52Z5100 white screen - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 06-11-2013, 02:09 PM - Thread Starter
Newbie
 
Steph41's Avatar
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey everyone,

First off, I would like to mention that this TV was not originally mine, so I do not know how old it is.

When I acquired it, it was having issues similar to (or so I read) a faulty T-CON board. There were vertical lines across the screen and there were ghosting images. Also, if I let the TV sit for approximately 20 to 30 minutes, the image would clear right up.

I ordered a T-CON board on eBay, but there was no difference. After a little more research, I thought the issue may lie in the ribbons at the top of the TV that go from the LCD panel to somewhere in the back. I took the TV apart, and applying pressure to these ribbons seemed to help. Therefore, I applied some double sided tape to the ribbons (seeing as there was a metal frame over the ribbons, the tape was supposed to keep the pressure on them). However, once the TV was turned off and had cooled down, it went from having the ghosting images to having a plain white screen when turned on.

Further research indicated that this might be the LCD panel, but when I twist the frame of the TV, I get what is shown in the attached image (it's a little hard to tell, but there are pink lines in the upper left hand corner, and an inverted triangle in the centrer of the screen. Also, there are some horizontal lines that seem the be jumping up and down along the bottom)

Any help would be greatly appreciated. IMAG0201.jpg 926k .jpg file
Attached Images
File Type: jpg IMAG0201.jpg (926.3 KB, 4 views)
Steph41 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-16-2013, 02:43 PM - Thread Starter
Newbie
 
Steph41's Avatar
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Is it possible that the T-CON that I ordered online is faulty? It was seller refurbished.
Steph41 is offline  
post #3 of 3 Old 06-19-2013, 05:44 PM - Thread Starter
Newbie
 
Steph41's Avatar
 
Join Date: Jun 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
UPDATE: I've put the TV back together for the time being, and I've noticed that the image isn't the same every time I turn it on. Sometimes the image will be perfectly clear, other times there will be horizontal lines across the middle of the screen, and at it's worst, there will be red and yellow lines spread vertically along the screen. Letting the TV warm up still resolves this issue, but I've noticed that twisting the screen has been more effective than before (as long as I hold the screen twisted, that is). Any and all help is appreciated.
Steph41 is offline  
Reply LCD Flat Panel Displays

Tags
Sony Bravia Kdl 52z5100
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off