KDL-52XBR4 strange green problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 06-18-2013, 10:14 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I got the tv from a friend of mine and it has a strange green haze in the top right corner. It is darker in the closer you get to the corner and kind of fans out about a foot to the left and down. If you turn up the backlight and brightness you can almost bleach them out but you can still notice it. If the screen is displaying grey its dark green in the corner and once again lighter as it fans out. Is this problem fixable or is it a problem with the actual lcd panel. Ive been reading up for 2 days straight and Im very confident with working with electronics. I did read the TCON board goes bad a lot but not sure if this is my problem. Also I did try doing the Tab Bonds and nothing seem to change when messing with those. Any ideas are appreciated thank you in advance.
TBSPW is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 06-18-2013, 10:15 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
TBSPW is offline  
post #3 of 9 Old 06-19-2013, 05:24 AM
AVS Special Member
 
schlick's Avatar
 
Join Date: Jul 2006
Posts: 1,392
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Looking at the pic, it's sort of tough to tell, due to the lack of RF signal presence, hence "snow" on screen. I'd guess from the irregularity of the shape, that the backlight tubes in that area aren't fully illuminated. I say that because you can see the tcon addressing is somewhat working because the snow is present beneath the haze. But that wouldn't cause the green haze condition. Is it safe to say this condition exists on all inputs? The green is typically indicative of loss of digital signal, but, again I can still see snow beneath it. If you get right up to the display in that area can you see that all 3 sub pixels are lit? If you can find a tcon cheap on somewhere like shopjimmy.com, i'd try it. Worth a shot.

If the inverter boards are interchangable, I'd also try swapping them and see whether the problem moves to somewhere else on screen.

Hope this helps some, good luck.
schlick is offline  
post #4 of 9 Old 06-19-2013, 08:42 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Sorry for just using the snow lol. Ill quick hook up my computer and take a few pics on different colors to see if this helps. Also the inverter boards, where are they located?





Like I said before it is like a very dark green in the corner and then gets lighter as it spreads from the corner
TBSPW is offline  
post #5 of 9 Old 06-19-2013, 08:47 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
and I forgot to mention it is on every input setting
TBSPW is offline  
post #6 of 9 Old 06-19-2013, 09:05 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Alright another update after a few trial and error ideas. After cranking the backlight, color, and brightness up it almost washes the spot out to where you barely notice it and the whole picture is almost still perfect. It almost looks like it is not there anymore but once again if you reset the settings its still there. Also I would like to add that after calling the previous owner this problem started small and then slowly spread. He did inform me that the tv was on many hours everyday and took quite awhile for it to get to the point that its at now.
TBSPW is offline  
post #7 of 9 Old 06-19-2013, 11:50 AM
AVS Special Member
 
schlick's Avatar
 
Join Date: Jul 2006
Posts: 1,392
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
If left unplugged for 30+ minutes, then powered back up, is the effect immediately as intense as in the above pix, or does it take some time to develop to that point?
schlick is offline  
post #8 of 9 Old 06-19-2013, 11:59 AM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Makes no difference
TBSPW is offline  
post #9 of 9 Old 06-19-2013, 05:41 PM - Thread Starter
Newbie
 
TBSPW's Avatar
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Major update... after unplugging the right side of the screen from the TCON board the problem seems to shift to the center of the screen...its not as bad but still very noticeable


as you can see its green in the corners like when the whole screen is powered but now in the center so does this mean bad tcon board
TBSPW is offline  
Reply LCD Flat Panel Displays

Tags
Sony Bravia Xbr Kdl 52xbr4 52 Inch 1080p Lcd Hdtv
Gear in this thread - 52xbr4 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off