PANASONIC TX-L26C10B NO PIC JUST SOUND, PIC COMES IF FRAME TWISTED?? PLEASE HELP ME!! - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 08-22-2013, 03:57 PM - Thread Starter
Newbie
 
daniel556's Avatar
 
Join Date: May 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Techies! smile.gif
I really hope someone can help me here as my Panasonic Viera TX-L26C10B started losing it's picture but you could still hear sound.
It would come back after turning it on and off until it's got so bad now that I can barely keep a picture at all and only then by "Twisting the frame".
If I push back on the top left and pull on the bottom left the picture comes back for a second, it did used to get it working all day but the problems just got so bad I can't get it to stay on.
It helped at first if I left the back off and have tried checking as many connections as I can see like re-connecting the ribbon cables etc.. but with no joy!
I've tried ALL the connections like HDMI, Scart, Digital Ariel and still no picture.
Please could someone help me as I can't afford to get it fixed or buy a new TV.
Many many thanks in advance,
Dan..

P.S Just ask if you need any more info!

P.P.S The Screen goes either white or black and sometimes gets a thin multi-coloured band down the left hand side now.
daniel556 is offline  
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off