LG 50PG20 Won't Power Up - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 01-06-2009, 09:34 PM - Thread Starter
Newbie
 
greg008's Avatar
 
Join Date: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an LG 50PG20 that won't power up. Yes its plugged in properly. The red standby light is on, when I try to turn it on the light blinks 3 times, once more and stays on blue for about 2 or 3 seconds then goes back to red.

I've hauled the back panel off as I have no warranty and I can't get a shop to look at it for two weeks but they figure it's the power supply board and will charge me around $400 plus labour. I see the same item on ebay for around $150 and it appears to be nothing more then a few screws and to unplug some wires.

So is there any way to confirm what the problem is for sure? I have no idea on the TV's history as I bought it broke without warranty. Thanks in advance.
greg008 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-07-2009, 07:14 AM
Member
 
Vythiel's Avatar
 
Join Date: Nov 2008
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
LG covers their TVs for 2 years as far as I know and your set was released in 2008. Have you tried calling LG support?
Vythiel is offline  
post #3 of 3 Old 01-07-2009, 06:00 PM - Thread Starter
Newbie
 
greg008's Avatar
 
Join Date: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Vythiel View Post

LG covers their TVs for 2 years as far as I know and your set was released in 2008. Have you tried calling LG support?

No I bought the TV knowing it was broken for cheap to try and repair it.
greg008 is offline  
Reply Plasma Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off