Sanyo 50" plasma power turns on then off? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 09-13-2012, 07:15 PM - Thread Starter
Newbie
 
Maverick530's Avatar
 
Join Date: Aug 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I got this new plasma Tv since its broken from my aunt and i hope i can fix it,
whats going on is that when i push the power button (on the Tv it self or the Remote) the power light turns on for a few seconds (about 5-6) and then turns off again. So far i took off the back of the tv and was looking around and from what i see, none of the capacitors are blown, and i ended up taking off the whole power board and noticed that its still all perfectly green on the other side, so no discoloration.

There are two capacitors that i question that are blown since they feel a little uneven when i run my finger on the top of them how ever i believe that its just because they are the bigger ones and are probably made a little diffrently maybe, when looking at them they look perfectly fine.

so, anyone else have this problem

Tv: Sanyo 50" plasma
Model: Dp50749
Made in 2010
Maverick530 is offline  
Reply Plasma Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off