PDP-4280 Clicking, but not turning on - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 09-13-2012, 07:58 PM - Thread Starter
Member
 
boss77's Avatar
 
Join Date: Jun 2001
Location: Hoboken, NJ
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So I came home yesterday and my PDP-4280 (less than 5 years old) will not turn on. I changed outlets and unplugged and plugged it back in, but it won't turn on. The red/blue light on the front does not illuminate at all. One interesting thing is that when I plug it in, I hear a clicking noise from the back of the TV. Any idea what this could be and how much it would cost to fix?

Thanks!
boss77 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-14-2012, 06:37 AM
Senior Member
 
homerging's Avatar
 
Join Date: Jun 2010
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 18
That sounds like a power board failure. It probably needs some electrolyte capacitors replaced. The clicking comes from the relays on the power board. Badcaps is a better place to ask these kinds of questions.

Panasonic FR caps are cheap, labour isn't . Most repair people don't do component level repairs any more and would swap in another power board sooner than replace a $1 part with a soldering iron.
homerging is offline  
Reply Plasma Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off