50" Samsung HP T5054 no pix or sound - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 01-14-2013, 10:27 AM - Thread Starter
Newbie
 
WB8UCD's Avatar
 
Join Date: Jan 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi folks
I am new to this forum so hopefully I am not starting a thread on something that has been covered.
My Samsung HPT5054 has no pic or sound. When the set is turned on I hear a relay click but nothing else happens.
I have removed the back and searched for blown fuses and damaged(bulging) electroylic capacitors and has not noticed any thing.
Any suggestions would be greatly appreciated.
Thanks Dave
WB8UCD is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-22-2013, 06:37 PM
Newbie
 
Danecook155's Avatar
 
Join Date: Feb 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Heyy I have a few questions about it. But could you email me: Carterkyle51@yahoo.com


Type in the subject line HP T5054

Thanks!!
Danecook155 is offline  
post #3 of 3 Old 03-01-2013, 02:34 PM
Member
 
str8maxn's Avatar
 
Join Date: Nov 2012
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Did you find a fix?
str8maxn is offline  
Reply Plasma Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off