Netflix played through my ROKU only delivers a stereo signal - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 08-25-2013, 04:00 PM - Thread Starter
Newbie
 
NMonney's Avatar
 
Join Date: Aug 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have seen this subject discussed, but not for the Roku. I can play Netflix direct from the wireless signal to my TC-P65ST60 TV and get Dolby 5.1 from my Marantz SR6005 AV Receiver, but Netflix played through my ROKU only delivers a stereo signal. My Roku 2 XS claims that it provides Dolby 5.1:
The Roku 2 XS delivers the best experience in 1080p HD streaming to your TV—plus motion-based gaming for an extra dose of great entertainment. Includes one-stop search across top channels like Netflix, Hulu Plus and Amazon Instant Video; a free app for iOS and Android; and a full complement of connectivity options. It supports 1080p (over HDMI), 720p (over HDMI), 480p (over HDMI), 480i (over composite video). Audio Outputs Digital: Over HDMI (5.1 channel surround sound pass-through and stereo)

With my previous TV, I got only the stereo from the Roku and when I called them they said the problem was likely the speed limitations of my internet (ATT U-verse). Now I know that is not correct. I use a high-quality HDMI cable for both (the TV cable is 3' longer).

I do not receive a 5.1 signal for Amazon from the TV direct to the receiver, but I believe Amazon does not send 5.1 sound with their HD transmissions.

I like the Roku interface presentation better (particularly for Amazon). Any suggestions regarding using the Roku and getting 5.1 for Netflix and many of the other programs not set up to come through the TV (unless I try to go through the browser)?
NMonney is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-25-2013, 06:46 PM
AVS Special Member
 
subavision212's Avatar
 
Join Date: Sep 2007
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 25
I'm pretty sure you have to set the audio for each movie you stream through the Roku. When you click on the film and the next menu comes up go to subtitles/audio and choose 5.1 if available. Not every film does. Also, make sure audio is set to 5.1 and not stereo in the Roku settings.

subavision212 is offline  
post #3 of 6 Old 08-25-2013, 07:31 PM
 
gregzoll's Avatar
 
Join Date: Jun 2009
Posts: 2,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 32
Netflix was having issues this past week, with movies that were supposed to be Dolby Digital Plus (DD 5.1) only streaming in Multi-Channel. Things have changed since Friday for Amazon that I have found, and some stuff with Netflix also. Make sure that your Roku is setup properly for Surround Sound in its settings is a start. Also as for the HDMI cable, you do not need a $100 HDMI cable, a $5.00 cable from Amazon or Newegg will work fine.

As for Amazon, same thing as Netflix this past week, they were having issues sending Dolby Digital 5.1, and looks like it has also been fixed as of Thursday. I addressed this on Tuesday with Sony, Amazon, Netflix, and of course Sony's answer was "Here is a list of our new line of equipment that you may be interested in." In other words, it is not our fault. Amazon got right on it, and credited back the money for Transformers Revenge of the Fallen, and were right on top after explaining that I only got Center channel and the Denon AVR-1612 that I have, would state "Multi in" regardless what we played, but only got the Center channel.

I did a reset on our Sony BDP-S590, just to make sure nothing we wonky, but after waiting, it really came down to the CDN that Netflix uses from Amazon, that was at fault.
gregzoll is offline  
post #4 of 6 Old 08-25-2013, 07:32 PM
 
gregzoll's Avatar
 
Join Date: Jun 2009
Posts: 2,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 32
Quote:
Originally Posted by subavision212 View Post

I'm pretty sure you have to set the audio for each movie you stream through the Roku. When you click on the film and the next menu comes up go to subtitles/audio and choose 5.1 if available. Not every film does. Also, make sure audio is set to 5.1 and not stereo in the Roku settings.
You do not have to go in and change audio on every movie with the Roku. It will default to whatever the service defaults at. You do have to make sure that you have a fast enough Internet package, and that you have the Roku setup for Surround sound though.
gregzoll is offline  
post #5 of 6 Old 08-31-2013, 01:10 PM - Thread Starter
Newbie
 
NMonney's Avatar
 
Join Date: Aug 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
This is the first opportunity I have had to respond to this thread. First let me thank each of you for your input! I now am getting Dolby 5.1 surround from my Roku through my receiver. I had previously set it for "surround" in the Roku but somehow it had changed to "stereo". All it apparently took was changing the setting back to surround and checking back again to be sure that is where it stayed (the first time I checked back it had changed back to stereo -- perhaps I had not backed out of the settings in a way that saved my selection). In any case, I now receive both Netflix and Amazon in Dolby 5.1. I have not had to go back into settings to reset it to surround...
NMonney is offline  
post #6 of 6 Old 08-31-2013, 09:45 PM
 
gregzoll's Avatar
 
Join Date: Jun 2009
Posts: 2,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 32
The Roku's have a tendency of reverting back to Stereo when doing firmware upgrades every now and then for some reason. I always went through the audio and video setting son the Roku I gave my next door neighbor, when I did a firmware update on it, due to it would revert back to factory settings for some reason.
gregzoll is offline  
Reply Plasma Flat Panel Displays

Tags
Netflix , Roku , Roku 2 Hd Streaming Player



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off