Receiver causing picture to fade? - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
 
Thread Tools
post #1 of 1 Old 09-22-2015, 09:41 AM - Thread Starter
Senior Member
 
bassage's Avatar
 
Join Date: Oct 2002
Location: Phoenix, Arizona
Posts: 425
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 101 Post(s)
Liked: 24
Receiver causing picture to fade?

I just hooked up a new Denon s510bt and it is destroying my picture. I have a 2014 model Samsung plasma with amazing black levels. Looks perfect when hooking up components straight to the tv, but when I run through the receiver, the blacks are gone. Not just a little off, but a black screen is now light gray. I tried an xbox one and a ps3 on different sources, both using HDMI, both look like garbage. They look perfect without the receiver. I have a higher end Denon in another room and never had this problem. Is there a setting on the receiver that I need to change?
bassage is online now  
Sponsored Links
Advertisement
 
Reply Plasma Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off