Maxent 50" plasma MX-50X3 official thread - DO NOT POST PRICES!!! - Page 73 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #2161 of 2188 Old 07-18-2011, 03:09 AM
Advanced Member
 
leiff's Avatar
 
Join Date: Nov 2005
Location: sanfrancisco
Posts: 639
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Does this tv have a optical out? And if it does will it passthrough a hdmi audio signial input out via optical?
leiff is offline  
Sponsored Links
Advertisement
 
post #2162 of 2188 Old 08-04-2011, 12:32 PM
Member
 
Newby1's Avatar
 
Join Date: Jun 2005
Location: Orlando, FL
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by The Mad Rogue View Post

I found a replacement board QPWB11522-1G-2 (just use Google shopping) for $54.95. The board appears to be new (in sealed bubble wrap) with the new capacitor already built in, but in a slightly different location. The board does work and fixed my problem (the TV quit 8 months after the original cap fix). It does need some fine tuning, but I'm going to swap the BIOS chip from my old one first. As of today, the seller (discount-merchant.com) has another one for the same price, and gets them in regularly.
I also noticed all the new TVs now come with 80mm cooling fans (the Panasonic has 4) just like those used for computer cases. Apparently, the original designers hadn't planned on everybody taking them off the stands and mounting them on walls where they don't get any air circulation. (The capacitors are only rated to 105 degrees) I plan on putting a tower fan on one of the box speakers I've got on either side of the TV.

Did your old board have DPWB11522-MPP-D on the white sticker? I need a new board but when I search that number no one has one in stock. I need to make sure it will have the same connections.
Newby1 is offline  
post #2163 of 2188 Old 08-13-2011, 03:51 PM
Member
 
Newby1's Avatar
 
Join Date: Jun 2005
Location: Orlando, FL
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I did the cap fix and tv works fine for about 1 hr then the picture goes crazy. Turn it off and come back later and it works again for about and hr. I was told by repair man that it needs a new board, but I can't locate one. I need the same board as the post above and no one seems to have one. Does anyone have a clue as to what might be wrong with the set? If its some more simple sodering, I'm up to the task. I don't want the repair man to fix it as he wants $400 for a new board and the tv just isn't worth that kind of money. Thanks in advance for any assistance.
Newby1 is offline  
post #2164 of 2188 Old 08-21-2011, 04:21 PM
Newbie
 
Loxosceles's Avatar
 
Join Date: Aug 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The cap fix worked fine for about 8 months, then did it again and works fine for now but I would recommend removing the board(Just a bunch of screws).
I did some research on replacing the board and also came up with an alternate number and are at this time available on Ebay.
The alternate number that worked for me when I searched Google is Maxent Main Tuner Board YPWB11592SMPP is alternate for QPWB11592Y1G and the Model # MX-58HPT51 and ms# P58h10NJA,
Hope this helps anyone in the future.
Thanks for the great help folks. !!!!
Loxosceles is offline  
post #2165 of 2188 Old 12-18-2011, 07:09 AM
Member
 
evofxdwg's Avatar
 
Join Date: Dec 2005
Location: Byron GA
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The single cap fix made my flicker problem change from doing it only on warmup to continuously AFTER warmup - about 2 to 3 flicks per second average when using the video input (from VCR cable tuner - i dont pay for digital cable as i have an antenna & ATSC tuner as well). Using ATSC tuner and HDMI, it still flickers, but much less frequency - maybe a one every 3 to 10 seconds. There was no visible deformation or discoloration of the cap or on the top of the board (although i did not go over it thoroughly).

I was hoping for a quick fix in the living room without removing the board but no joy.

This Maxent is 7 years old this month and im not wanting to spend much fixing it. Replacement boards seem to be over $100 and also hard to find. I dont want to gamble that much on a 7 year old TV. A nice new 60 or 65 inch panny, samsung, or LG sounds enticing.

Thinking about:
- trying some other inputs for video, or going back to upconvert to HDMI thru my AV receiver (I removed this because it was causing a lot of pix freeze problems which were also getting worse)
- moving it to the garage, removing the board and inspecting closely
- experimenting with freeze spray and a mirror while turned on
- checking what i can with a voltmeter (biggest problem is finding data for what the voltages should be)
- ordering the ebay repair kit which says it has 7 replacement components for about $22 including shipping.

Has anyone here installed the ebay kit? Did it help?
evofxdwg is offline  
post #2166 of 2188 Old 06-02-2012, 05:34 PM
Newbie
 
Madphule's Avatar
 
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jstic View Post

The fix for the flickering during the warmup period ... Desolder surface mount capacitor # 766, located just to the left of the green heatsink. You can then get a capacitor at Radio Shack to replace it with. Radio Shack part # 272-1029, a 220uf, 35V r...

I know this thread is old, but I just wanted to say Thank you!

I bought my set using these forums (so long ago my log-in was dead) and have loved the set. About a year ago the flicker on warm-up started but was livable.

This winter it got to be really bad but a space heater kept it from being noticeable (though the electric bill made it warrant replacement). I performed the capacitor replacement this morning and all looks great....

So THANK YOU!
Madphule is offline  
post #2167 of 2188 Old 06-06-2012, 12:14 PM
AVS Special Member
 
jonnythan's Avatar
 
Join Date: Jan 2006
Posts: 2,966
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
Will this set output audio from the HDMI input over the analog outputs?
jonnythan is offline  
post #2168 of 2188 Old 07-23-2012, 04:01 PM
Newbie
 
Pat1's Avatar
 
Join Date: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for all the good advice. I did the capacitor fix and it worked. Unfortunately, I have a lingering problem. I often get virtical rows of dots or specs. Also, sometimes the screen turns all blue or green. If I press on the board near the capcitor it effects the picture, often fixes the problem for a few hours. I notice there are some chips mounted on the back of the board just opposite the capacitor. There is a rubber pad mounted in the TV near those chips. I think when I press on the board, it is pressing those chips against the rubber pad. This seems to fix the problem. I resoldered the capacitor just to make sure that was not the problem. It seems fine. Any suggestions on how to deal with this?
Pat1 is offline  
post #2169 of 2188 Old 08-15-2012, 08:42 PM
Member
 
evofxdwg's Avatar
 
Join Date: Dec 2005
Location: Byron GA
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I thought i would update my Maxent status. I ordered the ebay capacitor kit a few months ago and installed it. Wasn't able to install them flat so i just bent the leads up a bit and soldered them. TV has worked fine except for minor issues with the channel number and input port display that was a problem before.

We did have a lightning event that apparently blew up the HDMI input and also damaged other electrical stuff in the house. So switched everything over to using component input on the TV.

So the $22 ebay cap fix has at least given this TV several more months of service. I will use it till it dies and then either find a cheap vid board or trash it.
evofxdwg is offline  
post #2170 of 2188 Old 08-16-2012, 09:33 PM - Thread Starter
AVS Special Member
 
jeremyhelling's Avatar
 
Join Date: Nov 2003
Location: Colorado, USA
Posts: 1,089
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 11
Wow, it hardly seems like 7yrs ago that I started this thread about this new promising 50" plasma that would give the almighty Panasonic a run for it's money at about half the price yet here we are... Almost 7yrs later and I just helped load my 50x3 onto the truck of it's new owner. It was bitter sweet to be sure. It performed flawlessly over it's life and never gave us so much as a single hiccup during all it's years or service. It's also sad to see it go since it was the first ever flat screen I ever bought and also the first flat screen most of my buddies saw in person. It's funny to see how far we've come since then but even with all the advancements in technology and what not this display still held it's own for sheer PQ. It may not have had a tuner, multiple HDMI inputs and many of the other features that have become standard since this one was new but I personally never missed any of those and was happy with the picture quality every time I fired it up to enjoy our evening entertainment. So, with a bit of a heavy heart I thank you all for joining me in making this upstart Maxent one of the greatest unknown 50" HD plasmas ever created. It was our little secret for quite a few years and aside from a few people having to replace cheap parts for a few bucks here and there I would say that our 'off-brand' display has suited us all very well. I just spoke with someone else on another forum who also purchased one at Best Buy 6yrs ago who was raving about how much use they've gotten out of it and also never had a problem.

But I digress.

Thanks to everyone who helped me and others in this forum and thanks to Maxent for producing a bargain display with the performance and dependability of it's substantially more expensive competition. When I started this thread the big question mark was the long-term reliability... I think we can put that debate to rest now.

cool.gif

Jer

'Build a man a fire and he stays warm for one night. Set a man afire and he stays warm for the rest of his life.'
jeremyhelling is offline  
post #2171 of 2188 Old 09-15-2012, 06:42 AM
Newbie
 
Greaseman's Avatar
 
Join Date: Dec 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Other than losing 1 AV port on mine it is still in use and working great (I bought mine back in NOV of 2005 after reading this thread). Thanks so Much for tipping everybody off to this monitor as it has been a purchase that I never regretted.

Around Christmas time I am going to by one of the 80" in series that go on sale, at that time I will re-purpose this as my gaming monitor for my computer, Looking forward to playing World of Tanks on a 50" in screen!!! biggrin.gif
Greaseman is offline  
post #2172 of 2188 Old 09-16-2012, 09:30 AM - Thread Starter
AVS Special Member
 
jeremyhelling's Avatar
 
Join Date: Nov 2003
Location: Colorado, USA
Posts: 1,089
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 11
Quote:
Originally Posted by Greaseman View Post

Other than losing 1 AV port on mine it is still in use and working great (I bought mine back in NOV of 2005 after reading this thread). Thanks so Much for tipping everybody off to this monitor as it has been a purchase that I never regretted.

Sure thing. This has been a useful community for me over the years so I was happy to contribute and am happy that these things didn't grenade and make me look bad. biggrin.gif
Quote:
Originally Posted by Greaseman View Post

Around Christmas time I am going to by one of the 80" in series that go on sale, at that time I will re-purpose this as my gaming monitor for my computer, Looking forward to playing World of Tanks on a 50" in screen!!! biggrin.gif

While I too am waiting to upgrade our current plasmas it won't be for something quite that large. And what's taking so long with the internet compatible and app capable TVs? This should be the norm by now and all TVs that are some should just come with this feature by now as it's really not a high dollar addition to any display. It should be like wireless remotes by now and should just be how they're made. Especially since it's probably the most useful innovation in TVs since the wireless remote. If you think about it, everything else is just slight increases in PQ compared to a feature like this. Oh well... some day I guess.

Jer

'Build a man a fire and he stays warm for one night. Set a man afire and he stays warm for the rest of his life.'
jeremyhelling is offline  
post #2173 of 2188 Old 09-16-2012, 07:44 PM
AVS Special Member
 
jonnythan's Avatar
 
Join Date: Jan 2006
Posts: 2,966
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
Virtually all big TVs are indeed internet connected and have apps. My new Panasonic ST50 does Netflix. MLB.tv, and a dozen other things.
jonnythan is offline  
post #2174 of 2188 Old 01-17-2013, 10:50 PM
Newbie
 
Greaseman's Avatar
 
Join Date: Dec 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well, I semi-retired my Maxent over the holidays, after 7 years I broke down and bought the 60" Vizio they had on sale all over the place during xmas ...(My wife grabbed me by the arm and dragged me away from the 80-90" models TV's that were on display and said don't even think about it).

I moved it to my computer room and tried to play world of tanks on it, I could get the graphics good but the fonts and the text were almost unreadable, so I just hooked up some rabbit ears with the digital receiver that I had picked up with the coupons the govt. was giving out a couple of years ago and the ota works great,

I'll probably hook the wii back up to it when I by an xbox for the main family room down the road, this maxent just keeps on chuggin along.smile.gif
Greaseman is offline  
post #2175 of 2188 Old 03-06-2013, 04:41 PM
AVS Special Member
 
tingham's Avatar
 
Join Date: Nov 2005
Location: Bucks County, PA
Posts: 2,652
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 18


My MX-50X3 has a just started doing this after all theses years. It happens about 10 seconds after start up. It still has a great picture and I would like to repair it if I could. I see one poster who has seen this problem but no one replied as to whether there was a fix for it. Anyone have any idea's?

Go Phillies! Go Eagles! Go Sixers! Go Flyers!
tingham is offline  
post #2176 of 2188 Old 03-07-2013, 08:58 AM - Thread Starter
AVS Special Member
 
jeremyhelling's Avatar
 
Join Date: Nov 2003
Location: Colorado, USA
Posts: 1,089
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 11
Quote:
Originally Posted by Greaseman View Post

Around Christmas time I am going to by one of the 80" in series that go on sale, at that time I will re-purpose this as my gaming monitor for my computer, Looking forward to playing World of Tanks on a 50" in screen!!! biggrin.gif
Quote:
Originally Posted by jeremyhelling View Post

While I too am waiting to upgrade our current plasmas it won't be for something quite that large. And what's taking so long with the internet compatible and app capable TVs? This should be the norm by now and all TVs that are some should just come with this feature by now as it's really not a high dollar addition to any display. It should be like wireless remotes by now and should just be how they're made. Especially since it's probably the most useful innovation in TVs since the wireless remote. If you think about it, everything else is just slight increases in PQ compared to a feature like this. Oh well... some day I guess.

Some day came and went. lol

We replaced this plasma and one other Vizio with two 51" Samsung plasmas and then at the end of November took advantage of the Black Friday deal that Sam's Club had and scored a couple of 60" Vizio smartTV LCD/LEDs and are quite happy. I know they're not the 80" that you were wanting to get but they're certainly more TV for the $ than we thought we would be able to get this soon. Just sold the 2nd of the two Samsungs on Craigslist yesterday so we're settled on the two new displays and are quite content. Hopefully you got your new TV too. cool.gif

Jer

'Build a man a fire and he stays warm for one night. Set a man afire and he stays warm for the rest of his life.'
jeremyhelling is offline  
post #2177 of 2188 Old 03-07-2013, 09:51 AM
AVS Special Member
 
tingham's Avatar
 
Join Date: Nov 2005
Location: Bucks County, PA
Posts: 2,652
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 18
Quote:
Originally Posted by jeremyhelling View Post

Wow, it hardly seems like 7yrs ago that I started this thread about this new promising 50" plasma that would give the almighty Panasonic a run for it's money at about half the price yet here we are... Almost 7yrs later and I just helped load my 50x3 onto the truck of it's new owner. It was bitter sweet to be sure. It performed flawlessly over it's life and never gave us so much as a single hiccup during all it's years or service. It's also sad to see it go since it was the first ever flat screen I ever bought and also the first flat screen most of my buddies saw in person. It's funny to see how far we've come since then but even with all the advancements in technology and what not this display still held it's own for sheer PQ. It may not have had a tuner, multiple HDMI inputs and many of the other features that have become standard since this one was new but I personally never missed any of those and was happy with the picture quality every time I fired it up to enjoy our evening entertainment. So, with a bit of a heavy heart I thank you all for joining me in making this upstart Maxent one of the greatest unknown 50" HD plasmas ever created. It was our little secret for quite a few years and aside from a few people having to replace cheap parts for a few bucks here and there I would say that our 'off-brand' display has suited us all very well. I just spoke with someone else on another forum who also purchased one at Best Buy 6yrs ago who was raving about how much use they've gotten out of it and also never had a problem.

But I digress.

Thanks to everyone who helped me and others in this forum and thanks to Maxent for producing a bargain display with the performance and dependability of it's substantially more expensive competition. When I started this thread the big question mark was the long-term reliability... I think we can put that debate to rest now.

cool.gif

+1 Jer...my Maxent has performed flawlessly all these years, (over 7 yrs since I purchased it on 2/3/06) until the last couple of days when I started experiencing vertical dots over the entire screen like my picture shows in my previous post. But, it looks like I'm back in business.smile.gif

I took the back access panel off and re-seated all the cable connections and checked some components, including the capacitor that everyone has had issues with. It looked fine to me and I have not had any warm up issues with the set.

I turned it back on and no more vertical dots on the screen on all inputs... hooray. Now I can continue watching it and it's very nice picture quality with those great inky blacks. The picture I posted was of a 4:3 image..notice how you don't see any side bars in that picture. I hope it lasts another 7 years.

Go Phillies! Go Eagles! Go Sixers! Go Flyers!
tingham is offline  
post #2178 of 2188 Old 03-09-2013, 01:59 PM
Newbie
 
lsnell0527's Avatar
 
Join Date: Mar 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just wanted to let everyone know that the capacitor fix for the Maxent 50X3 plasma input board worked great for us! We spent $18 and have our 50 inch plasma back just like new! Thank you so much for this thread! You saved us over $800!!!
lsnell0527 is offline  
post #2179 of 2188 Old 03-19-2013, 04:53 AM
Newbie
 
Greaseman's Avatar
 
Join Date: Dec 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by jeremyhelling View Post


Some day came and went. lol

We replaced this plasma and one other Vizio with two 51" Samsung plasmas and then at the end of November took advantage of the Black Friday deal that Sam's Club had and scored a couple of 60" Vizio smartTV LCD/LEDs and are quite happy. I know they're not the 80" that you were wanting to get but they're certainly more TV for the $ than we thought we would be able to get this soon. Just sold the 2nd of the two Samsungs on Craigslist yesterday so we're settled on the two new displays and are quite content. Hopefully you got your new TV too. cool.gif

Yep , I'm happy with this Vizio 60" but the internet apps leave something to be desired, they seem to lag real bad but I think it may have to do with my wireless signal in the area that it is in, I'm going to try hard wiring it and see if I have any luck.

But no complaints about pic quality though seems to be great on the TV side of things.

It's funny though, had the family over at Christmas and new years at the new house. They came in and saw the new Vizio and was like wow, then they came into my computer room where I had some football on and they were like " jesus and another big screen in here" I had to pull the rabbit ears out from the back of the TV to show them because they couldn't believe how good of picture I was getting OTA with this old maxent.
Greaseman is offline  
post #2180 of 2188 Old 03-19-2013, 09:25 AM - Thread Starter
AVS Special Member
 
jeremyhelling's Avatar
 
Join Date: Nov 2003
Location: Colorado, USA
Posts: 1,089
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 11
Quote:
Originally Posted by Greaseman View Post

Quote:
Originally Posted by jeremyhelling View Post


Some day came and went. lol

We replaced this plasma and one other Vizio with two 51" Samsung plasmas and then at the end of November took advantage of the Black Friday deal that Sam's Club had and scored a couple of 60" Vizio smartTV LCD/LEDs and are quite happy. I know they're not the 80" that you were wanting to get but they're certainly more TV for the $ than we thought we would be able to get this soon. Just sold the 2nd of the two Samsungs on Craigslist yesterday so we're settled on the two new displays and are quite content. Hopefully you got your new TV too. cool.gif

Yep , I'm happy with this Vizio 60" but the internet apps leave something to be desired, they seem to lag real bad but I think it may have to do with my wireless signal in the area that it is in, I'm going to try hard wiring it and see if I have any luck.

But no complaints about pic quality though seems to be great on the TV side of things.

It's funny though, had the family over at Christmas and new years at the new house. They came in and saw the new Vizio and was like wow, then they came into my computer room where I had some football on and they were like " jesus and another big screen in here" I had to pull the rabbit ears out from the back of the TV to show them because they couldn't believe how good of picture I was getting OTA with this old maxent.

I pretty much don't use the apps at all. The interface is clunky & slow and I took the time to go through them all and set them all up and haven't gone to them since. The 'smart' portion is poorly thought out and you can tell it was an afterthought to be able to put 'smarTV' on it to sell a few more units. The picture itself is just alright. I would give it a higher rating but the backlighting is pretty terrible. It's not even and has quite a few splotches and on dark scenes and when the power comes on (PQ is pretty unimportant here obviously) the uneven backlighting is pretty apparent. Oh well, for what I paid for two of them I'm content. I had those two 51" Samsung plasmas and the picture quality was SUBSTANTIALLY better and that's even considering the Samsung was 720p & this Vizio is 1080p. If I had it to do over again I would probably just keep those and call it a day but what's done is done. I got $100 each more for those Samsungs on Craigslist than we paid through a really good sale so that made this 60" Vizio LEDs about $599ea after it was all said and done so I have zero complaints. For our use they'll work just fine.

I miss having OTA HDTV a decade or so ago and having company over and then watching the smoke come out of their ears as I explained that that amazing picture they were seeing was free via rabbit ears. cool.gif

Jer

'Build a man a fire and he stays warm for one night. Set a man afire and he stays warm for the rest of his life.'
jeremyhelling is offline  
post #2181 of 2188 Old 02-18-2014, 02:13 PM
Newbie
 
w4ta's Avatar
 
Join Date: Jun 2006
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the Maxent 50x3 fix photos. Performed the entire fix in fifteen minutes (pulling the TV off the wall, removing the plate, swapping capacitor, and re-hanging TV).

I did not de-solder. Just tugged gently on the capacitor with forceps and it popped off, leaving the plastic capacitor-base on the board, which I lifted off with no resistance. I had never soldered before, but watched a number of online videos in preparation for this fix. Also practiced on an old circuit board.

I've had the TV for several years and have watched the flickering increase... until the screen would remain black for 10 minutes prior to warm-up. It now turns on instantaneously and looks great. Thanks to all who posted on this issue!!!!
w4ta is offline  
post #2182 of 2188 Old 03-20-2014, 01:13 PM
Newbie
 
Cromulon's Avatar
 
Join Date: Mar 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Created an account just to reply. Prompted by this thread, we bought this tv way back in late 2005 and have loved it ever since. Is one of our best purchases.

 

Around 2008 or so, it stopped responding to IR remote commands. Luckily we had just built a htpc which we used to control the tv via a long serial console cable. This setup worked solid for years until we moved in 2013. Since then the IR remote has worked just fine!

 

Our 50x3 slowly developed the flicker problem over the years. We got used to waiting an hour for the tv to warm up. The flicker got worse since the move so last night I fixed it based on the info in this thread. Was pretty scary in there close to all the other components with the hot iron. Burned my thumb. It comes on instantly now!

 

I wonder how many of these are still alive. Post updates!

Cromulon is offline  
post #2183 of 2188 Old 06-01-2014, 07:04 PM
Newbie
 
Realbiker's Avatar
 
Join Date: Jun 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I have had my Maxent plasma 52"? for 7 years as well and now the screen flickers after the tv warms up...never had one problem until now.  Unplug it and let it sit and it will work perfect for about 5 minutes then the flickering starts until screen eventually goes black.  Any ideas?  It's been too good of a TV for all these years to boot it out to the curb!

Realbiker is offline  
post #2184 of 2188 Old 06-01-2014, 08:05 PM
Newbie
 
mvandell's Avatar
 
Join Date: Oct 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I had similar symptoms, although for me the TV started up flickering and would then eventually stop flickering and seem to work OK. I had a friend who knows how to solder replace the capacitor that is mentioned in this thread (just search for capacitor in this thread). TV works perfectly now and I think the picture is better after as well. Not sure if this will work for you but might be worth trying...
mvandell is offline  
post #2185 of 2188 Old 06-02-2014, 04:07 AM
Newbie
 
Realbiker's Avatar
 
Join Date: Jun 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I'm going to give that a try, but it seems I have the opposite symtoms everyone else was having...works perfect when you first turn it on, then it begins to flicker the warmer it gets and finally goes to black.:confused:

Realbiker is offline  
post #2186 of 2188 Old 06-22-2014, 09:07 PM
Newbie
 
Join Date: Jun 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
I'm looking for a stand for a Maxent MX-50x5. Does anybody have any ideas where I might find one?
Loricossey1962 is offline  
post #2187 of 2188 Old 06-23-2014, 02:30 PM
AVS Special Member
 
EscapeVelocity's Avatar
 
Join Date: Nov 2006
Location: Charleston, SC
Posts: 5,652
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 117 Post(s)
Liked: 117
Who made the panels on these?

Vizio VP322 Plasma / Vizio GV42LF LCD / Denon 2200 Silicon Image DVD / Panasonic S97 Faroudja Genesis DVD / Oppo 970HD Mediatek DVD / Oppo 983H Anchor Bay DVD / Panasonic LX-600 Laserdisc / Aiwa MX100 Multi-region VCR / JVC S7600 S-VHS / PS2 / Sega Genesis / Nintendo SNES / Roku 2 XS & HD-XR / Realistic STA-90 Reciever / Realistic Minimus 7 / Antennacraft G1483 Hoverman / Belden 7915A RG6 / Channel Master 7777 Titan 2 UHF/VHF / Panasonic AX-200u / Optoma Graywolf 92" / Draper Luma 92"
EscapeVelocity is offline  
post #2188 of 2188 Old 06-27-2014, 12:06 AM
Newbie
 
Join Date: Jun 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Quote:
Originally Posted by mproper View Post
Boo-Yah! Just did the repair above.

$1.58 (after tax) and 20 minutes of my time = fixed TV. Awesome!

That makes me wonder if I can find some broken Maxents and just fix them and load up my house with Plasmas for cheap. Time to hit up Craigslist.
I found an old one on cl for free "dont know if I can even say that" I am getting the new cap tomarrow bit does any body have pics of the installed cap I noticed that there are no holes for the cap leads like there are in other electronics also does any body have a stand they dont need mine is missing the stand speakers and the small back panle to access the cap any help would be appreciated I just want my tv working so I can play gta
As for sounding off as menconed in a previous thread lots see who still has one mine is #54296E02814

Last edited by maxent50inch; 06-27-2014 at 12:26 AM.
maxent50inch is offline  
Reply Plasma Flat Panel Displays

Tags
Panasonic Viera Tc P50x3 50 Inch 720p 600 Hz Plasma Hdtv
Gear in this thread - P50x3 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off