Samsung FPT5084, 50", 1080p, 15000:1 Contrast ratio. - Page 145 - AVS Forum
Forum Jump: 
 
Thread Tools
Old 09-12-2011, 08:07 PM
Senior Member
 
jaymerkramer's Avatar
 
Join Date: Jul 2006
Location: St. Peters, Mo.
Posts: 383
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Most likely a power supply board but possibly took out other boards along the way. Not a hard fix if that is all it is but it would suck to sink the money in to it and that not be it. Good luck!

http://www.discount-merchant.com/Pro...25&Click=54985

http://www.youtube.com/watch?v=E17Wp0MyFe4
jaymerkramer is offline  
Sponsored Links
Advertisement
 
Old 09-13-2011, 07:26 AM
Member
 
DapperDanMan's Avatar
 
Join Date: Oct 2007
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by PaulInParkSlope View Post

My 5084 just went .

It fizzed, and a big cloud of smoke came out of the back. Its dead, and certainly out of warranty. Now what?

I'd imagine that fixing it would cost much less than a new 50" 1080p plasma. Perhaps give Samsung a call and have them send a tech out? You'd have to pay for the visit, but probably better than trying to self-diagnose and potentially buying and installing the wrong parts.

I don't want FOP, *********! I'm a Dapper Dan man!
DapperDanMan is offline  
Old 09-17-2011, 07:09 PM
Member
 
MilesToEmpty's Avatar
 
Join Date: Feb 2008
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Mine also died, just 2 weeks ago.

Repair center came out, tried swapping out the Logic Board, and it didn't fix it.

Said I needed a new panel and that included everything other then the logic board, cost would be $900.

Its unacceptable for a TV with less then 200 panel hours on it.

I want to fix it, but no one on any of the plasma forums online have any suggestions. Just to buy a new $1500 tv instead of trying to troubleshoot it.

Here's my original problem thread:
Quote:
We purchased our 5084 brand new, like 3 years ago.

Since then it has only ever been used for BluRay movies. Im going to guess it has around 300 hours on it.

After we had it about 4 months we had a loud buzzing noise and a service tech did something and it fixed the problem.

Tonight I went and turned it on. And after you hear everything click on it went POP. Sounded like the side farthest from the power cord.

And well, I have no picture now. Well, thats a lie. I do have a picture, but I get this on every input. The center rectangle refreshes. And the lines in it scroll from left to right.

It also has a green and blue sparkle that you can see in the photos all over the black.


The tech that came out said the "panel is bad" and "this is all the "panel."" He was referring to everything except the main logic board. He did try a new logic board, and it didn't solve anything.





Here's link to a video showing it "refreshing"

MilesToEmpty is offline  
Old 09-19-2011, 11:54 AM
Newbie
 
Johnny xP's Avatar
 
Join Date: Apr 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi all,

I have three vertical, 2" bars on the left side of my screen. They came about after the unit was shut off and on a few times. The bars originally were white but are now mixed with blue, green and red. I'm assuming the display panel will have to be replaced. I appreciate any input on this issue.

The Picture included is with the cable box off to clarify the bars.
LL
Johnny xP is offline  
Old 10-11-2013, 07:19 AM
Member
 
jbutle4's Avatar
 
Join Date: Aug 2005
Posts: 147
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My 5084 went out last night. When I tried to turn it on it clicked a few times, but never came on. Now I have a blinking red light.

My question is, since this model was manufactured during the time frame that is indicated in the class action suite, why isn't this model on the list of TVs covered for repair?
jbutle4 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off