Toshiba 42HP66 red speckles. LG glass. Zeinith owners read too. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 06-14-2007, 05:21 PM - Thread Starter
Member
 
bwhitish's Avatar
 
Join Date: Sep 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well my Toshiba 42HP66 has developed red speckles. I called toshiba and they set up a file for me and had me fax a copy of my original sales receipt. They then contacted teletron(local service company here in Seattle). They came out today and the minute I turned it on and told the serviceman that it was LG gless he knew exactly what was wrong. He ordered a new panel assembly that comes with three boards. He said he had seen a lot of LG's and Zeinith's with the same problem and that LG was aware of it. He said it should be 5-10 working days till they get the assembly in and then it will take a couple of days in the shop. They are going to send some one to pick it up when the parts arrive. Hope this info helps anybody with this problem.
bwhitish is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-15-2007, 05:12 AM
Advanced Member
 
dark1x's Avatar
 
Join Date: Jan 2006
Posts: 869
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
What exactly did they look like?

My first plasma was a Toshiba (with Panasonic glass) and it had an issue with wierd colored speckles that would appear in certain situations...
dark1x is offline  
post #3 of 5 Old 06-15-2007, 11:47 AM - Thread Starter
Member
 
bwhitish's Avatar
 
Join Date: Sep 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
They are like individual pixels that are red instead of what ever color they are supposed to be. And they move all over. They seem to be worse on start up. And they are easiest to see against black background.
bwhitish is offline  
post #4 of 5 Old 09-21-2007, 04:45 PM
Member
 
lanceroni's Avatar
 
Join Date: Oct 2006
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Funny, I had my tv repaired at Teletron too for the same problem. The red pixels are still there however... As you said they seem to be more prevalent at start up.
lanceroni is offline  
post #5 of 5 Old 09-25-2007, 11:41 PM - Thread Starter
Member
 
bwhitish's Avatar
 
Join Date: Sep 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Since I got mine back it has worked perfect. No trace of the red dots!
bwhitish is offline  
Reply Plasma Flat Panel Displays

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off