MONOPRICE is being sluggish with my RMA credit :( - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 02-21-2013, 02:00 PM - Thread Starter
AVS Forum Special Member
 
KBMAN's Avatar
 
Join Date: Jan 2002
Location: Grass Valley, CA
Posts: 3,437
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 255 Post(s)
Liked: 139
Sent the RMA this last Sunday, and now (Thursday), the RMA in my account is still not fully processed. I need the credit so that I can use that towards the new 40ft ultra slim Redmere cable. I've chatted with monoprice a couple times, but it seems that the final deal is with the financial dept. This is frustrating mad.gif
KBMAN is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-24-2013, 12:27 PM - Thread Starter
AVS Forum Special Member
 
KBMAN's Avatar
 
Join Date: Jan 2002
Location: Grass Valley, CA
Posts: 3,437
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 255 Post(s)
Liked: 139
finally got my credit yesterday, but I did not receive an email; I had to go to their website to see it.....whatever I guess rolleyes.gif
KBMAN is offline  
post #3 of 5 Old 02-24-2013, 01:02 PM
Advanced Member
 
Doctego's Avatar
 
Join Date: Nov 2012
Location: Central Jersey
Posts: 758
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 42
I don't really see the issue to be honest with you. You put it into the mail last Sunday, so your return actually didn't go out until Monday. 5 days for shipping, receiving, and processing for a company is a long time? Doesn't seem like it to me.

We are here to help you. Please help us to help you. If you provide incomplete information, at best, we can give you an incomplete response.
Doctego is offline  
 
post #4 of 5 Old 02-24-2013, 01:07 PM
AVS Forum Special Member
 
olyteddy's Avatar
 
Join Date: Oct 2005
Posts: 4,631
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 523 Post(s)
Liked: 912
Quote:
Originally Posted by KBMAN View Post

Sent the RMA this last Sunday, and now (Thursday), the RMA in my account is still not fully processed. I need the credit so that I can use that towards the new 40ft ultra slim Redmere cable. I've chatted with monoprice a couple times, but it seems that the final deal is with the financial dept. This is frustrating mad.gif

Quote:
Originally Posted by KBMAN View Post

finally got my credit yesterday, but I did not receive an email; I had to go to their website to see it.....whatever I guess rolleyes.gif
You got the RMA on Sunday. How did you ship the goods back? Star Trek Transporter? 1 week turnaround on a return does not seem at all unreasonable but.....whatever I guess rolleyes.gif

🔥🔥🔥 Sent from my Samsung Note 7 Using Ove Glove™ 🔥🔥🔥
olyteddy is offline  
post #5 of 5 Old 03-13-2013, 12:46 PM - Thread Starter
AVS Forum Special Member
 
KBMAN's Avatar
 
Join Date: Jan 2002
Location: Grass Valley, CA
Posts: 3,437
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 255 Post(s)
Liked: 139
You guys, I cut the ends off the old cable and sent them a pic right away....that's why I was a little ticked off....just an FYI..
KBMAN is offline  
Sponsored Links
Advertisement
 
Reply HDMI Q&A - The One Connector World



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off