LG BH200 DVD playback problem - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 10-04-2008, 12:21 PM - Thread Starter
jgib01's Avatar
Join Date: Apr 2004
Location: Lethbridge, AB
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My BH200 is suddenly unable to playback DVD's. Here's the problem... it seems to have lost it's ability to follow the DVD program chain. It won't auto play DVDs when inserted. I can then get the menu up by pushing the menu button, but after pushing play, it will play the first item (be that FBI warning, THX logo, etc.) and then won't continue. On one title, it is freezing part-way through the first item played, which item happens to be a 4 minute video title.

I don't know if this is related or not, but it also froze 2 nights ago when I was playing the Chris Botti Blu-ray, after fast forwarding through part of one of the chapters. Then last night, while watching Enchanted, I was getting lots of audio drop-outs about 3/4 of the way through the movie (switching from TrueHD to DD soundtrack seemed to fix this, so this may have been something with my audio receiver versus the player itself).

Anyone else out there ever experience anything similar to this with this player? Any suggestions as to what I might do myself to try to fix it, short of taking it in for service? FYI, I have the June firmware, which seemed to have been working for the past few months, and I've not made any setting changes to the player for some time. Apart from above gltches, Blu-ray seems to be fine, and HD DVD is playing OK too.
jgib01 is offline  
Sponsored Links
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off