MK subwoofer pumping with phono - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 11 Old 04-16-2014, 01:11 PM - Thread Starter
Newbie
 
Buffordlee's Avatar
 
Join Date: Apr 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Hey there I have an older M&K subwoofer The Volkswoofer and it sounds and plays great recently added a Project Music Hall 2.2 turntable to my system and all seemed fine, now the subwoofer is pumping when playing the Phono, I have an Acurus CD player and the MK is fine when it's Playing my preamp is a Sherbourne 1, eventually the sub will start to sound like a helicopter when playing vinyl  Please help 

Buffordlee is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 04-16-2014, 01:33 PM
AVS Addicted Member
 
Ratman's Avatar
 
Join Date: May 2002
Location: Collingswood, N.J.
Posts: 15,355
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 534 Post(s)
Liked: 463
Who "setup" your TT? I'd take a stab that something is not weighted, aligned, yada, yada, properly.
In other words, look to the TT and not the "system" (since all works well).

My initial guess would be subsonic "wow" that is possible due to poor setup and/or cabling.
Buffordlee likes this.
Ratman is online now  
post #3 of 11 Old 04-16-2014, 01:40 PM - Thread Starter
Newbie
 
Buffordlee's Avatar
 
Join Date: Apr 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Well I would be the one on set up cart come factory set up, I also have a BIC F12 sub in the same set up it play fines, I have played around a little with the weight adjustment with no luck and different records Thanks 

Buffordlee is offline  
post #4 of 11 Old 04-16-2014, 02:07 PM
 
arnyk's Avatar
 
Join Date: Oct 2002
Location: Grosse Pointe Woods, MI
Posts: 14,530
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 851 Post(s)
Liked: 1214
Quote:
Originally Posted by Buffordlee View Post

Hey there I have an older M&K subwoofer The Volkswoofer and it sounds and plays great recently added a Project Music Hall 2.2 turntable to my system and all seemed fine, now the subwoofer is pumping when playing the Phono, I have an Acurus CD player and the MK is fine when it's Playing my preamp is a Sherbourne 1, eventually the sub will start to sound like a helicopter when playing vinyl  Please help 

Acoustic feedback.

(1) Improve the isolation between the TT and the subwoofer which may require acoustic or mechanical isolation. Sometimes closing the cover on the TT can help..

(2) Simply add an switchable electrical high pass filter, probably between the preamp and the power amp.

A useful alternative would be found on this page in the form of an Harrison FMOD:

http://www.parts-express.com/cat/in-line-crossovers/405

You want the lowest frequency rated item that is still effective, which is impossible to predict over the web.
arnyk is offline  
post #5 of 11 Old 04-16-2014, 03:19 PM - Thread Starter
Newbie
 
Buffordlee's Avatar
 
Join Date: Apr 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Thank you for your response I don't that great of a system but I enjoy it greatly it really sounds good to us I will try the sloping crossover Thanks again

Buffordlee is offline  
post #6 of 11 Old 04-16-2014, 03:20 PM
AVS Addicted Member
 
Ratman's Avatar
 
Join Date: May 2002
Location: Collingswood, N.J.
Posts: 15,355
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 534 Post(s)
Liked: 463
Quote:
Originally Posted by Buffordlee View Post

Well I would be the one on set up cart come factory set up, I also have a BIC F12 sub in the same set up it play fines, I have played around a little with the weight adjustment with no luck and different records Thanks 
So you have two subs, a new TT, an one sub has a problem and the other doesn't?
Ratman is online now  
post #7 of 11 Old 04-16-2014, 05:19 PM
AVS Special Member
 
commsysman's Avatar
 
Join Date: Dec 2007
Location: Southern California
Posts: 5,514
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 258 Post(s)
Liked: 293
In most setups, it is impossible to prevent acoustic feedback from the subwoofer to the turntable.

When you have a warped record, or extreme low bass content on the record, it is very tough to isolate the turntable enough to prevent a microphonic oscillation from occuring.

I have to turn off my subwoofer on a number of records; that is all one can do.

If your main speakers go low enough, that should not be a problem.

The problem is much worse with a "live' floor than a concrete slab floor.
Buffordlee likes this.
commsysman is offline  
post #8 of 11 Old 04-16-2014, 05:41 PM - Thread Starter
Newbie
 
Buffordlee's Avatar
 
Join Date: Apr 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Yes I have 2 I run a set of CM2 off of the Bic and a set of CM1 off the M&K and I have 4 MA500 Marantz amps to run them, I know a weird set up but you get what you can Thanks

Buffordlee is offline  
post #9 of 11 Old 04-16-2014, 05:45 PM - Thread Starter
Newbie
 
Buffordlee's Avatar
 
Join Date: Apr 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Your right by all accounts raised floor and it started with a not so flat record, but it seems like I must shut it down for several minutes to get it right again, I think I'm going your route and install a switch to shut it down while playing vinyl I have a Bic sub in another location that does fine on LPs I think I can live without the M&K on records Thanks a bunch

Buffordlee is offline  
post #10 of 11 Old 04-24-2014, 06:52 AM
Member
 
Dezmond's Avatar
 
Join Date: Jan 2010
Location: WNY
Posts: 172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 12
Probably need a low cut or subsonic filter.
Dezmond is offline  
post #11 of 11 Old 04-24-2014, 02:40 PM
AVS Special Member
 
A9X-308's Avatar
 
Join Date: Mar 2008
Location: Australia
Posts: 5,926
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 428 Post(s)
Liked: 277
Quote:
Originally Posted by Dezmond View Post

Probably need a low cut or subsonic filter.
Definitely needs a HPF. Try 20Hz > 2nd order.
A9X-308 is offline  
Sponsored Links
Advertisement
 
Reply 2-Channel Audio

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off