Pioneer LaserDisc / DVD thread - Page 28 - AVS Forum
Forum Jump: 
 
Thread Tools
Old 02-28-2013, 01:35 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thank you for your help, very much appeciated, regards Edward
estott1967 is offline  
Sponsored Links
Advertisement
 
Old 02-28-2013, 03:20 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi all. Where would be the best place to buy pioneer belts for my laserdisc players. Thank you
estott1967 is offline  
Old 02-28-2013, 03:20 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi all. Where would be the best place to buy pioneer belts for my laserdisc players. Thank you
estott1967 is offline  
Old 02-28-2013, 05:16 PM
Senior Member
 
erhurd's Avatar
 
Join Date: May 2008
Location: San Diego County, southern California, USA, Planet Earth
Posts: 481
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 41
I had to replace a load belt for my Pioneer CLD-D702 last year in April. I found the needed belt here:

http://parts.pioneerelectronics.com/

Hope this helps!

Edwin R. Hurd
AVS Forums Lurker-In-Training!

My Tight-space A/V Setup
erhurd is offline  
Old 02-28-2013, 05:55 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
thank you
estott1967 is offline  
Old 03-04-2013, 06:00 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi All, good news, laserdisc_temple is no longer a registered user. Ebay and Paypal have obviously looked at this site and bluray.com and avsforum and have closed his ebay account. I wish to thank everyone for their help from a grateful forum member from Australia. Also others are interested in Ricardo.
estott1967 is offline  
Old 03-12-2013, 12:20 AM
Member
 
Mike Brantley's Avatar
 
Join Date: Jun 2001
Location: Mobile, Alabama
Posts: 162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am having laserdisc player problems. I have two Mitsubishi M-7057 laserdisc players (similar to Pioneer CLD-704), and they are both exhibiting the same problem after years of trouble-free service. Some discs play just fine, but others are showing horizontal flickering banding and even skipping. Both players starting doing this after I pressed them into service again to attempt to watch some laserdiscs after the players were idle for some months. Any ideas what the problem could be? (Hey, Kurtis!)

My third laserdisc player, a lesser model Pioneer CLD-503, will no longer eject the tray. Think that's a belt?

I am currently also shopping for another LD player. Even if I get these units fixed up, I am nervous about being able to play my large collection of big platters for many years to come, as I desire.
Mike Brantley is offline  
Old 03-12-2013, 10:46 AM
Senior Member
 
erhurd's Avatar
 
Join Date: May 2008
Location: San Diego County, southern California, USA, Planet Earth
Posts: 481
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 41
I cannot offer you any assistance with your problematic Mitsubishi laserdisc players but your Pioneer player definitely sounds like it is in need of a replacement load belt. I had a similar repair made last year in April.

Edwin R. Hurd
AVS Forums Lurker-In-Training!

My Tight-space A/V Setup
erhurd is offline  
Old 03-12-2013, 04:22 PM
AVS Club Gold
 
Kurtis Bahr's Avatar
 
Join Date: Jun 2002
Location: Northern Virginia
Posts: 825
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 23
The first thing you need to do is replace the grip ring that goes on top of the spindle motor. Then try the 7057's again. Over the years the rubber looses it tackiness and the LDs actually slip during startup and stop and can even slip during speed changes. It should play CDs just fine.

For the 503 I agree it could be the loading belt, you would need to take the top off and see exactly what is happening.
Kurtis Bahr is offline  
Old 03-12-2013, 09:04 PM
Member
 
Mike Brantley's Avatar
 
Join Date: Jun 2001
Location: Mobile, Alabama
Posts: 162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Edwin and Kurtis,

Thank you both. I will first attempt a more vigorous cleaning of the rubber ring and see if a bit of "resurfacing" will help it grip. I had tried this before, but only with cotton swabs and alcohol with really no significant force applied. I probably didn't accomplish much.

If I need to replace the ring for either player or both, is there a source for this part? Thanks!

The 503 model with the load belt problem will get my attention after I address the Mitsubisihi players. And I am still seeking an additional player in good working order if anyone has one stored away. Being unable to play my laserdiscs despite owning a trio of players has rather unnerved me. Heh.
Mike Brantley is offline  
Old 03-12-2013, 10:36 PM
Member
 
Mike Brantley's Avatar
 
Join Date: Jun 2001
Location: Mobile, Alabama
Posts: 162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
More thorough cleaning/scrubbing on the rubber in one of the players (didn't try the other) did not solve the problem. I think I just found the necessary part and will order ... http://parts.pioneerelectronics.com/part.asp?productNum=VEB1237
Mike Brantley is offline  
Old 03-13-2013, 08:38 AM
AVS Special Member
 
subavision212's Avatar
 
Join Date: Sep 2007
Posts: 1,451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 25
So I am looking for some setup advice. I have a CLD-99 that I use in my dedicated HT. It is hooked up via s-video and optical to my DVDO EDGE then via HDMI to my Onkyo 5507 (set to pass through) and out (via HDMI) to my ISF calibrated Panasonic 65PZ850U plasma. PQ is okay but not too good. Was curious if I would be better off hooking up another way. Haven't tried using the composite connection (the 99’s comb filter is supposed to be fairly good I've read) but was also wondering if I should just try hooking video output directly to the Panny from the EDGE. I'm not the most knowledgable techno person and know that there are definite PQ limitations to lasers but thought some expert here might have some starting tips to try and see if I could improve things a bit. Any suggestions would be greatly appreciated.

subavision212 is offline  
Old 03-13-2013, 10:33 AM
Senior Member
 
Retspin's Avatar
 
Join Date: Dec 2005
Location: Wilson, NC
Posts: 202
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I have my CLD-D406 connected to my DVDO Edge using composite since it doesn't have s video outputs. I have a Panasonic 50G10 plasma and I'm pleased with the results. I know there are better players out there, but I think the Edge makes a big difference with it's video processing power.
Retspin is online now  
Old 03-13-2013, 11:35 AM
Newbie
 
raphaelmsx's Avatar
 
Join Date: Feb 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,

I just bought a Pioneer VP-1000, but it came DOA, after initial spin-up, it does not recognize if the disc is CAV or CLV (both LEDs stay lit) and it displays random dots on a black background. If you hit play without any disc, it recognizes there's no disc and then opens the cover. Can someone help me fix this, or point me to the problem?

I've uploaded the video of what's happening on http://www.youtube.com/watch?v=6YOtjfIhsd8

Thank you very much!
raphaelmsx is offline  
Old 03-13-2013, 03:44 PM
AVS Club Gold
 
Kurtis Bahr's Avatar
 
Join Date: Jun 2002
Location: Northern Virginia
Posts: 825
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 23
Quote:
Originally Posted by Mike Brantley View Post

More thorough cleaning/scrubbing on the rubber in one of the players (didn't try the other) did not solve the problem. I think I just found the necessary part and will order ... http://parts.pioneerelectronics.com/part.asp?productNum=VEB1237

Yes, that is the Pioneer part number you need.
Kurtis Bahr is offline  
Old 03-13-2013, 03:46 PM
AVS Club Gold
 
Kurtis Bahr's Avatar
 
Join Date: Jun 2002
Location: Northern Virginia
Posts: 825
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 23
Quote:
Originally Posted by subavision212 View Post

So I am looking for some setup advice. I have a CLD-99 that I use in my dedicated HT. It is hooked up via s-video and optical to my DVDO EDGE then via HDMI to my Onkyo 5507 (set to pass through) and out (via HDMI) to my ISF calibrated Panasonic 65PZ850U plasma. PQ is okay but not too good. Was curious if I would be better off hooking up another way. Haven't tried using the composite connection (the 99’s comb filter is supposed to be fairly good I've read) but was also wondering if I should just try hooking video output directly to the Panny from the EDGE. I'm not the most knowledgable techno person and know that there are definite PQ limitations to lasers but thought some expert here might have some starting tips to try and see if I could improve things a bit. Any suggestions would be greatly appreciated.

Have you tried turning off the DNR in the 99. If it applies DNR and the DVDO has digital processing then double digital processing can look pretty bad.
Kurtis Bahr is offline  
Old 03-13-2013, 08:57 PM
Member
 
Signal64's Avatar
 
Join Date: May 2007
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Still anxious to hear from Duncan who is apparently responding to others.
Signal64 is offline  
Old 03-14-2013, 08:37 AM
AVS Special Member
 
subavision212's Avatar
 
Join Date: Sep 2007
Posts: 1,451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 25
Quote:
Originally Posted by Kurtis Bahr View Post

Have you tried turning off the DNR in the 99. If it applies DNR and the DVDO has digital processing then double digital processing can look pretty bad.
Yes, that's how I've had it set up since I got the player. Making adjustments in the DVDO's picture adjustments helps but picture still isn't all that great. I have the output set to 1080p since that's what my display is. It's no biggie. I'm making adjustments in the audio connections and just figured to try and see if I could improve the PQ since I haven't spent too much time with the lasers until recently. Going to try running s-video to my Onkyo 5507 and then to the display and see if it upscales better. Thanks for the input.

subavision212 is offline  
Old 03-14-2013, 04:13 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
laserdisc temple, cararte, has now changed his name to magic_80s

beware magic_80s
estott1967 is offline  
Old 03-14-2013, 04:13 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
laserdisc_temple, cararte, has now changed his name to magic_80s

beware magic_80s
estott1967 is offline  
Old 03-14-2013, 04:50 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
yes, another thing I have noticed is that magic_80s uses well known cpmpany names and inserts a hyphen inbetween each name. eg. mv_cinema magic_80s laserdisc_temple


beware magic_80s
estott1967 is offline  
Old 03-14-2013, 08:14 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
magic_80s is no longer a registered user, cararte got magic_80s up and running today. I got magic_80s closed today.
estott1967 is offline  
Old 03-16-2013, 09:54 PM
Newbie
 
eldaddio13's Avatar
 
Join Date: Mar 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Forgive me for my ignorance being new to the LD Player world and this forum, but I was just wondering what adding larger feet to some players does if anything? I'm guessing possibly some kind of vibration dampening??? Also, what are these "modifications" I hear people talking about, and what are their advantages? Can modifications be made to increase video resolution or something??? Bare with me please, cuz I'm trying to learn here.
eldaddio13 is offline  
Old 03-18-2013, 06:34 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Reinbo. My ebay user id is estott1967. if you go to ebay you can report him for spamming you about a refund or returning goods. you can also give them my ebay id and tell them he deceived me with the same excuses that he deceived you. they may then permanently suspend cararte i.e laserdisc_temple or now known as magic_80s
estott1967 is offline  
Old 03-18-2013, 07:11 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Reinbo. What name was magic_80s going under when you had trouble with him.


beware magic_80s
estott1967 is offline  
Old 03-18-2013, 09:39 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
magic_80s is now selling the unit msb ls1 for 800 gbpounds on ebay. this is the same unit that I paid 450 gbpounds for that did not arrive in the mail, that magic_80s did not refund monies for. his tracking number was invalid etc
beware magic_80s
estott1967 is offline  
Old 03-19-2013, 11:02 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
the msb ls-1 is based on the low end panasonic 600
estott1967 is offline  
Old 03-23-2013, 03:45 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have some of those rubber feet on the bottom of one of my elite players. However I found the player still had some jitter occassionly. I solved the problem by placing the offending player between two other laserdisc players. Funny thing - no jitter. In the old days with turntables you could place them on besser bricks to reduce wow and flutter. the besser bricks provided a rock solid (pun) foundation.
estott1967 is offline  
Old 03-23-2013, 03:48 PM
Member
 
estott1967's Avatar
 
Join Date: Feb 2013
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Eldaddio13, that is probably the best starting advice, get a good foundation. Then cables, line doubler or upscaler, Then experiment with amplifiers, settings, etc. Last have fun and watch movies.
estott1967 is offline  
Old 03-23-2013, 06:31 PM
Member
 
Mike Brantley's Avatar
 
Join Date: Jun 2001
Location: Mobile, Alabama
Posts: 162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Kurtis, thanks again for the advice -- and, in fact, for selling me one my of two Mitsubishi 7057 (Pioneer 704 clone) players several years ago. I just got that one up and running perfectly again, replacing the grip ring -- or "cushion," as Pioneer calls it on the parts site. Just a simple matter of peeling off the old ring and applying the self-adhesive one like a sticker. I will tackle the same job on the other Mitsubishi soon.

For those who may like to know, the little ring is $11.75 from Pioneer via the link in my prior post. I ordered two, and felt a bit cheated that the total cost with shipping and "handling" was over $40 for both. They came in a flat envelope. Indeed, Pioneer could have mailed them both with a single regular postage stamp. Oh, well.... at least I don't have to ship the player away and risk damage to it. That's worth the $40.

I have not yet looked into the Pioneer 503 player I have with the suspected bad load belt. That's to come.
Mike Brantley is offline  
 

Tags
Pioneer , Pioneer Brand , Pioneer Electronics
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off