built in dvd player is messing up - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 07-29-2012, 03:42 AM - Thread Starter
Newbie
 
reble's Avatar
 
Join Date: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a Skyworth flat screen hd tv/dvd player model slc-1551a-1. The tv part works fine. I am not shure if the dvd player is high definition but the tv it self is, The problem is in the built in dvd player. on some movies I have to wack the side of the tv to get the player to play the movie and sometimes the sound will get out of sync with the video and sometimes the video screws up. The same movies that screw up in the built in player play with no problems in my laptop and other stand alone dvd players and player/recorders. I have carefully tryed cleaning the laser lens with a q tip cotton swab and rubbing alcohol. It didn't solve the problem. I got this tv new in 2009. I have not had any problems with the dvd player until about 2 months ago. As of June I have been in my new apt were I have the room to open the tv up to try to clean the lens. At this point I am thinking of using some 3 and 1 oil on the lens support guide rails. But I want some advice on this before trying it. Also does anyone have any other ideas.


Steve
reble is offline  
Reply DVD Players (Standard Def)

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off