Oppo 983H disc tray - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
 
Thread Tools
Old 11-07-2012, 10:43 AM - Thread Starter
AVS Special Member
 
Kensmith48's Avatar
 
Join Date: Dec 2001
Location: Mid-Michigan
Posts: 1,363
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Liked: 23
I've had a 983H for a few years and now the tray only opens, but won't close when the button is pushed. Anyone know if there is a fix for this or do I need Oppo to repair?

Thanks,
Ken
Kensmith48 is offline  
Sponsored Links
Advertisement
 
Old 11-07-2012, 11:47 AM
AVS Special Member
 
moxie1617's Avatar
 
Join Date: Oct 2004
Location: Chicago Metro
Posts: 2,468
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 13
Give Oppo a call or send them an email. They may be able to walk you through a procedure to fix the tray. A long time ago I had a similar problem and they were able to resolve it on the phone. If not, remember that Oppo has a flat rate repair policy. I don't know what it is right now for the 983 but should be around $60.
moxie1617 is online now  
Old 11-07-2012, 08:26 PM - Thread Starter
AVS Special Member
 
Kensmith48's Avatar
 
Join Date: Dec 2001
Location: Mid-Michigan
Posts: 1,363
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Liked: 23
Thanks for the info. I sent Oppo an e-mail and they said the 983 has an alignment error and that I should turn the player off after removing any disc and then lift the front of the player several inches and then drop it to try and bring it back into alignment. I guess I'll give it a try tomorrow. Can't hurt.

Ken
Kensmith48 is offline  
Old 11-17-2012, 02:28 AM - Thread Starter
AVS Special Member
 
Kensmith48's Avatar
 
Join Date: Dec 2001
Location: Mid-Michigan
Posts: 1,363
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Liked: 23
Thought I'd update for those with the same problem. I followed Oppo's instructions and it worked great. I dropped the front edge once and now everything works as intended.
Kensmith48 is offline  
Sponsored Links
Advertisement
 
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off