Need to fix Audio on my LD-S2? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 04-18-2013, 03:45 PM - Thread Starter
Newbie
 
willywonka44's Avatar
 
Join Date: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a very nice almost mint Pioneer LD-S2 that sadly sat unused for about 15 years. I tried to hook up last night with no cable or internet to keep me busy and found there was an 0okay picture but no sound? All ot5hwer functions seem fine, I tried using different outputs and cables from the LD player to the Tv with no success. I am thinking in might have a bad Audio board or? I really have no desire to sell it for now just like to find some qualified help or taker to get repair3ed even if I have to drive a very long distance. i am afraid to ship for repair with an alsmot 90 damage rate for very heavy electronic items like an LD-S2. Any ideas? thanks! Bill
willywonka44 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-18-2013, 04:40 PM
AVS Club Gold
 
Kurtis Bahr's Avatar
 
Join Date: Jun 2002
Location: Northern Virginia
Posts: 814
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 21
Have you tried switching between analog and digital sound? These are two separate boards on the S2. Wondering it both digital and analog sound are bad. Also can you try the optical digital output?
Kurtis Bahr is offline  
Reply DVD Players (Standard Def)

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off