Help Me!!! - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 06-15-2014, 11:20 PM - Thread Starter
Newbie
 
Join Date: Jun 2014
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Help Me!!!

Alright so i need help connecting another subwoofer to my set up, i'm new to this website so i don't really know where to post this but if someone could help me that would be amazing!

Alright so i have 4 Logitech Z623's, Audio Engine A5+, and a Polk Audio Psw10 all hooked up at once. And how i did that is a 5 way 3.5mm splitter, expect my Polk Audio Sub is plugged into my Audio Engine A5+ Output, and then My Audio engine 3.5mm is plugged into the splitter. So i have 5 seperate things plugged into the 5 way and all my speakers work, but i want to add another subwoofer, the Polk Audio Psw125.

HELP ME!!! I don't know how i would connect it? I don't have anything i could plug it into, i want to add the extra subwoofer and the only thing i can thing of is buying this and plugging the two subs into it and then into my audio engine a5+ output? Would this work, would everything still play music?

http://www.amazon.ca/HDE-Port-Audio-...utput+splitter

And if your not allowed links then its called the HDE 4 Port RCA Audio Video Splitter.

Any Help would be amazing! Thank You!
undross is offline  
Reply Dedicated Theater Design & Construction

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off