optoma gt750- screen is blank why? - AVS Forum
Forum Jump: 
 
Thread Tools
Old 08-24-2014, 06:52 PM - Thread Starter
Newbie
 
Join Date: Aug 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Exclamation optoma gt750- screen is blank why?

I got optoma gt750 projector since months ago, but it's the first time this happens. i used it yesterday, it worked fine like always, but today when I tried to use it, most of the functions were disabled. I can only enter the menu, however, some of the options are gone and also the Display section in the menu, it wont let me press it, it skips to the next section. other than the menu button on the remote, nothing else works. I tried pressing everything I could think of, but nothing is happening! the projector is only showing the green background but it's blank. I turned it on and off several times, its the same. I unplugged it completely for hours, didn't work.
I connected several devices to it, the only thing that worked was the yellow video port. it showed the contents of the PS3 right away, but then when I use the hdmi again, nothing happens.
I can't think of something that somehow caused this to happen. I do have a 2 year warranty but for the time being I'm outside the UK (where I bought it).
any suggestions please help with this. I'm holding in my tears well so far. this is depressing.
any idea you have, I wanna know.
Thanks a lot.

Last edited by h0a0m0j; 08-24-2014 at 07:28 PM.
h0a0m0j is offline  
 

Tags
GT750 , issue , Optoma , problem , sos
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off