Editing 3D (interlaced) footage in Sony Vegas Movie Studio or Sony Vegas Pro - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 19 Old 02-05-2013, 04:06 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
I am opening another thread related to editing interlaced footage, based on Joseph Clark's comment:
Quote:
Originally Posted by Joseph Clark View Post

I wish the original Blu-ray 3D spec had included 1080/60i. There's no doubt in my mind that it looks better on all my displays than 1080/24p that's been converted from 60i.

I agree. Moreover, 60p (50p) full HD versions should be included as well. It's about time to do that.
Anyway, I am also projecting the shows on two passive projectors, so for me it is not a problem to show 60p full HD side-by-side.
By the way, is there any other standard which includes 60i/50i or 60p/50p full HD video (per eye) which can be played by 3D BD players or similar devices? AVCHD?

Now I have one question regarding editing 60i (50i) footage.
What should I do in Vegas editors in order to edit 60i footage and stereoscopically adjust the picture? I have tried several different approaches, but I'm always getting problems with moving objects. It seems that Sony editor does not take into account interlaced property of the clip during stereoscopic adjustment, so it mixes fields and therefore makes garbage out of the clip. I hope that I messed something and that it was my fault.

Yes, I know how to prepare interlaced footage (without deinterlacing left and right clips!) and edit it stereoscopically (including stereoscopic adjustments) in Sony Pro/MS, virtually without loosing video quality. However, such path engages VirtualDub and Avisynth scripts.
crunchy3d is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 02-05-2013, 06:06 AM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
Sure there is another stanard to burn 1080 50i/60i s3D to Blu-ray - it is AVCHD 3D. See here: http://www.avsforum.com/t/1437294/the-avchd-3d-thread

Vegas takes into account how to edit interlaced footage in a correct way - maybe your project settings are wrong? Project properties must be set in the deinterlaced mode either to blend or to interpolate, but not to none. But for sure Vegas is able to do that in the correct way. There is no need to deinterlace the footage in advance, that can happen during the final rendering.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #3 of 19 Old 02-05-2013, 07:05 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Quote:
Originally Posted by Wolfgang S. View Post

Sure there is another stanard to burn 1080 50i/60i s3D to Blu-ray - it is AVCHD 3D. See here: http://www.avsforum.com/t/1437294/the-avchd-3d-thread

Maybe I did not read it properly. I've got an impression that it was 1080i squeezed side-by-side version of stereoscopic video, but maybe it isn't.
Quote:
Originally Posted by Wolfgang S. View Post

Project properties must be set in the deinterlaced mode either to blend or to interpolate, but not to none. But for sure Vegas is able to do that in the correct way. There is no need to deinterlace the footage in advance, that can happen during the final rendering.

Ahhh, that was the case. I want to keep the highest quality during and after editing, so I don't want to deinterlace the footage by blending or interpolating it. It seems that I'll keep my way of editing. I'll soon upload some results on our server.
crunchy3d is offline  
post #4 of 19 Old 02-05-2013, 09:37 AM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
Quote:
Originally Posted by crunchy3d View Post

Maybe I did not read it properly. I've got an impression that it was 1080i squeezed side-by-side version of stereoscopic video, but maybe it isn't.

No, it is not sbs but a multistream file - where both L and R are in the same file. And that is possible for 1080 50i/60i too. Be aware that Vegas is not able to generate such multistream files.

Quote:
Originally Posted by crunchy3d View Post

Ahhh, that was the case. I want to keep the highest quality during and after editing, so I don't want to deinterlace the footage by blending or interpolating it. It seems that I'll keep my way of editing. I'll soon upload some results on our server.

That is not a deinterlacing of the final product, because that is enabled in your render settings. But it enables a internal deinterlacing where it is necessary in the internal data flow. Take for example L and R of two 1080 60i streams. The s3D autocorrect function calculates that one of the streams must be resized by a small amount. In the internal flow of Vegas, this stream must be deinterlaced first to be resized in the correct way. Without that, you have resizing artefacts. Other examples would be PiP functions.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #5 of 19 Old 02-05-2013, 10:52 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Quote:
Originally Posted by Wolfgang S. View Post

Be aware that Vegas is not able to generate such multistream files.

Suppose that you need Edius for the task?!?
In this case I'll rather produce two independedant streams and wait for better times... :-)
Quote:
Originally Posted by Wolfgang S. View Post

But it enables a internal deinterlacing where it is necessary in the internal data flow.

This is great news! I'll try it immediately. Since it is used internally, it probably does not matter what kind of deinterlacer we choose.
Still I can't understand why you, as the user, have to choose "denterlacing" if it has to be done internally by default on interlacing footage.
crunchy3d is offline  
post #6 of 19 Old 02-05-2013, 02:04 PM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Concerning editing interlaced footage - it is true that you can do it. Thanks! The only drawback is subtle decrease of sharpness.

I also did not manage to achieve skipping renderning interlaced footage which is not modified.
crunchy3d is offline  
post #7 of 19 Old 02-06-2013, 01:39 AM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
With interlaced footage, you always have some decrease in lines due to interline flicker.

The other effect is the decrease in sharpness due to effects like scaling, what happens if you zoom a little bit in the footage if you use the s3d plugin. To use the deinterlace mode "interpolat" in the project settings will deliver better results then "blend".

If that all is not good enough, then you can shoot in a progressive mode, maybe with other cameras.

That are all effects from the outdated interline footage. There is no question that a progressive format is more superior.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #8 of 19 Old 02-06-2013, 04:32 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Quote:
Originally Posted by Wolfgang S. View Post

With interlaced footage, you always have some decrease in lines due to interline flicker.

I thought about "subtle decrease of sharpness" when comparing to alternative way of editing the footage (converting it into fields, first). Such editing does not change the apparent resolution at all (you preserve pristine sharpness/resolution), while "interlaced editing" adds slight fuzziness (nut much, though).

The workflow is the following (for Vegas Pro):

- convert interlaced footage into fields and put left over the right one
- import it into Vegas Pro and select progressive Over/under half-size configuration
- edit it and save it in the same format

Now we've got the final video. The remaining steps are the following:

- Make interlaced files
- Deinterlace them

The quality is stunning.

For Vegas MS (I have version 11), in the first step you have to convert interlaces footage into fields and put them in side-by-side configuration. The drawback is that you edit vertically squeezed picture. However, the final quality is still perfect.

I'll try to make a simple SW which will produce all the necessary Avisynth files which will be used by VirtualDub for conversion of formats.
crunchy3d is offline  
post #9 of 19 Old 02-06-2013, 05:00 AM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
Do that with Avisynth, if you like. For Vegas, such a workflow is much too complicated.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #10 of 19 Old 02-10-2013, 05:05 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Quote:
Originally Posted by Wolfgang S. View Post

That are all effects from the outdated interline footage. There is no question that a progressive format is more superior.

I was always using 24p/25p video for my stereo projects (was using pairs of Panasonics GH1 and GH2). I was never even thinking about using 50i/60i footage until I met TD1/HMZ1.
After some preliminary tests I decided that using 60i option on HMZ1U isn’t such a bad idea at all. Here is a link to the original two clips in 24p and 60i modes and the resulting clip made in Xvid codec. The resulting clip is in 60p mode. Please, play it with Bino player or Stereoscopic player (switch deinterlace OFF in stereoscopic player!):

http://we.tl/a7yJXxs0T7

The final clip (20 seconds long) was made in Vegas Pro 12, the project was 60i full side-by-side (as suggested by Wolfgang), deinterlace method is set to “Interpolate” (also suggested by Wolfgang). The only task before editing was that I first deinterlaced footage which was used for slow-motion. After editing was finished, I deinterlaced the footage to obtain the final 60p clip. Both deinterlacings were made automatically (I wrote dedicated SW).
In my opinion, the result is very good. I like 60i->60p mode much more than 24p (when played by Bino or Stereoscopic Player). There were no filters applied to the clips, only “disable resample” was used.
Just on purpose, there is a star-chart on the video and the girl is wearing red T-shirt (both are problematic on interlaced video).
crunchy3d is offline  
post #11 of 19 Old 02-10-2013, 05:14 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
By the way, I never had a success by importing separate left/right files into Vegas Pro or Movie Studio, since sooner or later there were some artefacts appearing on the video (compression blocks, disappearing one of the views for some frames, etc.). Therefore I always import the footage in side-by-side format (full HD per eye).

Does anybody know if there is a way to achieve fluid editing of full HD side-by-side stereo project on Vegas Pro or Movie Studio?
crunchy3d is offline  
post #12 of 19 Old 02-10-2013, 08:15 AM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
I have not seen such error with the 1080 50p footage of two Sony TD10 cameras. One way to improve playback is to use 720 50p/60p settings for 1080 50i.

If you use 1080 50i/60i footage, I would not use sbs-full settings in the project settings, but 1080 50i/60i settings - and anaglyphic or sbs-half.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #13 of 19 Old 02-10-2013, 01:25 PM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Did you mean to edit in anaglyph mode and before rendering to change it again into full side-by-side? At least I am doing it so. I envy you for not having any problems with separate 2x1080p50 footage. wink.gif It's far from fluid in my case.
The situation is better (more fluid) if using freeware Cineform codec (instead of UT), but I have no idea how to correct false colours (red shirt becomes orange). I tried with different encoder settings (with or without BT709, RGB), but I could not get close enough to "accurate" colours obtained with UT codec. Namely, I don't want to colour correct every single clip in my video.
crunchy3d is offline  
post #14 of 19 Old 02-10-2013, 07:11 PM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
Do not mix up the project settings with the final render mode. That are two (relative) independent settings in Vegas. It is not necessary to change project settings for rendering.

BUT you have to adjust the project settings to your footage, to be able to end up with a good playback behaviour. So, maybe a reason why you have poor playback is that you do not use a good match between the project settings and your footage. But maybe it is also your specific footage. Hard to say without further informations.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #15 of 19 Old 02-11-2013, 06:40 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Thanks!
I'll try with different project settings and find out the best ones for my footage.
crunchy3d is offline  
post #16 of 19 Old 02-11-2013, 09:37 AM
AVS Club Gold
 
Don Landis's Avatar
 
Join Date: Jun 1999
Location: Jacksonville, FL
Posts: 10,885
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 122
crunchy3D- I have never seen color switch like you describe but you should check your pixel properties in the project properties and be sure it is set for 8 bit and in rendering set for default. Render as/ custom/ Project/color space = default

Also, make sure your video card is set for RGBs and not some other chroma level format.
Don Landis is offline  
post #17 of 19 Old 02-11-2013, 12:48 PM
AVS Special Member
 
Wolfgang S.'s Avatar
 
Join Date: Aug 2011
Location: Vienna/Austria
Posts: 1,133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 16
Oh, I know such color switches - they can derive from color space issues, that a codec is decoded in the wrong way in an NLE. I have seen such issues with earlier versions of Edius, I have seen it with some codecs in Vegas - so that is something that can happen. Maybe it can be improved with settings, maybe it cannot solved at all with settings. For the cineform issue, you could try to contact cineform if they know a way how to overcome that. Or you ignore that codec and use another workflow.

Kind regards,
Wolfgang
videotreffpunkt.com
Wolfgang S. is offline  
post #18 of 19 Old 02-12-2013, 11:33 AM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Thank you Wolfgang! It seems that I stumbled upon the same problem. I am just wondering if there is any other way how to change those colo(u)rs.

Just to explain to others what;s happening (if somebody else knows what can be done), there is pdf file which can be downloaded from WeTransfer:

http://we.tl/EnQJ1EjSWu
crunchy3d is offline  
post #19 of 19 Old 02-12-2013, 12:51 PM - Thread Starter
Member
 
crunchy3d's Avatar
 
Join Date: Jan 2013
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
I've finally managed to get similar colours of exported Vegas clip to the uncompressed one when importing it into VirtualDub and applied some filters.

The exported Vegas clip by CineForm codec should be opened in VirtualDub. In Video -> Video Color Depth, you have to choose the appropriate colour formats:

Decompression format = 4:4:4 planar YCbCr (YV24)
Output format = 24 bit RGB (888)

You don't have to choose any filter.

I tried to export the clip with uncompressed, UT422, UT RGB and Xvid codec. Uncompressed and UT RGB gave correct colours in VirtualDub, Media Player Classic and Bino. UT 422 and XVid codec gave false colours (orange) only in Media Player Classic, in Bino & VirtualDub it was OK.
crunchy3d is offline  
Reply 3D Source Components

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off