XpanD X103 vs Monster Vision Max 3D Glasses!? - Page 8 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #211 of 236 Old 03-05-2011, 09:34 AM
AVS Special Member
 
Mikenificent1's Avatar
 
Join Date: Dec 2001
Posts: 1,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by zombie10k View Post

.

Thanks for the review.
Mikenificent1 is offline  
Sponsored Links
Advertisement
 
post #212 of 236 Old 03-07-2011, 01:50 AM
AVS Special Member
 
swifty7's Avatar
 
Join Date: Aug 2005
Posts: 1,661
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
received my xpand 103's and didn't like it at all, the original sony 3d glasses blows it out of the water in every way except loosing 3d effect when you tilt your head. The xpand is going back to amazon a.s.a.p.....too bad.
swifty7 is offline  
post #213 of 236 Old 03-07-2011, 07:22 PM
AVS Special Member
 
OzHDHT's Avatar
 
Join Date: Jun 2003
Location: The Antipodes aka Oz
Posts: 1,267
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 35
Thanks for the review. I was kind of hoping to hear they might have a bigger improvement over the X103s, particularly brightness. Then again having already invested in 4 pairs of X103s for primarily for my Sony VW-90ES projector, I'm not exactly super keen on buying yet more glasses.

Speaking of the X103s, has anyone noticed that the reference to the firmware upgrade promised as 'after 15th Feb' on the website has disappeared along with the site being redesigned. I hate when upgrades are touted like that then nothing comes of it. I was really hoping, as I'm sure the other VW90ES owners were of some compatibility improvements being made..

Quote:
Originally Posted by swifty7 View Post

received my xpand 103's and didn't like it at all, the original sony 3d glasses blows it out of the water in every way except loosing 3d effect when you tilt your head. The xpand is going back to amazon a.s.a.p.....too bad.

Agree with you on that with the X103s and my 2 HX800 panels. However, even with a tad more ghosting, they are quite a lot better than using the Sonys with the additional polarizing filters required for viewing the VW90ES. The other thing is I find the X103s far more comfortable to wear than the Sonys.

OzHDHT is online now  
post #214 of 236 Old 03-08-2011, 04:02 AM
AVS Special Member
 
swifty7's Avatar
 
Join Date: Aug 2005
Posts: 1,661
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
the xpand might be more comfortable but what's the point of it being more comfortable if the glasses make 3d effects look bad and blurry. Are the Sony polarizers really that bad?
swifty7 is offline  
post #215 of 236 Old 03-08-2011, 06:59 AM
Advanced Member
 
markmathers's Avatar
 
Join Date: Jan 2011
Posts: 749
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I got my pair of x103s yesterday. I thought they were a noticeable improvement over samsungs glasses. And I haven't really had as much of an issue wit samsungs glasses either. The 103s seemed much clearer wit no ghosting/crosstalk to speak of while watching the 1st shrek movie...
markmathers is offline  
post #216 of 236 Old 03-08-2011, 05:45 PM
AVS Special Member
 
OzHDHT's Avatar
 
Join Date: Jun 2003
Location: The Antipodes aka Oz
Posts: 1,267
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 35
Quote:
Originally Posted by swifty7 View Post

the xpand might be more comfortable but what's the point of it being more comfortable if the glasses make 3d effects look bad and blurry. Are the Sony polarizers really that bad?

Try putting the polarizers on and using them with your TV(not the u get them without owning a VW90 of course, but you can search for a pic of them online). Effectively it's like sticking a grey sunglass lense over the top, making them significantly dimmer. There is no way that mild ghosting (certainly not major blurring with VW95) is worse than the loss of brightness occurring with the polarizers being fitted. You can see similar sentiments from other VW90 owners on the official tweaking thread :Link.

OzHDHT is online now  
post #217 of 236 Old 03-09-2011, 05:24 PM
AVS Special Member
 
OzHDHT's Avatar
 
Join Date: Jun 2003
Location: The Antipodes aka Oz
Posts: 1,267
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 35
It seems there's a new much improved and redesigned Xpand model due out next month. It was previewed at CES. Some big improvements, usb port and especially the custom tuning by smartphone app. Now I'm def regretting my January purchase of 4 pairs of the X103s! Rather than duplicate I posted the links in another thread in the proj forum: http://www.avsforum.com/avs-vb/showt...7#post20125187

OzHDHT is online now  
post #218 of 236 Old 03-09-2011, 06:27 PM
AVS Special Member
 
nickels55's Avatar
 
Join Date: Feb 2008
Location: Warrington, PA
Posts: 1,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 29
Xpand's new glasses direct link:
http://www.xpand.me/products/youniversal-3d-glasses/

Dlp Link, IR, Blue Tooth, and RF ready. These are going to cost a fortune.
nickels55 is offline  
post #219 of 236 Old 03-10-2011, 02:01 AM
AVS Special Member
 
OzHDHT's Avatar
 
Join Date: Jun 2003
Location: The Antipodes aka Oz
Posts: 1,267
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 35
Quote:
Originally Posted by nickels55 View Post

Xpand's new glasses direct link:
http://www.xpand.me/products/youniversal-3d-glasses/

Dlp Link, IR, Blue Tooth, and RF ready. These are going to cost a fortune.

It's been said they are going to cost more yeah.However, it's not like they are going to include all those transmitters, its just for wider compatibility. I can't see them being more expensive than the Monsters, which are a bit rediculous at $179 a pair rrp.

OzHDHT is online now  
post #220 of 236 Old 03-10-2011, 10:13 AM
AVS Special Member
 
zombie10k's Avatar
 
Join Date: Dec 2007
Posts: 7,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 234
I received my replacement Monster glasses for the broken pair. I have to be very careful handling them.

I'll give further impressions on the Monster vs. Xpand 103 on my JVC RS50 / 142" Dalite HP 2.8 setup. it's a bummer I can't get both to work at the same time, this will be a dealbreaker for most who already have the JVC's OEM and Xpand 103's. The sensor just doesn't pick up on the JVC emitter.

if anyone knows of a 3 pin DIN splitter, let me know. I cannot find such an adapter online.
zombie10k is online now  
post #221 of 236 Old 03-10-2011, 12:36 PM
Member
 
CerberusII's Avatar
 
Join Date: Dec 2005
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by zombie10k View Post

if anyone knows of a 3 pin DIN splitter, let me know. I cannot find such an adapter online.
I'll be making one today (hopefully). I will keep you posted.
CerberusII is offline  
post #222 of 236 Old 03-10-2011, 12:54 PM
 
Lee Stewart's Avatar
 
Join Date: Feb 2007
Location: Albuquerque, NM
Posts: 19,369
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 44
Quote:
Originally Posted by zombie10k View Post
I received my replacement Monster glasses for the broken pair. I have to be very careful handling them.

I'll give further impressions on the Monster vs. Xpand 103 on my JVC RS50 / 142" Dalite HP 2.8 setup. it's a bummer I can't get both to work at the same time, this will be a dealbreaker for most who already have the JVC's OEM and Xpand 103's. The sensor just doesn't pick up on the JVC emitter.

if anyone knows of a 3 pin DIN splitter, let me know. I cannot find such an adapter online.
Is there a USB port on the JVC projector?

http://www.bitcauldron.com/products/transmitters.html
Lee Stewart is offline  
post #223 of 236 Old 03-10-2011, 03:34 PM
Member
 
CerberusII's Avatar
 
Join Date: Dec 2005
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Today I made my own 3-pin y adapter so I can use my JVC emitter/glasses and the monster transmitter/glasses at the same time. It worked great! I ordered two 10ft male-female 3-pin cables, cut the female ends off both, and spliced them both on to one of the male ends. The BIG drawback of the Monster glasses is that the transmitter requires USB power. I need to figure this one out....
So for the quick review:
I viewed scenes from both Legend of the Guardians, and Tron Legacy (brightness junkies will not like this one...very dark movie). I do not notice a definite difference in actual brightness between the Monster and JVC glasses. What I do notice is that the JVCs have a subtle "natural" yellowish tint to them, and the Monster glasses have a "cooler" subtle bluish tint to them. I even notice the tint when wearing the inactive glasses looking at fluorescent lights. The end result here is that it does give a SMALL perceived brightness edge to the Monster glasses. I agree with zombie10k, I actually prefer the tint of the monster glasses as well. In addition, I find them to be much more comfortable than the JVCs.

That being said, I will keep the monster glasses for myself and let guests use the JVCs.
CerberusII is offline  
post #224 of 236 Old 03-11-2011, 07:03 AM
Advanced Member
 
markmathers's Avatar
 
Join Date: Jan 2011
Posts: 749
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Are the xpands sensitive to the 3d emitter, as far as losing sync? I noticed my pair kept going in and out of sync last night until I turned the screen towards me in which case it got better. However it did go outta sync when I would bring up picture menu/pop up menus. I don't remember my samsung glasses being that sensitive. Anyone else notice this?
markmathers is offline  
post #225 of 236 Old 03-11-2011, 06:36 PM
Member
 
wuffzack's Avatar
 
Join Date: Nov 2006
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by zombie10k View Post

that's makes 2 of us, my Monster IR sensor doesn't work with my JVC RS50 3D IR emitter. That is a major buzzkill since i'm not giving up using my 103's just to use the Monster glasses.

Does the Monster IR sensor work with your Nvidia emitter?
wuffzack is offline  
post #226 of 236 Old 03-13-2011, 11:12 AM
AVS Special Member
 
RonF's Avatar
 
Join Date: Feb 2001
Location: Sunny SoCal
Posts: 1,678
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 28
I'm really interested in the Monster glasses set up for the mentioned lighter tint, brightness and RF operation, and would hope there is some 3 pin Adapter available as I'm not good with tiny electronic wiring skills. So I can also use my X103 pair with the JVC projector and Monsters at the same time if needed.

But what am I missing....what is the logic of needing to plug the transmitter into both the 3 pin connector and a USB port for power? Were the Bit Cauldron glasses only meant to be run with an HTPC or flat panel with USB? That doesn't seem to make sense if they are being marketed as universal?
RonF is offline  
post #227 of 236 Old 03-13-2011, 05:38 PM
AVS Special Member
 
JackB's Avatar
 
Join Date: Apr 1999
Location: Pauma Valley, CA USA
Posts: 1,778
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 17
I am trying to get my 3D to work and I am having trouble getting there. I'm not sure if it's my glasses setup or a setting on the JVC RS40 projector. I have Directv projecting images that appear to be 3D as they are not watchable without glasses and the info box says 1080i(SBS). So I think the process works from D* to the projector. Problem is I can't get the RF emitter to sync with the projector port. A single red light turns on when plugged in but it doesn't move as it is supposed to when hunting for the 3D signal.

1. Is there a setting in the JVC RS40 projector menu I need to set in order to activate the 3D Synchro port? Under HDMI Input I have the 3D format set to Auto.

2. Do I have to be in 3D Picture Mode to activate the 3D Synchro port?

Any help would be appreciated. It's Sunday and Monster tech support is not open.

Jack
JackB is offline  
post #228 of 236 Old 03-15-2011, 05:56 AM
Senior Member
 
knobby's Avatar
 
Join Date: Dec 2004
Location: london ontario
Posts: 254
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
hoping for more monster shutter glasses reviews for our samsung dlps.these glasses are not available yet in canada.hoping these glasses will work well with our sets.please post a review if you have a pair and own a samsung 3d dlp.thanks
knobby is offline  
post #229 of 236 Old 03-23-2011, 07:06 AM
AVS Special Member
 
Mikenificent1's Avatar
 
Join Date: Dec 2001
Posts: 1,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by CerberusII View Post

. The BIG drawback of the Monster glasses is that the transmitter requires USB power. I need to figure this one out....

If you're using it with a JVC 3D projector, you don't need to connect the USB plug for power, just the vesa cable. That's how I have it hooked up with my RS40. FYI there's a thread now just for the Monster glasses.
Mikenificent1 is offline  
post #230 of 236 Old 03-23-2011, 07:09 AM
AVS Special Member
 
Mikenificent1's Avatar
 
Join Date: Dec 2001
Posts: 1,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by JackB View Post


1. Is there a setting in the JVC RS40 projector menu I need to set in order to activate the 3D Synchro port? Under HDMI Input I have the 3D format set to Auto.

Hopefully you got it working by now, but if not, I find that once the PJ is up and running and you have the 3D source on and the PJ in 3D mode, if you don't see the sync lights on the Monter transmitter, just pull the cable out of it and plug it back in and you should see it sync up after that.
Mikenificent1 is offline  
post #231 of 236 Old 03-23-2011, 05:29 PM
AVS Special Member
 
JackB's Avatar
 
Join Date: Apr 1999
Location: Pauma Valley, CA USA
Posts: 1,778
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 17
Quote:
Originally Posted by Mikenificent1 View Post
Hopefully you got it working by now, but if not, I find that once the PJ is up and running and you have the 3D source on and the PJ in 3D mode, if you don't see the sync lights on the Monter transmitter, just pull the cable out of it and plug it back in and you should see it sync up after that.
Mike,

I've got it working now but with USB power. I will try your suggestion. I talked to a Monster engineer assigned to the product and he didn't know anything about the JVC projectors as they hadn't been certified. Sounded like it was up to JVC to do that. His thought was that the 3rd prong was supposed to supply power and that JVC hadn't turned it on. If yours worked then so much for that estimate. He told me to use USB and it worked right away.

On a related item. I have ESPN on D* projecting a 3D emblem when the channel is idle. Shouldn't I be getting the "Res not supported" message even though there is no live programming? A couple of hours later I got the message when there was a basketball game being broadcast.

Jack
JackB is offline  
post #232 of 236 Old 03-24-2011, 05:40 AM
AVS Special Member
 
krichter1's Avatar
 
Join Date: Mar 2002
Location: Chicagoland (Naperville)
Posts: 2,644
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 80
When ESPN is idle it's a DTV supplied screen showing at 1080i/60 SbS I think. Use your info in your menu to confirm.

Kevin

You only live once, but if you live it right, once is enough.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

The Richter Family 3D Theater  

krichter1 is offline  
post #233 of 236 Old 03-24-2011, 06:45 AM
AVS Addicted Member
 
walford's Avatar
 
Join Date: May 2003
Location: Orange County, CA
Posts: 16,789
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
AFAIK D* broadcasts ESPN-3D programs in HDMI 1.4a 720p/60 SbS 3D format.
walford is offline  
post #234 of 236 Old 03-24-2011, 07:56 AM
AVS Special Member
 
JackB's Avatar
 
Join Date: Apr 1999
Location: Pauma Valley, CA USA
Posts: 1,778
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 17
Does this mean that the encoding is different when there is an ESPN broadcast versus the static image when the channel is idle? Must be otherwise the ESPN program would be viewable?

Jack
JackB is offline  
post #235 of 236 Old 03-24-2011, 10:15 AM
Senior Member
 
shazza's Avatar
 
Join Date: Nov 2006
Posts: 496
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by swifty7 View Post

received my xpand 103's and didn't like it at all, the original sony 3d glasses blows it out of the water in every way except loosing 3d effect when you tilt your head. The xpand is going back to amazon a.s.a.p.....too bad.

Just tested the xpand 103 against my Sony glasses (watching Space Station 3D), and was actually quite happy with them. Didn't notice any blurring or lack of 3D affect compared to the Sony glasses. They are also more comfortable. Will continue testing them, but biggest advantage for me is no loss of 3D when tilting my head - an issue I have mostly with PS3 games.
shazza is offline  
post #236 of 236 Old 03-24-2011, 02:51 PM
Senior Member
 
Vampyro's Avatar
 
Join Date: Nov 2005
Posts: 352
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just got my Ultraclear 3D glasses and after 15 minutes with them I give them thumbs up especially for the price. They go out of sync but not as bad as the Samsung glasses. Also, Samsung glasses break easy because there is no frame on the bottom, happened twice to me. The ultraclears work better and are sturdier---easy decision if you are in the market.


I have the Monstervision Max3d also and for me the Ultraclear 3D glasses work much better than the Monsters...could be I got a bad kit because the monstervision does not completely resolve all the 3D layers on my Samsung Plasma no matter what setting or adjustment, permanent ghosting---For the same price of the monstervisions I could get 4 pairs of the Ultraclears!
Monsters probably going back
Vampyro is online now  
Reply 3D Tech Talk

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off