A few questions before I buy - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 12-02-2012, 05:10 PM - Thread Starter
Member
 
egold54's Avatar
 
Join Date: Nov 2008
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Hey all,

I have a mits. 60738 along with a sony bdp-s570 3d br player. Never gave 3d much of a thought until now. I do have the firmware update so Im told I can go with either dlp link glasses or ir glasses.

It's confusing on which way to go. I've been told the ir is better for keeping the sync. than dlp-link

I've been talking with this guy at his website and store

http://ahugq.vcfpq.servertrust.com/

What do you guys recommend for my wife and I. We both also wear eye glasses.

Thanks
egold54 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-03-2012, 11:25 AM
AVS Special Member
 
Alan P's Avatar
 
Join Date: Jan 2003
Location: Rapid City, South Dakota
Posts: 3,010
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 851 Post(s)
Liked: 440
I've just gotten into 3D myself and ordered up 5 or 6 pairs of glasses from Amazon to find the best for me. I also wear prescription glasses.

So far, I've found these to be the most comfortable by quite a large margin. However, the optics seem not that great. No matter how much I clean them, they seem to have a "film" on the lenses:

http://www.amazon.com/gp/product/B0058SYDUW/ref=oh_details_o03_s00_i00


And these seem to have the best optics/clarity and are second best comfort-wise:

http://www.amazon.com/gp/product/B005V4YWVI/ref=oh_details_o00_s00_i01


You may need a different model of these glasses to work with your TV - I have a 2011 Mits 73740.

AVR: DENON 2113ci
FL/R: Klipschorn
CC: Klipsch RC64ii
SUR: Polk LS F/X x 4
SUB: PSA XS15 x 4 (Soon to be replaced with dual T-18s!)
DISP: Mitsubishi WD-73740
Alan P is online now  
post #3 of 5 Old 12-07-2012, 05:59 AM - Thread Starter
Member
 
egold54's Avatar
 
Join Date: Nov 2008
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I just got these yesterday,

http://ahugq.vcfpq.servertrust.com/samsung_emitter_p/ss1-1.htm

http://ahugq.vcfpq.servertrust.com/product_p/jp.htm

2pairs of glasses and the emitter cost me 90.00 with shipping.

Nice guy to deal with always answered my emails

It's taking me a bit to get it going with my 60738 mits and s570 sony blueray but I have 70% of the bugs worked out. I can see 3d off sony's streaming site. I tried pirates of the Caribbean and no luck yet. I see the 3d image on the tv but using the glasses each eye produces a clear pic but when both eyes are open the miages do not come together to for a 3d image. It's in my b/r player settings.

Kind of forgotten about 3d when I bought the equipment 2 years ago b/c of the pricing for the adapters and glasses but for 90.00 bucks wow very cool indeed.
egold54 is offline  
post #4 of 5 Old 12-07-2012, 09:27 AM
AVS Special Member
 
nickels55's Avatar
 
Join Date: Feb 2008
Location: Warrington, PA
Posts: 1,155
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 31
There is usually a DLP Link preference to people using older sets where it cannot be turned off. Can you disable DLP Link? If not, look at areas with solid blacks on the screen through your IR glasses. Are they truly black or are they tinted red/green? On my Sammy almost all IR glasses do not block the DLP Link flash and my blacks look tinted red in 3D. Using DLP Link glasses gets the blacks looking 100% black. IR keeps sync better, but at the expense of poor picture quality.
nickels55 is offline  
post #5 of 5 Old 12-07-2012, 04:34 PM - Thread Starter
Member
 
egold54's Avatar
 
Join Date: Nov 2008
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I'll check out the blacks on the sony/imax streaming site that's what's working right now. I thought the pic. looked really good and I had all the lights turned off also but then again I don't have anything to compare it to. The pirates movie could be a setting in the sony. I had trouble getting the emitter to even come on initially. I changed the B/R player to 720p and then the emitter did turn on. I also turned it back on to 1080p to give the wife a demo of 3d and this time even at 1080p the emitter came on. I did not check the movie,, wives aren't into playing its let me know when it's working or is this another one of those things you have to tinker with. I was nope it's working seeeeeeeeeeeee. I'll check it out in the morning when she's still sleeping lol. Thanks for the info.
egold54 is offline  
Reply 3D Tech Talk

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off