Harman Kardon SB16, Sony HDTV, HD DVR, BD and Apple TV Connection help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 12-29-2012, 09:51 AM - Thread Starter
Newbie
 
aafsahi's Avatar
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Good morning. I am trying to hook up all the following so that sound comes from the HK SB16 soundbar, but no matter what i try, the best i can get is only the Apple TV to come out of the soundbar, and all others come only from TV speakers. My components have the following input/outputs:

AppleTV: Newest model with HDMI, Optical and USB
Sony HDTV (KDL-46W4100) : Multiple HDMI, Optical, component, analog and whole bunch of others
Cable DVR (Scientific Atlantic Explorer 8240 HDL): HDMI, optical, component etc
Sony BD: HDMI, optical, analog and component
Harman Kardon SB16: Optical, coaxal, and analog (no HDMI)

I would appreicate any help you can provide. I have spent three days and trying everything, including variations on the DVR and TV's speaker settings, but no luck...

Thanks.
aafsahi is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 12-29-2012, 10:13 AM
AVS Special Member
 
Possumgirl's Avatar
 
Join Date: Dec 2008
Location: SoCal (L.A. area)
Posts: 1,901
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58
Seems like the connections should be straightforward. Connect your three source devices (AppleTV, cable box & BD player) to your TV via HDMI. Connect an optical cable from your TV to the soundbar. Go into your TV settings and set default speakers to external/home theater. May as well turn TV speakers off as well. That should be all there is to it. Be sure you're selecting the optical input on the soundbar if it doesn't just default to that.

If that doesn't work, try connecting just one source device at a time to isolate where the issue may be occuring. Post back with detail if there's still a problem.
Possumgirl is offline  
post #3 of 8 Old 12-30-2012, 09:00 AM - Thread Starter
Newbie
 
aafsahi's Avatar
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the response. I have tried isolating each of the devices (AppleTV, BD and DVR) to see why the sound does not work. When I only connect only AppleTV to the SB16 thru the optical, it works well thru the SB16. Same thing is true when I only have only the DVR connected to the SB16 via optical. I also tried having both the AppleTV and DVR connected at same time and no problems.

The problem seems to be the DVR, no matter how it is connected (by itself, with one or both other devices) it just does not transmit sound to the sounbdar. I tried changing audio settings in the DVR control from HDMI to Two Way or Digital and no go....

Any other solutions?

Much appreciate this help.
aafsahi is offline  
post #4 of 8 Old 12-30-2012, 10:27 AM
AVS Special Member
 
Possumgirl's Avatar
 
Join Date: Dec 2008
Location: SoCal (L.A. area)
Posts: 1,901
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58
Um, I think there might be some typos in there. eek.gif First paragraph says the DVR is working both by itself and with the Apple connected. Second paragraph says DVR isn't working. Since I can't tell if it's the DVR or maybe the BD player being the problem child, whichever one it is, does it work fine when connected all by itself to the TV with soundbar completely disconnected? Assuming it does, when you reconnect the soundbar what happens? Audio just stops?
Possumgirl is offline  
post #5 of 8 Old 01-01-2013, 09:01 AM - Thread Starter
Newbie
 
aafsahi's Avatar
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Sorry, you are right. I typed it wrong. The DVR is the only device that is not working. And to your answer your last questions, yes each component works perfectly well when connected alone, either to TV or through Soundbar. When I connect the DVR to play through the soundbar, nothing comes out of it.

Could the problem be with the Audio settings in the DVR? Thanks and happy new year.
aafsahi is offline  
post #6 of 8 Old 01-01-2013, 09:22 AM
Advanced Member
 
Doctego's Avatar
 
Join Date: Nov 2012
Location: Central Jersey
Posts: 738
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 41
Quote:
Could the problem be with the Audio settings in the DVR? Thanks and happy new year.

Definitely could be the issue. For my DVR, I needed to go into the DIGITAL AUDIO settings to choose the proper audio output.

We are here to help you. Please help us to help you. If you provide incomplete information, at best, we can give you an incomplete response.
Doctego is offline  
post #7 of 8 Old 01-01-2013, 10:38 AM
AVS Special Member
 
Possumgirl's Avatar
 
Join Date: Dec 2008
Location: SoCal (L.A. area)
Posts: 1,901
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58
Quote:
Originally Posted by aafsahi View Post

Could the problem be with the Audio settings in the DVR? Thanks and happy new year.

Happy New Year to you as well. smile.gif I just spent some time reading reviews of the SB16 and I may have found the answer. According to what I read, the soundbar needs PCM (not bitstream) on its digital connections. Your Sony TV may be one of the few HDTVs that output Dolby from connected devices. So you're going to have to find an audio setting on either the DVR or on the TV to output PCM only. If the DVR lets you turn Dolby off, start there. If no joy that way, see if your TV has a setting to output PCM only via optical.
Possumgirl is offline  
post #8 of 8 Old 01-01-2013, 02:40 PM
AVS Special Member
 
Possumgirl's Avatar
 
Join Date: Dec 2008
Location: SoCal (L.A. area)
Posts: 1,901
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58
I had another thought. Your TV has analog audio out. You could just connect the TV to the soundbar using good ol' red/white cables instead of the optical output. I think that will solve the issue with the DVR.
Possumgirl is offline  
Reply Soundbars

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off