Energy Power Bar Elite Soundbar Problem :( - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 04-01-2013, 05:53 AM - Thread Starter
Newbie
 
nicecar's Avatar
 
Join Date: Apr 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi All,

Hoping someone will have an answer for me..

Installed a new soundbar this afternoon, the sound etc all seemed great. It is connected to a Samsung E8000 via optical cable, the TV has a PS3/Apple TV/Cable TV/Ethernet for Internet connected.
Problem is...after 10-20 minutes of playing the TV or Cable TV it the sound starts becoming distorted and fuzzy. The odd thing is if I change channels then go back to the original channel the problem will resolve itself?

I'm hoping I don't have to take the unit back cause it was a PITA to wall mount/chase the wiring through the wall !!
nicecar is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-01-2013, 06:08 AM
Advanced Member
 
Doctego's Avatar
 
Join Date: Nov 2012
Location: Central Jersey
Posts: 738
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 41
I have no idea but your situation is proof that it's always a good idea to test out new equipment thoroughly before running wires through the wall.

I would try some things to see if you can narrow down what is causing the problem. The first thing that I would do is connect the optical cable directly from one of the sources to the soundbar. Let it play for as long as it takes. Make sure that the optical cable is seated properly. Especially when run through walls, they can become loose. If you have another optical cable, try swapping it out and see if the problem persists.

We are here to help you. Please help us to help you. If you provide incomplete information, at best, we can give you an incomplete response.
Doctego is offline  
post #3 of 7 Old 08-05-2013, 04:58 PM
Newbie
 
kdigital's Avatar
 
Join Date: Oct 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So, I bought an Energy Power Bar Elite yesterday for the downstairs TV, brought it home, set it up, and it sounds great. It will never replace a nice surround setup, but considering its a soundbar, it sounds stellar.

Setup was a snap and I hooked it up to the TV via optical cable. Here's the rub: just like the OP, after a few minutes playing, the sound becomes horribly distorted. Everything sounds like like a guitar played through a distortion pedal with a healthy dose of reverb.

I swapped the cable for alternates from my cable collection 3 times. The results were the same. Analog audio (RCAs) through the soundbar's second input work fine.

The store I bought the soundbar from called today for a follow up to see how the soundbar is working and if am happy with the shopping experience at their store. I told them about the problem and they said I can return or exchange the soundbar. The thing is I really like the sound and would prefer not to exchange the soundbar since other people obviously have problems as well and I concerned a replacement may have the same problem. I don't want to keep the soundbar if the optical input doesn't work properly.

Anybody have a solution?
kdigital is offline  
post #4 of 7 Old 08-14-2013, 10:33 PM
Newbie
 
boofer81's Avatar
 
Join Date: Aug 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am on my second power bar. Had the same issues with the first one so I sent it off to get fixed now the sub doesn't sync. Got a new one today and have the same issues with the distortion and the sub still won't sync. Now I have a new issue. It's muting itself randomly then unmuting itself. I love the sound of this thing but I think I'm going to switch brands.
boofer81 is offline  
post #5 of 7 Old 08-15-2013, 04:13 AM
Newbie
 
kdigital's Avatar
 
Join Date: Oct 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think my Energy Power Bar Elite is going back to the store as well. Also i sent an email to the manufacturer and the folks at Energy did not reply to my inquiry, so I suppose a return is the best recourse. It's a shame because when it works properly, the system sounds great.
kdigital is offline  
post #6 of 7 Old 01-10-2014, 05:46 PM
Newbie
 
riceonice2's Avatar
 
Join Date: Feb 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have same problem right now but the bar is over 6 months old now. Disappointed used to be great
riceonice2 is offline  
post #7 of 7 Old 01-18-2014, 11:03 AM
Senior Member
 
iserum's Avatar
 
Join Date: Jun 2005
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
i got one from best buy and sub won't sync to SB, the blue light on sub will flash for one second and no connection afterward. had to return it. i got the Jamo torsten as replacement.
iserum is offline  
Reply Soundbars

Tags
Energy Power Bar Elite Soundbar With Wireless Subwoofer

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off