IMAX 3D Playback Issues - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 04-20-2013, 06:34 PM - Thread Starter
Newbie
 
mmgerecke's Avatar
 
Join Date: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello! First time poster, long time reader. I am leaning on the community for some help. I cannot seem to get either IMAX Under The Sea 3D or the IMAX Huble to display in 3D. At first I thought there was just lack of depth and effect and then I read rave reviews about a potato cod popping way out in Under The Sea. I can watch Avatar 3D with no issues...

My setup:

Sony S590 3D BDP
Onkyo 809 Receiver (set to though for video)
Panny GT50
Active shutter glasses
Everything is connected with high speed HDMI

Is there something I am overlooking? I don't understand why one 3D blu ray will work, but not another.

Thanks in advance.
mmgerecke is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-20-2013, 07:42 PM
Advanced Member
 
ferl's Avatar
 
Join Date: Jan 2004
Location: Illinois
Posts: 687
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 26
Have you tried connecting the BDP directly to the TV?

ferl is offline  
Reply 3D Content

Tags
Imax Arabia Blu Ray 3d

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off