Looking for panel connectors from failed TC-PxxS60 or S64 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 08-16-2017, 07:49 AM - Thread Starter
Member
 
Superdog's Avatar
 
Join Date: Oct 2008
Location: Alabama
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 11
Looking for panel connectors from failed TC-PxxS60 or S64

Odd request I know. I lost the right side of the picture on my Panny plasma (65S60), and traced it to a failed chip on the ribbon connector that connects to the C1 board. Planning to replace the set with OLED eventually, and want to experiment with trying to graft on a cable with a working chip before I get rid of it; probably impossible, but want to try. Putting this out there to see if anyone has a failed panel that they wouldn't mind snipping off a few of the bottom ribbons (as much length as possible) before disposing of the panel.

Not sure if the connectors are any different between the different sized panels. Will pay shipping and a little extra for your effort.

Thanks!
Stu

Sent from my XT1575 using Tapatalk
Superdog is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-14-2017, 08:31 AM - Thread Starter
Member
 
Superdog's Avatar
 
Join Date: Oct 2008
Location: Alabama
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 11
Bump.

Sent from my XT1575 using Tapatalk
Superdog is offline  
Sponsored Links
Advertisement
 
Reply This and That

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off