My screen smells and has black dots - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 01-09-2002, 08:47 AM - Thread Starter
Senior Member
 
Augie's Avatar
 
Join Date: Sep 2001
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I installed a Da-Lite Tensioned Cosmopolitan 16:9 92x52 (106 diagonal) Da-Mat 1.1 gain screen several weeks ago. When the screen is lowered out of its case, it smells like... well, it's hard to describe... it has this petroleum-like smell. It seems to have diminished some, but it is definitely still there. What is it and will it ever go away?

Also, small black marks (dots) are showing up on the screen. They look like marker marks. They weren't there originally, but several have appeared. Are these marks coming off the backing onto the front when the screen is rolled up? I tried washing them off with Ivory dishwashing soap and water with no success. They aren't distracting, but I'm curious.
Augie is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-09-2002, 09:18 AM
Advanced Member
 
Petey's Avatar
 
Join Date: Aug 2001
Location: Las Vegas, NV, USA
Posts: 546
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the same odor when extracting my Da-Lite Video Spectra screen. It's not as strong now as when I initially got it about 2 months ago but you can still smell it. I'm guessing it's from whatever they use to create the black borders but I've been wrong before.

Can't help you with the black spots. Mine is completely white.

Petey
Petey is offline  
post #3 of 7 Old 01-09-2002, 10:00 AM
Senior Member
 
TimC's Avatar
 
Join Date: Nov 1999
Location: Columbus, Ohio
Posts: 215
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Black spots and a smell...

Is the screen in a fairly damp location (like a basement)?Could be mold.
TimC is offline  
post #4 of 7 Old 01-09-2002, 10:50 AM - Thread Starter
Senior Member
 
Augie's Avatar
 
Join Date: Sep 2001
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally posted by TimC
Black spots and a smell...

Is the screen in a fairly damp location (like a basement)?Could be mold.
Definitely not mold. Doesn't smell like mold and the spots look like someone touched the screen with a black magic marker. No, I don't have kids... but maybe my wife is trying to sabotage my expensive hobby! ;)
Augie is offline  
post #5 of 7 Old 01-10-2002, 12:06 AM
 
centaur's Avatar
 
Join Date: Dec 2001
Posts: 319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hm, black spots and a smell...

Jokes aside (cough) it could be a lubricant for the mechanism or screen-protectant. And being hydrocarbon-based, this may be breaking down the color on the backing.
centaur is offline  
post #6 of 7 Old 01-10-2002, 04:05 PM
AVS Special Member
 
starscomeout's Avatar
 
Join Date: May 2001
Location: Glendale, AZ
Posts: 1,125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Matt,
I hate to bring up the obvious, but did you call and ask Da-Lite about this? If the screen is new, then I am sure they would replace it.

Don
starscomeout is offline  
post #7 of 7 Old 01-10-2002, 05:45 PM
AVS Special Member
 
Doug Baisey's Avatar
 
Join Date: Jun 1999
Location: Diamond Bar Calif USA 91765 / Seattle area WA 98512
Posts: 4,923
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
augie,
The smell is normal, leave it down and let it cure yo fit your environment, the smell will go away. The back dots need to be brought to the attention of the mfg fast, I think Da-lite has a card in the box that says to call right away if there is a defect or carton damage, Doug
Doug Baisey is offline  
Closed Thread Screens

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off