Monoprice multi-format screen problems? - AVS | Home Theater Discussions And Reviews
Forum Jump: 
Thread Tools
post #1 of 4 Old 12-20-2012, 11:45 AM - Thread Starter
Newbie
 
takhan's Avatar
 
Join Date: Dec 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Experts,

Based on the discussions in the forum, I purchased a 120" multi-format screen from Monoprice. As others noted, the instructions are pretty basic (wanting?), but not too difficult to put together. I assembled it in a couple of hours but when I leaned it against the wall to test it, found out that the bottom part of the multiformat panel doesn't retract back into the roller. Contacted monoprice and sent them a picture of the problem and they agreed to send me a replacement.

Now my replacement is giving the same problem. The top panel seems to retract fine, but the bottom panel does not go back. I didn't see anyone else report this problem so I'm curious if I just have bad luck and ended up getting two bad panels or it's something else including my assembling skills.

Would appreciate feedback from other Monoprice multi-format screen owners before calling monoprice again.

Thanks in advance for your help.

Tariq
takhan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-01-2014, 02:37 PM
Newbie
 
Join Date: Nov 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Hi Tariq,

I just received my 120" screen from Monoprice and was having no problem putting it together until I couldn't get the bottom mask to retract. As in your case, the top is fine, but the bottom one is stuck open. Did you ever fix this problem or has anyone else been able to resolve?

Thank you,
Joe
axteljo is online now  
post #3 of 4 Old 02-07-2015, 04:15 PM
Senior Member
 
Gregor's Avatar
 
Join Date: Oct 2000
Location: Nashville, TN
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Same problem here - anyone find a solution or fix?
Gregor is offline  
post #4 of 4 Unread Today, 04:52 PM
AVS Special Member
 
rwestley's Avatar
 
Join Date: Mar 2004
Posts: 6,735
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)
Liked: 73
I know what the problem is with the Monoprice screens. The manufacture used plastic parts on the masking mechanism. They crack and that is what causes the problem. I sent Monoprice the broken parts and I think that they plan to change them in future shipments. My first screen had the same problem and they replaced it with another having the same issue as others have reported. I decided that instead of sending it back I took it apart and had a welding shop make side brackets out of metal instead of plastic. Had it put back together and it has been working fine ever since. I sent the 4 plastic brackets back to Monoprice so that they would send them to the factory any get the problem fixed. I suggest that you contact them to see if the problem has been resolved. It seems that they had a bad run on the screens with masking.
rwestley is online now  
Sponsored Links
Advertisement
 
Reply Screens

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off