AVS Forum

AVS Forum (http://www.avsforum.com/forum/)
-   Screens (http://www.avsforum.com/forum/23-screens/)
-   -   Stewart screen problem (http://www.avsforum.com/forum/23-screens/19210-stewart-screen-problem.html)

bryan_chow 11-09-2000 01:00 PM

I just received my new Stewart Luxus A Electriscreen.

I was disappointed to see that the power/control cable for the unit is truncated bare wires (no plug, etc). I naively thought that I could just hang it up, plug it in and go. I guess I need to buy a power cable and splice the wires or something? Any tips/info?

Thanks,
Bryan

Bill Lucas 11-09-2000 03:50 PM

Bryan,

Why don't you contact the manufacturer and ask them what procedure to use? Don Stewart comes to this forum from time to time but you'd be better served if you used proper channels and contacted customer service. Good luck with your new screen.

Dan Henderson 11-12-2000 02:39 AM

Bryan,

I'm sure that over 90% of the screens that Stewart sells are not installed by the customer. We usually have to extend the wire that Stewart gives us to plug the motorized screens in, so we always expect to have the proper parts on hand.

To answer your question, yes, you will just need to goto Home Depot and buy a 110v 2 (or 3?) prong plug. Sometimes we run the power pretty far so that we can switch it on with the receiver or projector. (When a 12v ground is not availible)

Dan

------------------
Dan Henderson
dan@net-impress.com


All times are GMT -7. The time now is 05:09 PM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.