Official JVC RS15/ HD550 Owner's Thread - Page 25 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #721 of 859 Old 06-29-2011, 10:42 AM
Member
 
mreggena's Avatar
 
Join Date: Dec 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Do anyone have a RS15 projection on a 120" screen with a throw of about 16' ? If so how does the image and brightness look?

I have a RS15 that i havent hooked up yet (still finishing the basement). I am worried because at the beginning of my basement build, projectorcentral.com said that ~ 16' throw would be perfect for a RS15 on a 120" screen with 1.0 gain. Now it seems like something has changed because now the site says I need to move it much closer and shrink the screen size to make it bright enough.

I cant easily move it because I have already braced the ceiling where i plan to mount it and ran HDMI and power. I just hope its going to work ok. The wife is "expecting" it to be a nice bright image, similar to our 50" plasma. I really dont want it to look like crap because I will never hear the end of how i spent so much money on all of the HT stuff etc!

JVC RS15
120" Elite Sable Screen
Onkyo NR-808 Receiver
Aperion 6C Center Channel, 4T Towers, 5DB Surrounds, and Bravus 10 sub
mreggena is offline  
Sponsored Links
Advertisement
 
post #722 of 859 Old 06-29-2011, 10:52 AM
AVS Special Member
 
erkq's Avatar
 
Join Date: Sep 2006
Posts: 5,519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 94
Quote:
Originally Posted by mreggena View Post

Do anyone have a RS15 projection on a 120" screen with a throw of about 16' ? If so how does the image and brightness look?

I have a RS15 that i havent hooked up yet (still finishing the basement). I am worried because at the beginning of my basement build, projectorcentral.com said that ~ 16' throw would be perfect for a RS15 on a 120" screen with 1.0 gain. Now it seems like something has changed because now the site says I need to move it much closer and shrink the screen size to make it bright enough.

I cant easily move it because I have already braced the ceiling where i plan to mount it and ran HDMI and power. I just hope its going to work ok. The wife is "expecting" it to be a nice bright image, similar to our 50" plasma. I really dont want it to look like crap because I will never hear the end of how i spent so much money on all of the HT stuff etc!

Well, you are NOT going to get 50" plasma brightness out of it for sure. But that's a rather lofty goal with a front projector.

I use a 120" wide 1.1 gain with my RS20 (maybe just a tad dimmer than your RS15) and I've never had any complaints, even from myself! I run it high lamp 0 iris and it's got about 450 hours on the bulb. But it's no plasma!
erkq is offline  
post #723 of 859 Old 06-29-2011, 11:13 AM
Member
 
SSpivey's Avatar
 
Join Date: Jan 2003
Location: Lakefield Ontario Canada
Posts: 71
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well it's certainly not going to look like crap.

It's meant to be used in a darkened room, though. It's more like being at the movies.

As for distance, the closer you can get it the brighter it will be. The zoom lens only offers it's maximum aperture at it's widest setting. If you keep the same image size and move the projector back/zoom 'in' then the light output will drop a bit. Not as much as half, but close. (This is not as much as it might sound like)

I'm running about 120" at about 12foot distance
S.
SSpivey is offline  
post #724 of 859 Old 06-29-2011, 11:17 AM
Member
 
mreggena's Avatar
 
Join Date: Dec 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I would say 80% of the time it will be totally dark in the room. The other 20% will be when I have family/friends over and there will be some ambient light. Cant be totally dark with kids running around!

Just not sure how i screwed this calculation up. I messed with that sight multiple times before determining what i wanted. I really would hate to have to go back and rewire, resupport the mount spot on the ceiling, if i have to I will. Just makes me mad. aargh!

I might have to play with it some tonight to see how the image looks on a white primed wall.

JVC RS15
120" Elite Sable Screen
Onkyo NR-808 Receiver
Aperion 6C Center Channel, 4T Towers, 5DB Surrounds, and Bravus 10 sub
mreggena is offline  
post #725 of 859 Old 06-29-2011, 11:22 AM
AVS Special Member
 
erkq's Avatar
 
Join Date: Sep 2006
Posts: 5,519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 94
Quote:
Originally Posted by SSpivey View Post

Well it's certainly not going to look like crap.

Absolutely not! The other detail I left out is mine is 21' back, in a projection room.
erkq is offline  
post #726 of 859 Old 06-29-2011, 11:27 AM
Member
 
mreggena's Avatar
 
Join Date: Dec 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think something is wrong with the projectorcentral.com site.

if you select a RS15 (1000 lumens) set it with a throw of 15' 11" on a 120" screen it says the image brightness is 9Fl. But if you do the same specs with a RS20 (only 900 lumens) it says the brightness will be 15 Fl.

how is that possible if the RS20 is 100 lumens dimmer?

JVC RS15
120" Elite Sable Screen
Onkyo NR-808 Receiver
Aperion 6C Center Channel, 4T Towers, 5DB Surrounds, and Bravus 10 sub
mreggena is offline  
post #727 of 859 Old 06-29-2011, 11:34 AM
AVS Special Member
 
erkq's Avatar
 
Join Date: Sep 2006
Posts: 5,519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 94
Quote:
Originally Posted by mreggena View Post

I think something is wrong with the projectorcentral.com site.

if you select a RS15 (1000 lumens) set it with a throw of 15' 11" on a 120" screen it says the image brightness is 9Fl. But if you do the same specs with a RS20 (only 900 lumens) it says the brightness will be 15 Fl.

how is that possible if the RS20 is 100 lumens dimmer?

I don't know. I haven't gone to the pj site in years. This is only one reason why. BTW, 1000 lumens is a pretty optimistic rating. I'd use under 800 for your calculations... calibrated, not at min throw, something older than 0 hours, slightly optimistic rating to begin with... you get the drill.
erkq is offline  
post #728 of 859 Old 06-29-2011, 12:03 PM
AVS Special Member
 
Big Picture's Avatar
 
Join Date: Dec 1999
Location: USA
Posts: 1,667
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I have a Jason Turk calibrated RS15 a 120" StudioTek 130 screen (about 10 years old). RS15 in low lamp mode currently has 600 hours on bulb and is ceiling mounted 15' from screen, the image is currently plenty bright in my bat cave.
Big Picture is offline  
post #729 of 859 Old 06-29-2011, 02:38 PM
Advanced Member
 
Steve Richards's Avatar
 
Join Date: Dec 1999
Location: Norwell, MA, USA
Posts: 676
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I have a 110" screen with the projector at 22' - I use the normal bulb brightness (not high) and the picture is sufficiently bright that I can leave the ceiling lights on low.

I agree with the other posters I don't think you will have an issue unless you compare it side by side with the plasma.

Regards,
Steve
Steve Richards is offline  
post #730 of 859 Old 06-29-2011, 03:02 PM
AVS Special Member
 
KJSmitty's Avatar
 
Join Date: Jan 2007
Posts: 1,606
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 34
Another data point here.... :-)

RS15 and Carada 126 inch screen combo, 13.5' throw distance. Clock is currently at 450ish hrs on the bulb and I have yet to use high lamp mode. Not optimum yet "plenty" bright with the room lights dimmed 65-75%.

Think you will be fine at 16' on a 120" screen.

As you mentioned adjust the lens to 120" at say 12 feet and then again at 16 feet/throw on your primed wall and compare. See if the distance and brightness difference is enough to move your mount/wiring etc..

Love DIY
KJSmitty is offline  
post #731 of 859 Old 06-29-2011, 04:21 PM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I updated my post #718 about my RS15 that is living at JVC for service. I hope it can come home some day. 4 1/2 weeks gone.
joatmon is offline  
post #732 of 859 Old 06-29-2011, 05:12 PM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by mreggena View Post

I would say 80% of the time it will be totally dark in the room. The other 20% will be when I have family/friends over and there will be some ambient light. Cant be totally dark with kids running around!

Just not sure how i screwed this calculation up. I messed with that sight multiple times before determining what i wanted. I really would hate to have to go back and rewire, resupport the mount spot on the ceiling, if i have to I will. Just makes me mad. aargh!

I might have to play with it some tonight to see how the image looks on a white primed wall.

You will be fine. My projector is mounted 18ft from a 128" 2:35 screen and the brightness is fine. It is a complete dark room majority of the time, but when some times have the lights on, or I let some light from windows by removing black out curtains and the picture is still highly viewable. I have had the projector since day one when it released with a little over 1100hrs on bulb right now picture still looks good.
thadoneternal is offline  
post #733 of 859 Old 06-29-2011, 05:19 PM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post

I updated my post #718 about my RS15 that is living at JVC for service. I hope it can come home some day. 4 1/2 weeks gone.

Ok, that is scarying me because I just sent my projector to JVC on Monday to fix the pinkish blur on the left side of the projector image. If it takes as long as yours to repair I am going to request they just send me a replacement or give me a steep discount on a new model or something.
thadoneternal is offline  
post #734 of 859 Old 06-30-2011, 07:56 AM
Member
 
mreggena's Avatar
 
Join Date: Dec 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks everyone for your replies...I will be able to sleep better tonight.

JVC RS15
120" Elite Sable Screen
Onkyo NR-808 Receiver
Aperion 6C Center Channel, 4T Towers, 5DB Surrounds, and Bravus 10 sub
mreggena is offline  
post #735 of 859 Old 07-01-2011, 03:58 PM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post

I updated my post #718 about my RS15 that is living at JVC for service. I hope it can come home some day. 4 1/2 weeks gone.

I think you might want to give them a call and light a fire under them, because I have the same issue. I shipped Monday 6/27, they showed it received Thursday 6/30 at 10:30AM, by that afternoon it was Invoiced to be shipped back. I called customer service this afternoon, and they said the optical block had to be replaced and they are finishing up final rounds of testing and will be shipping it back soon. Not sure why your status still says it needs parts, but it seems like we both have the same exact issue.
thadoneternal is offline  
post #736 of 859 Old 07-07-2011, 11:58 AM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thadoneternal View Post

I think you might want to give them a call and light a fire under them, because I have the same issue. I shipped Monday 6/27, they showed it received Thursday 6/28 at 10:30AM, by that afternoon it was Invoiced to be shipped back. I called customer service this afternoon, and they said the optical block had to be replaced and they are finishing up final rounds of testing and will be shipping it back soon. Not sure why your status still says it needs parts, but it seems like we both have the same exact issue.

I hope you're the lucky one. They said the part won't be in until 7/27/2011. Have they finished your projector? I updated my chronicle of the fiasco that is JVC on POST #718
joatmon is offline  
post #737 of 859 Old 07-08-2011, 05:08 AM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post

I hope you're the lucky one. They said the part won't be in until 7/27/2011. Have they finished your projector? I updated my chronicle of the fiasco that is JVC on POST #718

Yeah, they said they are done with it. Repair and testing was finished on 6/30. I called to find out why it has not been shipped yet, because the Rep. said it was prepared for shipping but did not have any tracking. I have to follow back up today to get supervisor to overnight back to me because it has just been sitting there at their service center. Both Rep. and Supervisor have both verified that the optical block was replaced and testing completed on 6/30 which was the same day they received it. Not sure why your repair is in a holding pattern. I know there are two service centers (L.A & TX), maybe it depends on which one you sent it to, mine was sent to their TX location.
thadoneternal is offline  
post #738 of 859 Old 07-08-2011, 10:38 AM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
thadoneternal, I followed the advice of a customer service Rep and sent it to California. Maybe I should have sent it to TX because I live in TX. You'd think they could ship the parts to other sites if they have them somewhere. This is a colossal joke of customer service.
joatmon is offline  
post #739 of 859 Old 07-08-2011, 11:03 AM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post
thadoneternal, I followed the advice of a customer service Rep and sent it to California. Maybe I should have sent it to TX because I live in TX. You'd think they could ship the parts to other sites if they have them somewhere. This is a colossal joke of customer service.
Yeah I am not sure why they told you to send it to Cali. I even found out that if you live near the service center that you could take it to them in person and they will check it out while you are there. With you being in TX, I am surprised the Rep did not mention that option to you. Even though mine is fixed, the problem I am having is getting them to ship the damn thing back to me. It has been sitting there for a week now, and only response I have gotten is that my issue has been escalated to a supervisor to find out why it has not shipped when it shows repairs complete in their system. You would think this would be a 1 day task, but I have been waiting for an answer to this since Wed. when the escalation was 1st submitted.

I also checked their website today, and it looks like TX is not even listed as a service center anymore, not sure if this has anything to do with me not getting my RS15 back.
thadoneternal is offline  
post #740 of 859 Old 07-09-2011, 08:36 AM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thadoneternal View Post

Yeah I am not sure why they told you to send it to Cali. I even found out that if you live near the service center that you could take it to them in person and they will check it out while you are there. With you being in TX, I am surprised the Rep did not mention that option to you. Even though mine is fixed, the problem I am having is getting them to ship the damn thing back to me. It has been sitting there for a week now, and only response I have gotten is that my issue has been escalated to a supervisor to find out why it has not shipped when it shows repairs complete in their system. You would think this would be a 1 day task, but I have been waiting for an answer to this since Wed. when the escalation was 1st submitted.

I also checked their website today, and it looks like TX is not even listed as a service center anymore, not sure if this has anything to do with me not getting my RS15 back.

I talked to the service manager at the (claimed by him) one facility in the US that repairs our projectors and that is in California. They have "several" projectors waiting for optical blocks. They could not answer why they are telling you that yours has been serviced. They have told me on different occasions that the the part will be available to them on 7/27, then the 21st, then on the 12th. I assume they are actually lying to you and me and are desperately hoping the parts come in while they can blow us off. I just assume they are trying to give me hope that the projector will be finished soon.
joatmon is offline  
post #741 of 859 Old 07-10-2011, 01:40 PM
AVS Special Member
 
KJSmitty's Avatar
 
Join Date: Jan 2007
Posts: 1,606
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 34
Greetings all RS15/HD550 owners,

I brought this topic up before yet only a couple commented. Ive had my RS15 for near two years now, about 450 hrs on the clock. I really believe the "motion blur" is getting worse. Started really noticing it last year yet now it appears that near any motion in the movie the entire image turns blurry.

I would really like to hear other owners descriptions of their "motion blur" issues (normal?) or lack there of on their 15s/550s etc. I truly believe I either never paid much attention prior (unlikely), or it has been such an insidious onset that it came about near un-noticed until last year etc....

So, is it even possible for something like "motion blur" to get worse on a projector? If so, what would cause it and should I be soliciting JVCs support?

Thanks all

Love DIY
KJSmitty is offline  
post #742 of 859 Old 07-11-2011, 11:39 AM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post

I talked to the service manager at the (claimed by him) one facility in the US that repairs our projectors and that is in California. They have "several" projectors waiting for optical blocks. They could not answer why they are telling you that yours has been serviced. They have told me on different occasions that the the part will be available to them on 7/27, then the 21st, then on the 12th. I assume they are actually lying to you and me and are desperately hoping the parts come in while they can blow us off. I just assume they are trying to give me hope that the projector will be finished soon.

Just spoke with the service manager and he said they are shipping it back to me today. I insisted it be overnight, and he said they already scheduled it to be sent overnight delivery, and he will contact me back once a tracking number has been issued. He said the delay was due to an extended quality control. I should have asked him this when I spoke with him, but when he calls back with my tracking number I will inquire about the delay everyone else has experienced and how I jumped the line.
thadoneternal is offline  
post #743 of 859 Old 07-12-2011, 04:51 PM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by joatmon View Post
I talked to the service manager at the (claimed by him) one facility in the US that repairs our projectors and that is in California. They have "several" projectors waiting for optical blocks. They could not answer why they are telling you that yours has been serviced. They have told me on different occasions that the the part will be available to them on 7/27, then the 21st, then on the 12th. I assume they are actually lying to you and me and are desperately hoping the parts come in while they can blow us off. I just assume they are trying to give me hope that the projector will be finished soon.
So, the one thing they lied about was sending my projector back overnight, and calling me with the tracking number. They did email me the tracking number and it was shipped out Monday as promised, just by ground and I will have it back on Thursday.

I called rep. to inquire about the McAllen center no longer being listed for repairs and they said all repairs are being directed to the California location, but any products that come into the McAllen area will still be repaired. I am just assuming that their systems are not able to look at each others part inventory or else they could have overnighted parts to repair equipment sent to the cali location instead of holding them for weeks on end.

I'll update on the quality of repair once I get the projector back mounted.
thadoneternal is offline  
post #744 of 859 Old 07-13-2011, 02:29 PM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by thadoneternal View Post

So, the one thing they lied about was sending my projector back overnight, and calling me with the tracking number. They did email me the tracking number and it was shipped out Monday as promised, just by ground and I will have it back on Thursday.

I called rep. to inquire about the McAllen center no longer being listed for repairs and they said all repairs are being directed to the California location, but any products that come into the McAllen area will still be repaired. I am just assuming that their systems are not able to look at each others part inventory or else they could have overnighted parts to repair equipment sent to the cali location instead of holding them for weeks on end.

I'll update on the quality of repair once I get the projector back mounted.

My Status on JVCs tracking site changed from "Waiting Parts" to "Started". Updated POST #718
joatmon is offline  
post #745 of 859 Old 07-14-2011, 07:27 PM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Updated Post #718. JVC has finished my repair and has assigned a tracking number. Hopefully it gets shipped out tonight or tomorrow, and I'll have my projector back next week.
joatmon is offline  
post #746 of 859 Old 07-18-2011, 06:23 PM
Senior Member
 
Drew_N's Avatar
 
Join Date: Feb 2001
Location: Chester County, PA
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
To those that have had pink/purple issues recently - I think I have just joined the club. My ~20 month old RS15 that just randomly started having pink on the right side. Can anyone confirm this is what they experienced? Did JVC have you try anything or just ship it back?
LL
LL
Drew_N is offline  
post #747 of 859 Old 07-19-2011, 04:33 AM
Member
 
arkay's Avatar
 
Join Date: Jan 2003
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Drew_N View Post

To those that have had pink/purple issues recently - I think I have just joined the club. My ~20 month old RS15 that just randomly started having pink on the right side. Can anyone confirm this is what they experienced? Did JVC have you try anything or just ship it back?

Yes that is exactly what mine looks like--lucky for you it is still under warranty. Mine is out by 4 months. How many hours do you have on your RS15?
arkay is offline  
post #748 of 859 Old 07-19-2011, 11:34 AM
Member
 
thadoneternal's Avatar
 
Join Date: Aug 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Drew_N View Post

To those that have had pink/purple issues recently - I think I have just joined the club. My ~20 month old RS15 that just randomly started having pink on the right side. Can anyone confirm this is what they experienced? Did JVC have you try anything or just ship it back?

That is exactly the issue I had, except on the left side of the screen. I had around 1400 hours on the unit when I started to notice it back in March. Waited until the end of June to send it off. Took them 1 day to fix, but 1 1/2 weeks to send it back. I would suggest you send it back because the issue is caused by the optical block which has to be replaced.

So, far I have not seen any further defects after the repair. Of course, it would probably take another 1400hrs for me to notice any other issues, but I will be out of warranty by then, and hopefully upgrading to a newer model by then.
thadoneternal is offline  
post #749 of 859 Old 07-19-2011, 01:54 PM
Member
 
joatmon's Avatar
 
Join Date: Dec 2004
Location: Texas, US
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Make sure you talk to JVC before you send in the projector. They are having trouble procuring the parts to fix it. My saga continues on post #718
joatmon is offline  
post #750 of 859 Old 07-19-2011, 03:41 PM
Senior Member
 
Drew_N's Avatar
 
Join Date: Feb 2001
Location: Chester County, PA
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well, I suppose I'm glad its a known issue. I'm having trouble getting an actually person on JVC's support line. What number and which options did you choose? Did you have to log it before sending it?

I also see two warranty addresses, one for general service and another for RS projectors. I'm assuming you sent to the projector one, but haven't received the 72 hour turnaround?
http://support.jvc.com/consumer/supp...ts/fscform.pdf

http://support.jvc.com/consumer/supp...erviceform.pdf

I have about 950 hours on my projector.
Drew_N is offline  
Reply Digital Hi-End Projectors - $3,000+ USD MSRP

Tags
Jvc , Oppo Bdp 83 Blu Ray Player

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off